locked
Windows Update Loop - Win 7 Pro - x64 :: Error 80071A91 RRS feed

  • Question

  • Hi, I've been referred to this forum by the Microsoft community from this post: answers.microsoft.com  /en-us/windows/forum/windows_7-system/windows-update-loop-win-7-pro-x64-error-80071a91/b17c5bc5-7977-4f8b-9b45-ecb265886381 (same as below)

    Any assistance is appreciated. dave_ned at hotmail.com.

    -------------

    Hi,

    "There is a system repair pending which requires reboot to complete. Restart Windows and run sfc again"

    I've got the error (80071A91) that others have experiences while trying windows update and for the life of me I cannot get the updates to install.

    Looking for the past 4 hours via Google, trying different recommended things and still no luck

    http://answers.microsoft.com/en-us/windows/forum/windows_vista-windows_update/unable-to-install-updates-getting-error-code/27a21977-f964-4376-bfab-2f29ea127c6a

    # SFC /scannow causes the "repair status message" and asks for reboot.

    I've downloaded fix-it, tried booting into a system repair/restore disk using command line to run

    #sfc /scannow /offline....

    using the dispart to LIST VOLUMES  (based on this http://mikemstech.blogspot.com.au/2011/12/how-to-perform-offline-system-integrity.html )

    I've tried #fsutils resourse set autorevert=true (or something, can't find the exact post as I've rebooted so many times)

    I've tried dismc.exe (or similar without success)

    Basically I'm stuck with these updates (~10 of them) always sitting there downloading, installing every time I shut down the PC.

    Running a system repair disk created in windows still does not allow #sfc /scannow....

    My Last system restore was 04/08/14 and I cannot even restore the system to this point as the restore fails and asks to remove itself once I restart the system.

    Details:

    OEM version of windows purchased legally and genuine microsoft logo in system dashboard.

    Intel Core I5 -3330

    16GB RAM

    Windows 7 Pro - 64bit OS

    Service pack 1

    **NOTE** I have the C drive hooked up in RAID 0. Two(2) * 60GB SSD disks in RAID 0 used as C: via BIOS RAID

    Secondary storage disk a D:

    Been working and updating fine for the past 5-6 months.

    I have the Optical drive setup as O: and a Daemon tools virtual drive as drive E:

    While running DISKPART and using LIST VOLUME I see this:

    currently the system seems to have lost all update history

    Any information or help on this is appreciated. I don't want to reformat and reinstall, I don't really want to 'repair' and wipe my current software installation so I'm hoping there is a way.

    Anyway I can get the 'pending state' removed.?

    Thanks in advance

    David

    Monday, August 18, 2014 11:16 AM

Answers

All replies

  • Hi,

    Firstly, from the Recovery Console command prompt, enter the following :

    dism.exe /image:C:\ /cleanup-image /revertpendingactions

    After that, reboot the computer in Safe mode to run sfc /scannow command to check the result.

    Meanwhile, I would like to suggest you reset the Windows Update components for test:

    How do I reset Windows Update components?

    http://support.microsoft.com/kb/971058


    Karen Hu
    TechNet Community Support

    Tuesday, August 19, 2014 8:38 AM
  • Hi thanks for the reply. I seem to be doing all of these things but not in a specific order or sequence. I will try your suggestions.

    Firstly, here is a result of the fixit program which I also ran earlier. (can't attach image due verification issues and not dealing with that problem as yet [due to old email not updatable...])

    Results of FIXIT (2 errors, rest 'fixed')

    • Service Registration is missing or corrupt
    • Windows Update error 0x80070057(2014-08-20-T-09-02-23P)

    The rest gave OK's (Problems installing recent updates fixed, problems installing recent updates etc)

    I will now follow your instructions using dism.exe and safemode above

    Wednesday, August 20, 2014 11:14 AM
  • Hi, I've rebooted into Repair mode (Console), (because repair said windows is installed on E:) run dism.exe /image:E:\ /cleanup-image /revertpendingactions

    This gave a message about small scratch space but did say something out a fix. Upon reboot into safemode with console I received the same message 

    "C:\Windows\system32>sfc /scannow

    Beginning system scan.  This process will take some time.

    There is a system repair pending which requires reboot to complete.  Restart Windows and run sfc again."

    I then rebooted and tried SCF again, no luck... Same message, same updates still sitting there.

    Partition info: (as mentioned earlier C is in RAID 0 with 2 SSD disks)

    DISKPART> list volume

      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
      Volume 0     O                       DVD-ROM         0 B  No Media
      Volume 1     E                       DVD-ROM         0 B  No Media
      Volume 2         System Rese  NTFS   Partition    100 MB  Healthy    System
      Volume 3     C                NTFS   Partition    111 GB  Healthy    Boot
      Volume 4     D   GB320        NTFS   Partition    298 GB  Healthy

    Wednesday, August 20, 2014 11:46 AM
  • Hi,

    According to your volume information, your system volume is C instead of E.

    Thus please run that command using C letter for test.


    Karen Hu
    TechNet Community Support

    Thursday, August 21, 2014 2:22 AM
  • Hi, The reason it is set as C: is that it is correctly mounted in a normal boot.

    The reason I mentioned E: was that when I run system recovery-> to run dism.exe this boots in X: and when I do #diskparrt -> list volume the same drive that is shown as C: above is listed as E:

    Therefore: 1. I cannot run the C: command as I get "Error 2 - cannot find disk image"

    2. I cannot run dism.exe in standard 'Elevated level command prompt" as I get an Error 7 - Imgae option points to a running windows installation.

    Sorry but I'm stuck...

    Thursday, August 21, 2014 11:47 AM
    • Marked as answer by Michael_LS Tuesday, September 9, 2014 8:02 AM
    Wednesday, August 27, 2014 2:04 AM