none
unable to run cmdlets on FastSearch Server for SP2010 - DB Connection Error?? RRS feed

  • Question

  • Hi,

    I have SP2010 installed on Server-A. FastSearchServer DB and Sharepoint 2010 DB are on Server-A as well. And, Fast Search Server is installed on a separate server (Server-B).

    I'd like to run some cmdlets on fast search server. I logged in with the same user account used when installing Fast Server, opened Fast Server Powershell as admin, ran the cmdlet, and got an error:

    DB on Server-A has all protocols enabled (TCP/IP, named pipes and all those) - if this matters at all.

    PS C:\> Get-FASTSearchMetadataFullTextIndex
    Get-FASTSearchMetadataFullTextIndex : An error occurred while connecting to or
    communicating with the database.
    At line:1 char:36
    + Get-FASTSearchMetadataFullTextIndex <<<<
      + CategoryInfo     : OperationStopped: (:) [Get-FASTSearchMetadataFul
      lTextIndex], AdminException
      + FullyQualifiedErrorId : e103: An error occurred while connecting to or communicating with the database.,Microsoft.SharePoint.Search.Extended.Administration.Commandlets.Schema.GetMetadataFullTextIndexCommand
    
    
    Friday, January 14, 2011 11:19 PM

All replies

  • Did you give the FS4SP user access at the database as described at MSDN? Giving the user read/write permissions to the database.

    Is your user a member of the local FS4SP server group FASTSearchAdministrators?

    Have you checked the firewall settings of you FAST server? (Can you for instance do a telnet to port 1433 on the SQL server, which is the default TCP port it listens to, and get a connect?)

    Regards,
    Mikael Svenson


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    Sunday, January 16, 2011 9:31 PM