locked
windows installer 4.5 installation error RRS feed

  • Question

  • Hi

    I tried to install Dotnet framework 3.5sp1 or 4.....It display message install windows installer 3.1 or 4.5 before install dotnetframework...........Then I tried to install windows installer 3.1 or 4.5 .....But there is no response of the installer file.........I didnt understand what was going on.........which requirements need to install windowsinstaller 3.1 or 4.5....

    My system configuration

    Ram : 500MB

    Hard disk : 250 MB

    OS : windows XP

    Is there any solution to me?

    Saturday, May 5, 2012 8:24 AM

Answers

  • I suppose you are running Windows XP SP2 as Windows Installer 3.1 v2 is included with Windows XP SP3.

    It is highly recommended that you update to Windows XP SP3 because support for Windows XP SP2 has ended. Moreover, Windows XP SP3 is a minimum system requirement for Microsoft .NET Framework 4. 

    In case you are already running Windows XP SP3 (right-click My Computer > Properties to check) and still receive the message that you need Windows Installer 3.1 or above is required, then open the Command Prompt and run the following command-

    sfc /scannow

    Wait for it to complete. Also please check Windows Installer version installed (Start menu > Run > type msiexec /? > Press Enter). A dialog box will appear and in the first line, the version is displayed.

    • Marked as answer by kv222 Thursday, May 10, 2012 11:06 AM
    Saturday, May 5, 2012 10:12 AM

All replies

  • I suppose you are running Windows XP SP2 as Windows Installer 3.1 v2 is included with Windows XP SP3.

    It is highly recommended that you update to Windows XP SP3 because support for Windows XP SP2 has ended. Moreover, Windows XP SP3 is a minimum system requirement for Microsoft .NET Framework 4. 

    In case you are already running Windows XP SP3 (right-click My Computer > Properties to check) and still receive the message that you need Windows Installer 3.1 or above is required, then open the Command Prompt and run the following command-

    sfc /scannow

    Wait for it to complete. Also please check Windows Installer version installed (Start menu > Run > type msiexec /? > Press Enter). A dialog box will appear and in the first line, the version is displayed.

    • Marked as answer by kv222 Thursday, May 10, 2012 11:06 AM
    Saturday, May 5, 2012 10:12 AM
  • Hi,

    Try to download Microsoft Fixit tool and try.

    http://fixitcenter.support.microsoft.com/Portal/FindSolutions/1173

    Download the (ndowsXP-KB942288-v3-x86.exe)

    http://www.microsoft.com/en-us/download/details.aspx?id=8483


    Mohammed Imtiyaz Ali

    Saturday, May 5, 2012 12:39 PM
  • Thank you Swapnil99pro,

    I update to windows xp sp3. Dotnet framework 4 was installed. My application is running into my pc.

    Tuesday, May 8, 2012 9:00 AM
  • Thank you Swapnil99pro,

    I update to windows xp sp3. Dotnet framework 4 was installed. My application is running into my pc.

    It is requested that you mark the post that solved your problem as the answer. 
    Tuesday, May 8, 2012 9:04 AM