locked
Issue with User Roles RRS feed

  • Question

  • Hello all,

    I'm currently setting up Service Manager 2012 R2 and everything seems to be fine until I wanted to change what people could see within Service Manager.

    I have a custom Incident Resolver role which limits certain users to what views they have, but for some weird reason the changes within that role do not get enforced until I manually restart the System Center Data Access Service. It worked fine last week, but this week its stopped working.

    Has anyone else come across this and perhaps know a way of fixing this please?

    Any help would be much appreciated.

    Many thanks,

    Phil

    Thursday, August 6, 2015 1:10 PM

All replies

  • Just to provide some more information.

    We have Service Manager 2012 R2 with Update Rollup 6.

    The consoles run the latest version, Update Rollup 6.

    Is there a waiting time after you adjust a user role or are those changes instant?

    I've checked the event logs and cannot find any errors.

    To test the permissions from the user role, I close the console and restart it to log in with the test account.

    Tried to clear the cache from the console which didn't help.

    Any tips from anyone? Kind of at a loss here and don't fancy having to reinstall it all :(

    Thursday, August 6, 2015 6:35 PM
  • Hi,

    Have you seen this article?

    Service Manager role based security scoping

    http://scug.be/scsm/2010/03/21/service-manager-role-based-security-scoping/

    Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 7, 2015 6:27 AM
  • Hi,

    Yes, I've followed that article.

    I've just cleared all custom user role and recreated it.

    Selected all management packs, all queues, all configuration items, all catalog items, all tasks, all form templates but selected certain views.

    Loaded up the console on my laptop which was reinstalled and upgraded to Update Rollup 6 and it still shows what was set in an old user role.

    I'm a bit lost now as to what is can be.

    Any ideas please?

    Many thanks,

    Phil

    Friday, August 7, 2015 7:42 AM
  • Hi,

    One of my customer also have the same problem,

    We forwarded this issue to Microsoft premier case, and waiting them solution.

    But you can check this,

    Do some changes on incident resolver group, and open console with one of member that group on SCSM Management server. (run scsm console as different user) and check changes is visible or not. If changes are visible on console, you must check client computer.

    Fırat


    • Edited by Firat YASAR Friday, August 7, 2015 11:07 AM
    Friday, August 7, 2015 9:20 AM
  • Hi,

    How do you run the scsm console as a different user on the server?

    As a test, I reverted back the VM to before I installed Update Rollup 6 and any changes to the User Role were instant. Performed another update to Update Rollup 6 and then the changes stopped again.

    Thanks,

    Phil

    Friday, August 7, 2015 9:51 AM
  • Hi,

    Some more testing done.

    I've tested running the console on the server as my test account.

    First initial login into SM console and it shows the correct Views.

    If I remove one of the Views (untick the check box) and then launch the console as the test user, it doesn't change the Views and its still there.

    Also tried this using the built in Incident Resolver group.
    Moved the user from my custom group into the default Incident Resolver group and the user is still seeing the Views specified from my custom group. The default Incident Resolver group has all Views selected (All views can be accessed.).

    Any other tips as it looks like I am going to have to revert back to an older snapshot.

    Thanks,

    Phil


    • Edited by Bugzi Friday, August 7, 2015 10:23 AM Forgot to include more testing
    Friday, August 7, 2015 10:19 AM