locked
Connecting to a new router has seemingly caused a problem with scvhost.exe and Windows Update. RRS feed

  • Question

  • I've encountered a problem that seemingly defies logic and common sense. The problem is Windows Update, running under one of the svchost.exe entries in task manager is using 100% CPU and 100% RAM.

    I'm even struggling to find a way to explain this because its so bizarre but here goes... and I'll use a timeline.

    1/ Early 2014 and Vista is clean installed and brought up to date with all installs successfully deployed. Acronis images are made along the way.

    2/ This 'perfect' image is brought into service and programs/files added. Its been in use ever since with regular backups made up to the present. I have those backups. There is also not a single failed update from day one.

    (These backup are fine, I regularly use them as I evaluate stuff... for example I might go and try W10 Tech Preview for a week or two and then revert back to the last Vista image)

    Now for the real problem.

    3/ A few days ago I had to replace my router due to a hardware problem with it. As I connected my Vista PC I noticed the 100% CPU/RAM usage issue. All had been well up to the instant the router was replaced. The problem appears to be svchost.exe with task manager showing it to be the culprit. Clicking through the processes I find that stopping Windows Update stops the high resource usage.  Windows Update also will not actually update now although Defender will if run manually from the Defender GUI.

    Where this gets bizarre is that even going back to my 'day one' Disk images gives the same problem. That absolutely defies logic. It is as though the OS has been 'tagged' in some way by the old router................

    I've spent many many hours on this trying everything from MS 'Fix Its' to trawling the registry, running aggressive cleaning regimes... oh and it does all this on a friends router and also connecting to 'unsecured' networks in the area. I've run file checks at command prompt level from an install disc and all is well. I tried a 12 point MS suggestion of registry hacks, reregistering DLL's etc etc. Nothing works. All I can do at the moment is disable Windows Update in MSconfig. Also as a test, I tried installing one of Augusts updates manually from the stand alone installer. I get a message that the update is not applicable... so I tried some more. Same result. Truly bizarre, and yet all had been perfect up to the new router install. Tried resetting and disabling the Firewall. Same. 

    It really is as if the OS has been corrupted in some way from day one and yet worked fine on the router I had had for a few years. How can that be possible ?

    Has anyone ever encountered anything remotely like this before ? Are there any hidden file locations that could cause Vista to complain when it sees connection to another router ?

     

     

      

     

    Sunday, August 16, 2015 6:19 PM

All replies

  • Start with Process Monitor and Process Explorer from Sysinternals. This will allow for deeper dig into processes:

    https://technet.microsoft.com/en-us/sysinternals/bb545027.aspx

    HTH

    Milos

    Sunday, August 16, 2015 6:43 PM
  • Thanks Milos. I'll have a look at that tomorrow all being well.
    Sunday, August 16, 2015 7:13 PM
  • I've had a quick run through with Sysinternals and that confirms windows update is the problem. Being new to Sysinternals I'm not sure how to proceed to track down the problem. These from Task Manager. Sysinernals shows the same basic issue. 

    Monday, August 17, 2015 1:20 PM
  • I've been all this time working on this issue, sadly with no luck, but...... I have made a startling discovery.

    I did another clean install of Vista yesterday and promptly installed SP1 and SP2 from the stand alone packages (as I did two years ago with the main image). This latest install also fails with the same 100% CPU and RAM usage due to Windows Update.

    So now I take the same base image used above (before SP1 and SP2 were installed) and that WILL correctly check for and install updates.

    Question... has something fundamental changed within Windows Update within the last month and it is some such change that is rendering all my previously good images as faulty. In other words some bizarre and huge coincidence.

     

      

     
    Thursday, August 20, 2015 2:10 PM
  • See,

    MS Forums


    • Edited by Mooly01 Thursday, August 20, 2015 2:21 PM
    Thursday, August 20, 2015 2:21 PM