locked
Spell Check not running on Outlook 2010 RRS feed

  • Question

  • Spell Check option is set check spelling before sending however, spell check is not running.
    Friday, March 19, 2010 4:42 PM

All replies

  • Are you by chance entering your message in the signature section of the message?  Spell check doesn't check the signature portion.
    Brian Tillman [MVP-Outlook]
    Friday, March 19, 2010 4:57 PM
  • Hi,

    This issue maybe caused by without installing with the following Microsoft Office programs:

    • Microsoft Word
    • Microsoft Excel
    • Microsoft PowerPoint
    If you do not have one of these programs installed, this feature maybe not available.
    Monday, March 22, 2010 7:53 AM
  • Hi,

    This issue maybe caused by without installing with the following Microsoft Office programs:

    • Microsoft Word
    • Microsoft Excel
    • Microsoft PowerPoint
    If you do not have one of these programs installed, this feature maybe not available.

    Spell check is included with Outlook, no need for the other office products. Check before sending should always work; some spell check as you type features require Word.

    Diane Poremsky [MVP - Outlook]
    Outlook Tips: http://www.outlook-tips.net/
    Outlook & Exchange Solutions Center: http://www.slipstick.com
    Monday, March 22, 2010 1:01 PM
  • Diane,

    I have the same problem with Outlook 2010. Spellcheck is not working in Outlook and Word 2010
    My test sentence is: "the quenn is joung"
    Grammar check is coming back with the should have capital T which is ok but otherwise it believes
    everything is correct.

    As a German person in the US this feature is one of the most important ones I need  :-(

     

     

    Tuesday, May 4, 2010 4:27 PM
  • Any news regarding this issue... Upgraded Outlook 2007 to Outlook 2010, and now er do not have any Spelling or Grammer correction running. We tried both the Eng and DE versions, same fault! Auto correction does not work either..... Please help...
    Tuesday, May 25, 2010 1:40 PM
  • Check to see if the following registry entry exists, and if yes, please take a backup of this key and delete the entry.
    HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override\en-US

    - Thanks, Jinesh.
    • Proposed as answer by anthrological Monday, November 22, 2010 9:40 PM
    Wednesday, May 26, 2010 4:58 AM
  • Microsoft does not have a fix for this.  Thanks for spending $500.00 with me on a faulty program.  I have to reread all emails and documents and do it the old school way.  That's the Microsoft way.  

     

    Correct me if I'm wrong.

     

    No override, no Outlook Shared Features, no fix? 

    Friday, February 4, 2011 2:06 PM
  • There is nothing like that in my registry.  Isn't this sort of a major error for Outlook?

     

    Anything else you can suggest?

     

    Thansk! 

    Friday, February 4, 2011 2:07 PM
  • Bill, can you come to my work and fix this?
    Friday, February 4, 2011 2:08 PM
  • Sorry, Brian.  Can you come to my work and fix this?
    Friday, February 4, 2011 2:08 PM
  • There is nothing like that in my registry.  Isn't this sort of a major error for Outlook? 


    You mean this: HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override\en-US

    <wrong>If it doesn't exist, add it.</wrong>

    Oops - that's bad advice as you should be deleting it to fix this problem. <g>

    The usual causes of spell check failing is typing in the sig block (right click on the mispelled word - what menu do you see?) or this key is corrupt and it needs to be deleted. (http://www.slipstick.com/emo/2009/up090611.htm#3)



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    • Proposed as answer by Ray Watters Tuesday, March 22, 2011 7:51 PM
    Friday, February 4, 2011 2:18 PM
  • I'm having the same issue, sometimes it works sometimes it doesn't.  Today it won't work at all.  I've spent hours trying to figure it out.

     

    Tuesday, March 15, 2011 7:26 PM
  •  if you recently upgraded to Outlook 2010 you will no longer have the auto correct options.   To fix this all you have to do is copy winword.exe to the office14 folder.
    Example:
    Copy Winword.exe from here C:\Program Files\Microsoft Office\Office12\
    to
    C:\Program Files\Microsoft Office\Office14
    Reason this happens: Outlook is looking for its own editor which is word but since we upgraded only Outlook there is no winword in the directory and it fails. If running office 2003 browse to its folder and if all fails just search for winword.exe and copy.
    Sunday, April 3, 2011 9:04 AM
  •  if you recently upgraded to Outlook 2010 you will no longer have the auto correct options.   To fix this all you have to do is copy winword.exe to the office14 folder.

    Note that this hack applies to autocorrect not working, not spell check on send not working or other issues where it sometimes works and sometimes doesn't. Also, if you have any sort of problems with outlook, before asking for help, you need to delete the copy of winword.exe  and verify the problem still exists - hacks like this can have unintended consquences (plus it puts outlook into an unsupported mode).

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Sunday, April 3, 2011 12:51 PM
  • Thank you -- I found this in my registry, deleted it and spell check is now working in Outlook for me.

     

    Monday, April 25, 2011 1:54 PM
  • I agree, adding this toteh registry is bad advice but not completely off-track.

    I have two computer which I work with side-by-side. One computer is running Windows XP and the other runs Windows 7. The Windows XP computer was upgraded from Office 2003 Small Business Edition to Office Pro Plus 2010; the Windows 7 computer has a fresh install of Office Pro Plus 2010.

    On the Windows XP computer I took the previous advice and removed the contents of the HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override key (please note I kept the Override key itself, the key simply has no other settings within it). Once I did this, my auto-correction worked perfectly.

    On the Windows 7 machine I experienced the same problem so I went to go do the same thing in the registry there. To my surprise, there was no Override key listed under HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0. In a spark of insight, I decided to create the key, a blank key named Override. I then closed the registry and opened Outlook and lo and behold, the auto-correct worked.

    Perhaps the absence of the key is what is causing the problem. Perhaps Office looks for the key but doesn't react properly when it discovers that the key is missing. It is also possible that certain settings contained in the key (possibly left from previous versions of the software) confuse the Override settings if they are incompatible or legacy to Office 2010.

     

    Wednesday, June 1, 2011 8:09 PM
  • I do not understand why this problem has existed for so long and Microsoft has not fixed it.  Diane Poremsky [MVP - Outlook], you seem to be a BFD, why hasn't it been fixed?  Why should people who should not be fooling in the registry need to deal with this?

    Thoughts?

    Monday, June 6, 2011 11:51 AM
  • I do not understand why this problem has existed for so long and Microsoft has not fixed it.  Diane Poremsky [MVP - Outlook], you seem to be a BFD, why hasn't it been fixed?  Why should people who should not be fooling in the registry need to deal with this?

    Thoughts?


    I haven't checked, but there might be a "Mr Fix it" that removes the override key. It's not something that they will release a hofix for because it doesn't affect many people - and depending on the cause, may not need a hotfix.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Monday, June 6, 2011 12:16 PM
  • Just wanted to say that the registry hack worked for me.

    Thanks

    Thursday, June 30, 2011 9:43 PM
  • great and very simple fix for auto-correct not working with Outlook 2010, thanks very much indeed
    Thursday, July 21, 2011 8:27 AM
  • Brian, You are a bang on... I have had this highly frustrating issue for months now and after reading your email realise that every email I write is in the signature section. Thank you. A. Ditz

    Tuesday, September 20, 2011 9:13 AM
  • I have noticed that if I use Stationary then autocorection and spell checking does not work.

    Any Idea for this?

    Thursday, October 20, 2011 12:02 PM
  • Is it one of the stationeries shipped with outlook or a custom stationery?

    Did you check the styles used in the stationery and see if they are marked to skip spell check?



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, October 20, 2011 1:42 PM
  • This partially worked for me.  It fixed the Auto Cap feature for first letter of a sentence.  But, it does not auto-correct spelling errors.
    Saturday, October 29, 2011 12:21 AM
  • iabbass - Thank You.  I did the Winword.exe copy.  This partially helped.  Auto capitalization now works.  But, auto correct still does not.
    Saturday, October 29, 2011 1:55 PM
  • This worked for me

    Thanks

    Wednesday, February 1, 2012 9:43 PM
  • I would like to thank Jinesh for the note on the deleting the registry key.  None of the other solutions worked (I tried the suggested solutions before this one and many others).

    I would add a note: remeber to close all Office 2010 programs before deleting the key (and don't forget the backup!).

    -Regards, Barbara


    • Edited by BarbaraLloyd Thursday, November 29, 2012 1:25 AM
    Thursday, November 29, 2012 1:24 AM
  • i think i am also writing in signature area. plz tell me how do i check if i am writing in siognature area and how do i change it.
    Friday, January 4, 2013 8:53 AM
  • how do i check it?
    Friday, January 4, 2013 9:07 AM
  • I found a work-around for this problem

    On outlook Message window Click on Review Tab > Spelling and Grammar >Options>Custom Dictionaries > on Dictionary Language choose >English (U.S) instead of all language.

    That's it !!!

    Happily ever after!!

    Monday, July 15, 2013 7:25 AM
  • Thanks a lot, Diane solution works!

    Avatar of Diane Poremsky [MVP]
    • Proposed as answer by ShanDSN Monday, October 14, 2013 6:03 PM
    • Unproposed as answer by ShanDSN Monday, October 14, 2013 6:04 PM
    Wednesday, August 28, 2013 9:56 AM
  • Pretty easy to do:

    File > option > Mail > check the box that says "Always check spelling before sending".

    Hope this helps.

    Monday, October 14, 2013 6:05 PM
  • Pretty easy to do:

    File > option > Mail > check the box that says "Always check spelling before sending".

    Hope this helps.

    on Outlook 20102
    Monday, October 14, 2013 6:06 PM
  • This fixed our issue having tried many other things.
    • Edited by bbuyack Wednesday, November 27, 2013 5:08 PM
    Wednesday, November 27, 2013 5:07 PM
  • Working from Remy2009 solution I found a work around along similar lines

    I'm using Office Home & Business 2010, so both Outlook and Word are running 2010 versions.  OS is Windows 7 Pro 64 Bit

    Basically it looks like you need English (US) installed as an editing language even if you are not using it.  To add go to the File menu in Outlook

    File > Options > Language

    In the Table labelled "Choose Editing Languages" you should have English (US) showing as installed even if it is not enabled.  If it is not installed add it via the pulldown below the table ("Add Additional Editing Languages").  If necessary you can then set the default language as required.

     I'm using English (UK) and it now appears to be working fine.

    • Proposed as answer by Sun Kwok Friday, October 27, 2017 5:07 PM
    Wednesday, March 5, 2014 11:12 AM
  • Worked like a charm thx!
    Monday, December 29, 2014 4:40 PM
  • Thanks!

    I had a similar issue. English (US) and Alastian was setup as the languages with English (US) as default. The autocorrect was not working at all. I removed the Alastian language, stlil no effect, so added English (UK) and set it as the default, and autocorrect started working. Then I set English (US) as the default and it continued to work, this time in the correct flavor of English!

    Friday, October 27, 2017 5:09 PM
  • If you have set all of the settings correct and the issue continues, then this problem is created because you have a bloated temp file.  Navigate to the location of your Outlook mail file (e.g. - "C:\Users\username\AppData\Local\Microsoft\Outlook", where username is your account name).  Rename your current temp file, which is safer than deleting it.  Close Outlook and restart it.  A new temp file will automatically be created and your spell check will automatically run for you again.
    Wednesday, January 31, 2018 7:12 PM