locked
Updated to 1809 Now store will not load if on domain network RRS feed

  • Question

  • Today I updated to the october update to my windows 10 enterprise and i wanted to try the new "My Phone" app.  so after the update i went to the store to get it.  I was presented with the store needs to be online, but you are not.  code: 0x80072EFD.

    I spent many hours today trying everything from looking for proxy settings, disabling and renabling adapters, wsreset, manually clearing windows update, sfc scans, etc.   nothing worked

    i updated another machine  no problems at all.  but that machine was on my private testing network (basically a 192.168 network setup in my lab, but ultimately connects to the same rout able network, and all traffic has to go through the same gateway, firewalls, DNS servers, as my main machine.)  

    as a test,  i enabled a usb ethernet adpater,  connected it to the private network and disabled my "domain network" and bam the store worked like a charm!   There were no reboots, relogins or anything.  just simple adapter changes.

    put it back and it stopped working again.  So i don't think it's a user profile glitch or machine GPO.

    The store worked fine last week when i installed one note and slack.  but today it failed.  The IT staff said they made no changes to GPO, so it isn't that.  but now all of a sudden I can't get the store to run on a Domain Network Ethernet connection, but I can on a public one.   Any ideas short of reseting the OS.  I just got this machine 2 months ago and really do not want to reinstall it, just because the store doesn't want to work on this one ethernet adapter.

    Any thoughts on what to try next!

    Thursday, October 4, 2018 12:27 AM

Answers

  • Confirmed on my desktop after 1809 upgrade.

    Turning on IPv6 fixes this weird issue where some applications can connect to internet (Chrome) and others don't (Edge).

    I fixed it by simply turning on IPv6 in my network adapter properties without reboot.





    • Edited by Luc E Thursday, October 4, 2018 6:11 AM
    • Proposed as answer by Nielles Friday, October 5, 2018 6:28 PM
    • Marked as answer by Joseph Ward Friday, October 19, 2018 4:33 PM
    Thursday, October 4, 2018 6:08 AM

All replies

  • I am having the same problem and reverting to old build. None of the universal app will connect to internet. But windows apps will. Edge cannot connect but IE can.

    have you verified that it's only windows store or other apps like Money, Edge etc are also having this issue?


    Nikhil

    Thursday, October 4, 2018 5:31 AM
  • Hello,

    I believe this is due to the fact that iPv6 must be enabled on your system to run the apps. Microsoft has made this change mandatory with V1809 and IMO it is not documented yet anywhere. I got this information from my forum colleagues. So you can try enabling iPv6 and see if that helps you:

    1. Open administrative Windows PowerShell.

    2. Type Enable-NetAdapterBinding -Name "*" -ComponentID ms_tcpip6 and press Enter key.

    3. Close Windows PowerShell and check if the apps works now.

    Hope this helps!

    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    • Edited by Kapil.AryaMVP Thursday, October 4, 2018 5:51 AM
    • Proposed as answer by Tanku_L Thursday, October 4, 2018 8:35 PM
    Thursday, October 4, 2018 5:49 AM
  • Confirmed on my desktop after 1809 upgrade.

    Turning on IPv6 fixes this weird issue where some applications can connect to internet (Chrome) and others don't (Edge).

    I fixed it by simply turning on IPv6 in my network adapter properties without reboot.





    • Edited by Luc E Thursday, October 4, 2018 6:11 AM
    • Proposed as answer by Nielles Friday, October 5, 2018 6:28 PM
    • Marked as answer by Joseph Ward Friday, October 19, 2018 4:33 PM
    Thursday, October 4, 2018 6:08 AM
  • This solution did not fix a problem for me.
    The Store, Office365 still doesn't work on domain network.

    Thursday, October 4, 2018 7:55 AM
  • Same. IPv6 enabled with IPv4 preferred via registry. MS Edge and store app do not work. Occurs across 200 workstations in domain - so large sample pool.
    Thursday, October 4, 2018 6:47 PM
  • Try checking this registry setting:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters

    If DisabledComponents exists, check if it is set to 0 instead of 0xFFFFFFF

    Then reboot the computer

    That did the trick for me



    Thursday, October 4, 2018 6:56 PM
  • Confirmed working except I went to the Ethernet Adapter properties manually and rechecked the IPv6 box as opposed to using Powershell. I had disabled IPv6 since I do not use it and had to re-enable it for the Store to work. Thank you!
    Thursday, October 4, 2018 11:40 PM
  • For current issues including Edge cannot load website and Store apps issue,

    Workaround:

    Re-enable IPv6 on the network adapter.

    Change network type from private to public.

    I have submitted this situation to Microsoft via our channel.

    Let’s wait for update

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 5, 2018 8:14 AM