locked
Macro visible on one computer (Word 2010), but not visible on another (Word 2013) RRS feed

  • Question

  • Hi all.  I have a Word document I created in Word 2010 (Win 7 32-bit).  In it, I have created and saved a macro.  In Word, when I open the Developer-->Macros section, I can see the macro.  It is in "All active templates and documents."  But when I try to open that same file on another computer, running Word 2013 (and Win 7 64-bit), the macro is not visible in the file.  Can someone help me resolve/troubleshoot this issue?  I'm not a macro/VB blackbelt, so I'm sure I'm doing something stupid.

    Thanks in advance.

    Monday, November 16, 2015 3:53 AM

Answers

  • Simplest would probably be to record it again and save it in your document. Then delete it from your normal template.

    What, exactly does this macro do?

    If you are going to be working with macros, it is time you started using the Visual Basic Editor that is built into Word.

    Method 1

    When in Word, press Alt+F11. This opens the Visual Basic editor.

    Find the Normal project.

    Under that will be a NewMacros module.

    In that, you will find your macro.

    Method 2

    When in Word, on the Developer Tab under Macros find your macro and press the button to Edit it.


    Charles Kenyon Madison, WI

    • Marked as answer by cagross99 Sunday, November 29, 2015 10:27 AM
    Saturday, November 21, 2015 10:04 PM

All replies

  • This may have to do with the Trust Center settings on the second computer. By default, these will not allow macros in a document to run (or even be seen) unless it is stored in a special place or given special permissions.

    However, a more likely reason is the storage location. When you recorded the macro, where did you save it? The default location is the normal template in the newmacros module. Unless you told word to save in the document, it will not be in the document. Even then, you must save the document in the .docm rather than the .docx format.


    Charles Kenyon Madison, WI

    • Proposed as answer by Charles Kenyon Sunday, November 22, 2015 11:00 PM
    Monday, November 16, 2015 2:59 PM
  • Thanks for the info.

    >> When you recorded the macro, where did you save it?

    If I open my Word document (on my Word 2010 computer--the same computer in which it was created), and go to Developer-->Macros, I can see the macro in-question.  The "Macro in:" is set to "All active templates and documents."  I assumed that meant the macro would be stored in (and available to) all Word 2010 documents on this computer.  Am I misunderstanding that?

    Tuesday, November 17, 2015 3:33 AM
  • What do you see if you open another document on that computer? Do you still see the macro?

    Is this a .docm type document? If not, it does not contain any macros.


    Charles Kenyon Madison, WI

    Tuesday, November 17, 2015 7:32 AM
  • >> What do you see if you open another document on that computer? Do you still see the macro?

    I do indeed see the macro on every Word document on my computer.  Even Word documents that were created on another computer.

    >> Is this a .docm type document? If not, it does not contain any macros.

    These are all .docx files.  I'll try saving as a .docm and opening on my other computer.  I'll report back here.

    Tuesday, November 17, 2015 8:10 AM
  • Hi.  I hope you're still available.  I'm still having an issue.  Even when I save the document with the macro as a .docm (from my work computer--Win 7 32 bit, Office 2010), I still can't view the macro on my home computer (Win 7 64 bit, Office 2013).  On both computers, I have "Enable all macros" set in Word options.  Any ideas?
    Friday, November 20, 2015 10:01 AM
  • >> What do you see if you open another document on that computer? Do you still see the macro?

    I do indeed see the macro on every Word document on my computer.  Even Word documents that were created on another computer.

    >> Is this a .docm type document? If not, it does not contain any macros.

    These are all .docx files.  I'll try saving as a .docm and opening on my other computer.  I'll report back here.

    That you are seeing the macro in every document tells me that it is stored in your normal template, not in your document. Your recorded macro is currently stored in the NewMacros module of your normal template. Do NOT try simply copying this template to your home computer.

    Charles Kenyon Madison, WI


    Friday, November 20, 2015 6:53 PM
  • Hi.  I hope you're still available.  I'm still having an issue.  Even when I save the document with the macro as a .docm (from my work computer--Win 7 32 bit, Office 2010), I still can't view the macro on my home computer (Win 7 64 bit, Office 2013).  On both computers, I have "Enable all macros" set in Word options.  Any ideas?

    Again, where is the macro stored? If you saved it in the normal template (which is the default save location), it does not travel with your document, regardless of the format of the document. It is not a part of the document. This is an option you see when you first begin recording the macro (set the name for the macro).

    You should NOT have enable all macros set in Word except in limited circumstances.


    Charles Kenyon Madison, WI


    Friday, November 20, 2015 6:56 PM
  • Thanks for the reply.

    >> Again, where is the macro stored?

    I want to track that down.  But how do I ascertain that?  

    >> You should NOT have enable all macros set in Word except in limited circumstances.

    Gotcha.  I've only enabled it in this case as a test.

    Saturday, November 21, 2015 9:27 PM
  • Simplest would probably be to record it again and save it in your document. Then delete it from your normal template.

    What, exactly does this macro do?

    If you are going to be working with macros, it is time you started using the Visual Basic Editor that is built into Word.

    Method 1

    When in Word, press Alt+F11. This opens the Visual Basic editor.

    Find the Normal project.

    Under that will be a NewMacros module.

    In that, you will find your macro.

    Method 2

    When in Word, on the Developer Tab under Macros find your macro and press the button to Edit it.


    Charles Kenyon Madison, WI

    • Marked as answer by cagross99 Sunday, November 29, 2015 10:27 AM
    Saturday, November 21, 2015 10:04 PM
  • >> What, exactly does this macro do?

    It locks the numbering in the document.

    >> Simplest would probably be to record it again and save it in your document. Then delete it from your normal template.

    Right.  Then when I work on the document on another computer, the macro is available.  When I get back to my work computer I'll try out your suggestions and re-try saving/opening the document on my home computer.

    Thanks again for your help so far.

    Saturday, November 21, 2015 10:19 PM
  • Just to let you know, I finally was able to test everything and it is all working as expected.  I'm now saving the macro in the document, and saving the document as a .docm.  Thanks again.
    Sunday, November 29, 2015 10:27 AM