none
DPM 2007 Backup Tape Says Free but Report says 4 Recovery Points Created on Tape RRS feed

  • Question

  • DPM 2007 on W2k3 Std 32-Bit. colocation and Encryption enabled

    Not sure what has happened. Normally I see what is on my LTO4 tape before ejecting. But both Identify Tape and Inventory Library say my tape is Free contains Data.

    I see nothing in Event viewer and system has been working flawlessly for many months.

    Recovery shows no backup on Saturday when the tape ran, shows last Saturday and all the Disk backups each day.  Not even Disk for Saturday.  It is possible the server was hung as Windows Updates were run at 4AM and tape is scheduled for 1PM Saturday.

    Is there someway to rerun Tape Backup as there were no alerts saying tape backup failed?

    Status Report say one warning and no Criticals for the week.  60 Recovery Points to Disk and 4 to Tape as it should be.


    Peter Jam

    Monday, May 19, 2014 3:14 PM

All replies

  • HI,

    Disclaimer - the below powershell script has not been tested on DPM 2007 servers.

    Although you cannot pick the recovery point date in the past to make a new recovery point from, you can run the DPM Power shell script in this post to select a recovery goal to make a current backup for.  The recovery point date would be that of the latest disk based recovery point for any goal selected.

    http://social.technet.microsoft.com/Forums/en-US/dpmtapebackuprecovery/thread/4d9e8f47-33b6-4f57-82fa-6d25f6c43d80


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, May 19, 2014 5:48 PM
    Moderator
  • Mike,

    I did not get any errors, but it looks like I did not have a job scheduled.  See below for window of Powershell response:

     The list below shows all scheduled backup to tape jobs (short term and long ter
    m)

     For optimun output, set PoweShell Width for screen buffer size  to at least 110


         Protection Group               Term       Goal            Tape Label
         ------------------------------ ---------- --------------- --------------
     1 -

    Which job(s) you want to run? If running more than one job enter numbers separat
    ed by space: 1 2

    You selected to run 1 job(s). You can monitor job(s) progress via DPM Administra
    tor Console
    PS C:\Program Files\Microsoft DPM\DPM\bin>

    Since it did not list a Protection Group only the number 1 I don't think it worked for DPM 2007.  I have 2 PG so I used 1 2, but it only tried to run 1.

    No Tape Backup running in Administration Console.  But there is a synchronization running and a recovery point for same in waiting.  maybe after it finishes?


    Peter Jam

    Nope

    Mike reset the tape schedule for 10AM today.  It failed with the error below.  Not sure if it is software or hardware.  But I powered off the tape and powered it back on.  Part of the backup ran and then tape malfunctioned again. could not read the tape, when I said view contents it said it had to be re-catalogged but that would not work. (Bad tape?)  So put another tape in and it is running again.

    Description:        Library drive Quantum LTO 4 Tape Drive in Quantum LTO 4 Tape Drive is not functioning and library jobs may fail until the drive is repaired.  The drive is not functioning for the following reason:

     (ID 3303)

                    DPM encountered a critical error while performing an I/O operation on the tape SQL2005-00000008 (Barcode - ) in Drive Quantum LTO 4 Tape Drive. (ID 30101 Details: Data error (cyclic redundancy check) (0x80070017))

    What do you think, hardware, tape or software.

    • Edited by pjamme Tuesday, May 20, 2014 5:03 PM more updates
    Monday, May 19, 2014 6:20 PM