locked
Exchange 2010 Error for send on behalf with linked mailboxes RRS feed

  • Question

  • Hi,

    we have two domains, one hosting the mailserver the other the users, when one user tries to give another send on behalf in the outlook client. If I do so in a regular mailbox, I can see instantly every user I granted this right, in the linked mailbox nothing happens and the user gets the error, that he has no rights to send on behalf.

    I have seen several threads about the topic, but nothing of use in there. Has it got something to do with the circumstance that the ad-account is per default disabled??

    I also checked the security settings for SELF, they are ok

    anybody an idea

    Friday, January 27, 2012 2:07 PM

Answers

  • if you are using exchange 2007 or 2010,

    open up exchange management console, goto Recipient configuration > mailbox, right click on shared mailbox got to properties,  on properties goto mail flow settings >  click on delivery options click on properties  in delivery options send on behalf  add users to  grant this permision to. click ok.

     


    With best regards Siddarth Sajjan : Disclaimer: This posting is provided "as is" with no warranties, and confers no rights.
    • Marked as answer by trader089 Monday, January 30, 2012 9:34 AM
    Saturday, January 28, 2012 1:28 AM
  • Hi Siddarth,

    thanks again for your effort, at the end there was a third reason. There have been occasionally two mailboxes in a row (the one complained on and one we tested additionally) not working properly, the rest of the 2000 seems to be okay. I concluded, it would be a bug with Exchange, but fortunatly I was wrong!  It was a combination of a corrupt user profile and a probably corrupt mailbox. After resetting the user profile and deactivating/reactivating the mailbox it works properly again.

    So I am out of the thing with a lot of extra work!!!! This is what counts at the end;-)

    With best regards

    Karl


    karl tries to be an admin but finds himself being administrated
    Monday, January 30, 2012 9:38 AM

All replies

  • if you are using exchange 2007 or 2010,

    open up exchange management console, goto Recipient configuration > mailbox, right click on shared mailbox got to properties,  on properties goto mail flow settings >  click on delivery options click on properties  in delivery options send on behalf  add users to  grant this permision to. click ok.

     


    With best regards Siddarth Sajjan : Disclaimer: This posting is provided "as is" with no warranties, and confers no rights.
    • Marked as answer by trader089 Monday, January 30, 2012 9:34 AM
    Saturday, January 28, 2012 1:28 AM
  • Thanks Siddarth,

    I am perfectly aware about this possibilities, but we are talking about 2000 mailboxes to work on so what I would need to know is wheather there is a possibility, that the user can do it him/herself. And the problem is, that the user has put the rule to his/her Outlook-client, but the settings wouldn't show off, even given a grace period of two days. This means eather I don't know the switch to turn to enable this feature for linked mailboxes or a lot of extra work. I'd prefare the first option.

    sincerly karl


    karl tries to be an admin but finds himself being administrated
    Sunday, January 29, 2012 12:34 PM
  • Hi Siddarth,

    thanks again for your effort, at the end there was a third reason. There have been occasionally two mailboxes in a row (the one complained on and one we tested additionally) not working properly, the rest of the 2000 seems to be okay. I concluded, it would be a bug with Exchange, but fortunatly I was wrong!  It was a combination of a corrupt user profile and a probably corrupt mailbox. After resetting the user profile and deactivating/reactivating the mailbox it works properly again.

    So I am out of the thing with a lot of extra work!!!! This is what counts at the end;-)

    With best regards

    Karl


    karl tries to be an admin but finds himself being administrated
    Monday, January 30, 2012 9:38 AM