locked
Chrome with Addons RRS feed

  • Question

  • Hello,

    sombody managed to sequence Google with addons (Ghostery Adblock) for example?.

    Included the %localappdata%\Google Folder, but don't get it working. After deploying the packet the addons are gone... Has domeone a solution?


    Best regards
    Andreas Ernst
    MCITP:EA, MCP, MCTS

    Saturday, August 15, 2015 12:39 PM

Answers

  • I have also created the add-ons as a separate package and connection grouped them successfully.  In that case I had to make sure to remove the localappdata exclusion from all group packages.

    Tim


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Saturday, August 22, 2015 12:59 PM
    Moderator
  • Try using the enterprise MSI, you can place extentions in the installdir... you can download it here
    Wednesday, August 19, 2015 3:59 PM
  • Try publishing the packages globally and see. For add-on's it sometimes requires to be published globally.

    Some parameters that need to be added to shortcut I found here which might help ( Not Sure though ) - http://peter.sh/experiments/chromium-command-line-switches/

    Try adding these parameters to shortcut --in-process-plugins or

    –no-sandbox (In some cases extensions will not be installed, if this parameter is not set)


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    • Marked as answer by Andreas Ernst Wednesday, August 26, 2015 8:51 AM
    Monday, August 24, 2015 11:43 AM
  • Hi guys,

    finally  I figured it out. Inside the Connection Group there was Google Chrome priority 0 and the addon priority 1. If I change this from 0->1 and 1->0 it works and the addon gets loaded (maybe its a poroblem by merging the VFS filesystems). Next problem, I just can load 1 Addon, if i join more than 1 Addon in the connection group only the first gets loaded.

    Staying on it... I'll give reply.


    Best regards
    Andreas Ernst
    MCITP:EA, MCP, MCTS

    Tuesday, August 25, 2015 7:13 AM

All replies

  • Please provide more information about,

    Your Infrastructure [Which Version, OS & Infra]

    You sequenced Google Chrome & Add On. You added them as Connection Group?

    Do you see any errors in the event log?

    What do you mean by Addons are gone?

    Tuesday, August 18, 2015 12:20 PM
  • Hello,

    sry for the lack of information.

    the Addons are named 

    Lightshot
    Ghostery
    Tag Assistant
    dataslayer
    Awesome Screenshot
    Tag Assistant by Google
    Webpage Screenshot
    Page Speed Insights by Google
    Google Analytics Debugger

    Search by Image (by Google)

    AppV 5 SP3 Sequenching and Deploying on Server 2012 R2. 

    I haven't done it as connection group. Just sequenced GoogleChrome + Addons and saved them in one big package.

    No Errors in the event log.

    I mean that no addons are available. If I open the sreamed package on the client and go under addons, they say me "No Addons installed" even the buildin ones (google docs) are missing. 


    Best regards
    Andreas Ernst
    MCITP:EA, MCP, MCTS

    Wednesday, August 19, 2015 7:42 AM
  • What version of GoogleChrome are you trying to sequence? I have sequenced version 41.0.2272.118 and was successfully able to publish it without any issues. I was able to see the build in extensions. I used App-V 5.0 SP3 sequencer and client. Published the app globally.


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Wednesday, August 19, 2015 10:40 AM
  • Do you any specific reason for capturing them as a whole?

    Why don't you give a try by sequencing them as Individual Packages. You'll get more advantages by doing so.

    Also, will be easy to troubleshoot as well.

    Wednesday, August 19, 2015 10:58 AM
  • Thx Iam using 5.0SP3 also. Trying to sequence chrome V40. i will try sequence it as individual packages and give you reply.



    Wednesday, August 19, 2015 1:01 PM
  •  %localappdata% (or [{Local AppData}] )is on the default exclusion list. So are you sure, you removed it from the exclusion list before starting your sequence?
    Wednesday, August 19, 2015 3:44 PM
  • Hi,

    100% sure. All my trying didn't work out today... Will start tomorrow new... Next day better day. Thx for your help till now. I will post me results here later.

    Wednesday, August 19, 2015 3:52 PM
  • Try using the enterprise MSI, you can place extentions in the installdir... you can download it here
    Wednesday, August 19, 2015 3:59 PM
  • I have also created the add-ons as a separate package and connection grouped them successfully.  In that case I had to make sure to remove the localappdata exclusion from all group packages.

    Tim


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Saturday, August 22, 2015 12:59 PM
    Moderator
  • Hi,

    testing today. Will give you response. Thanks for the great feedback!


    Best regards
    Andreas Ernst
    MCITP:EA, MCP, MCTS

    Monday, August 24, 2015 8:57 AM
  • Hi,

    I failed again. 

    %localappdata% exclusion for chrome

    %localappdata% exclusion for the Addin

    In the sequencing process i coose "add an addin"

    enabled COM objects in both packets

    Joined them in a connection group.

    Chrome starts without Addin

    when Iam browsing the chrome folder in /Appvve i can see the extensions but they won't load :(

    Even if i say chrome /appvve:PACKAGEIDOFTHEADDIN_... just chrome comes up without addon


    Best regards
    Andreas Ernst
    MCITP:EA, MCP, MCTS


    Monday, August 24, 2015 10:40 AM
  • Try publishing the packages globally and see. For add-on's it sometimes requires to be published globally.

    Some parameters that need to be added to shortcut I found here which might help ( Not Sure though ) - http://peter.sh/experiments/chromium-command-line-switches/

    Try adding these parameters to shortcut --in-process-plugins or

    –no-sandbox (In some cases extensions will not be installed, if this parameter is not set)


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    • Marked as answer by Andreas Ernst Wednesday, August 26, 2015 8:51 AM
    Monday, August 24, 2015 11:43 AM
  • Hi guys,

    finally  I figured it out. Inside the Connection Group there was Google Chrome priority 0 and the addon priority 1. If I change this from 0->1 and 1->0 it works and the addon gets loaded (maybe its a poroblem by merging the VFS filesystems). Next problem, I just can load 1 Addon, if i join more than 1 Addon in the connection group only the first gets loaded.

    Staying on it... I'll give reply.


    Best regards
    Andreas Ernst
    MCITP:EA, MCP, MCTS

    Tuesday, August 25, 2015 7:13 AM
  • Please check if the Suggestions by Tim in the URL below may help you,

    http://www.tmurgent.com/TmBlog/?p=2240

    Registry Keys with Override Local might sometime cause issues. See if there ia any & change them too Merge with Local.

    Tuesday, August 25, 2015 1:52 PM
  • What did you use for PVAD? Chose a dummy pvad for each package in  your group. If you chose the same dir as pvad for each package, the highest package wins, and will override the lower once.
    Tuesday, August 25, 2015 10:24 PM
  • Hi,

    Appv5.0SP3 dont asks for a install folder. The Addons are in the VFS Tree. So they should be merged. I will set this tread as solved. But will comment if I found a soulution.

    Many Thanks!


    Best regards
    Andreas Ernst
    MCITP:EA, MCP, MCTS

    Wednesday, August 26, 2015 8:50 AM
  • You can turn on setting the PVAD in App-V 5.0 SP3 by editing the following Registry.

    HKLM\SOFTWARE\Microsoft\AppV\Sequencer\Compatibility

    If the Compatability key doesn't exist, you must create it.Create a DWORD Value named EnablePVADControl, and set the value to 1. 


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Wednesday, August 26, 2015 9:25 AM