locked
Service Requests not resolving RRS feed

  • Question

  • Good Morning TechNet Experts,

    I have been having an issue with service requests and I'm one week away from deployment. Basically, I had no need for a "Review" activity, we implement service requests the same way we implement incidents. An analyst opens a ticket for customer, once service has been applied they should resolve the service request. With incidents this is easy, you just change the incident status to resolved...

    However, with Service Requests I created a new template that did not require the "Approval" activity, only the "Apply Service" activity. My Idea was when an analyst is finished with the ticket, he/she just marks the "Apply Service" activity as completed and the service request can move to "Completed" status.

    Although the activity is being marked as completed, the ticket is not changing status. Some are stuck in "In Progress" and some are stuck in "New" status (even though the activity is showing as completed....). These have been stuck for more than 24 hours now... when this actually goes into production a week from now even 5 minutes is a long time.

    What can I do to solve this? I am open to implementing a new procedure if required. Thanks in advance!


    Thursday, March 5, 2015 3:15 PM

Answers

  • Hi,

    First of all, it looks like you are having an issue with your workflows. Please restart the HealthService (Microsoft Monitoring Agent) and check if the workflows restart. Do other workflows run (e.g. notification subscriptions)?

    Secondly, if you are using service requests with only one manual activity, I believe the handling is a little bit complicated for your analysts. Why don't you remove all activities completely from your SR template? The service request will then go to status "Submitted" once created, and the analyst can use the task "Complete" to complete the SR without having to worry about activities.

    HTH,

    Dieter

    • Marked as answer by SirLearnAlot Thursday, March 5, 2015 5:59 PM
    Thursday, March 5, 2015 4:38 PM

All replies

  • Hi,

    First of all, it looks like you are having an issue with your workflows. Please restart the HealthService (Microsoft Monitoring Agent) and check if the workflows restart. Do other workflows run (e.g. notification subscriptions)?

    Secondly, if you are using service requests with only one manual activity, I believe the handling is a little bit complicated for your analysts. Why don't you remove all activities completely from your SR template? The service request will then go to status "Submitted" once created, and the analyst can use the task "Complete" to complete the SR without having to worry about activities.

    HTH,

    Dieter

    • Marked as answer by SirLearnAlot Thursday, March 5, 2015 5:59 PM
    Thursday, March 5, 2015 4:38 PM
  • Thanks for the tip! I deleted all the activities and now the analyst just has to click "Complete" in the tasks pane to resolve the SR.

    Restarting the HealthService got all my notifications working again and fixed the stuck status of the service requests... however I opened the log and now found many more errors. Ill open a new question for this.. thanks!

    Thursday, March 5, 2015 5:59 PM