locked
Regedit.exe crashing on Windows Vista Business RRS feed

  • Question

  • I have a number of Windows Vista Business machines on a Windows 2003/2008 domain that are all of a sudden having a problem running regedit.exe.  We have a logon script set to run a regedit and so users are getting an error message pop up every time they log on. Even if you log on with administrative permissions and run regedit.exe manually from the Run command, the same error occurs, so I'm not at all sure this is actually a security issue. However, I couldn't figure out where else in these forums to post this question. It is not yet happening on all machines, but seems to be spreading.  The actual error message is as follows:

    Log Name:      Application
    Source:        Application Error
    Date:          02/16/10 12:42:23 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      RN135.domain.com
    Description:
    Faulting application regedit.exe, version 5.1.2600.5512, time stamp 0x48025214, faulting module SHUNIMPL.dll, version 6.0.6002.18005, time stamp 0x49e03821, exception code 0xc0000142, fault offset 0x00009eed, process id 0xffc, application start time 0x01caaf2f649e7967.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-02-16T17:42:23.000Z" />
        <EventRecordID>5582</EventRecordID>
        <Channel>Application</Channel>
        <Computer>RN135.domain.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>regedit.exe</Data>
        <Data>5.1.2600.5512</Data>
        <Data>48025214</Data>
        <Data>SHUNIMPL.dll</Data>
        <Data>6.0.6002.18005</Data>
        <Data>49e03821</Data>
        <Data>c0000142</Data>
        <Data>00009eed</Data>
        <Data>ffc</Data>
        <Data>01caaf2f649e7967</Data>
      </EventData>
    </Event>

    On one of the problem workstations, I've tried replacing the shunimpl.dll file, which did nothing. Then I replaced the regedit.exe file. Now, on that particular workstation, I can run regedit, but only if I type the entire path: C:\windows\regedit.  That's a slightly different problem, but still it is odd and I don't know why that is happening.

    Any ideas would be appreciated.
    Deb
    Tuesday, February 16, 2010 6:23 PM

All replies

  • Forgot to mention that I also ran sfc /scannow and it didn't seem to find or fix any problems.
    Deb
    Tuesday, February 16, 2010 6:52 PM
  • Hi,

    It seems that the regedit.exe is corrupted or that the version is out of date. Version 5.1.2600.5512 is for Windows XP or Windows Server 2003. In Windows Vista, the version of regedit is at least 6.0.6000.16386. The reason that why you can excute the regedit after replacing the regedit.exe file but needing to type the entire path is that the new version of regedit isn't registered on your comptuer. To resolve this kind of issue, I would like to suggest you obtaining the latest Windows Server 2003 Service Pack.

    Best Regards
    Dale
    Wednesday, February 17, 2010 3:16 AM
    Moderator
  • I am not running this on a Windows 2003 server, I'm running it on a Vista machine, so I can't see how a Windows 2003 Server service pack would be any help. 

    We never replaced the original regedit.exe file on these machines, so the file version could not be wrong.  Plus, when I look at the regedit.exe file properties, it shows that the version is 6.0.6001.18000. So, it appears that the error message is somehow picking up the incorrect file version. Not sure what that means, if anything.

    And, in case what you meant to say was that I needed the latest Vista server pack, these machines are already running Vista SP2.

    Deb
    Wednesday, February 17, 2010 6:08 PM
  • Sorry for misunderstanding.

    Regarding the current situation, have you tried the Startup Repair to automatically replace incorrect or corrupted versions of files? It is worthy to have a test.

    Best Regards
    Dale
    Tuesday, February 23, 2010 5:45 AM
    Moderator