none
custom field type not showing up as crawled property

    Question

  • Hi all,

    I have a custom field type, inheriting from SPFieldText and I cannot get columns of this fieldtype to show up as a crawled property.  I do have list items with this column and have set the value.  I have tried clearing out the crawl index and then doing a full crawl again.  Also, I am crawling content sources: http://server and sps3://server

    I do not have any crawl rules setup.

    Thanks,
    Ryan
    • Moved by Mike Walsh FIN Saturday, September 6, 2008 10:42 AM Wrong forum (Moved from SharePoint - Development and Programming to SharePoint - Search)
    Saturday, September 6, 2008 1:47 AM

Answers

  • OK, fixed this one.  We were not PUBLISHING our list items.  They were left in draft.  I did not know that search will not index draft items.  Thanks!
    • Marked as answer by ryandale56 Monday, September 8, 2008 7:03 PM
    Monday, September 8, 2008 7:03 PM

All replies

  • This is more of a search specfic question, but go into your SSP and under your search settings, there is something called "managed properties".  Custom fields will have to be added to the managed properties for them to be search upon properly.  You'll most likely have to recrawl the content after you do this as well.
    Saturday, September 6, 2008 4:10 AM
  • Moving to the search forum
    Saturday, September 6, 2008 10:42 AM
  • Thanks for the reply Tony.  My problem is not that I don't know how to add a column/property to a Managed Property.  My problem is that my custom column that is using my custom field type does not show up as an available crawled property to even add to a managed property.  Yes, I have verified I have list items that use this column and have data in that column and I have done many full crawls.  Additionally I have tried resetting the index altogether and running a full crawl, and my column still does not show up.

    Has anyone else experienced this? I'm thinking there may be some code in my custom field type that I need to add?

    Thanks,
    r
    Monday, September 8, 2008 5:39 PM
  • OK, fixed this one.  We were not PUBLISHING our list items.  They were left in draft.  I did not know that search will not index draft items.  Thanks!
    • Marked as answer by ryandale56 Monday, September 8, 2008 7:03 PM
    Monday, September 8, 2008 7:03 PM
  • I found this when looking for an issue of mine - Custom Properties to the USER profiles were not appearing in the Managed properties list - new ones that were mapped to AD fields were, but not new, unmapped ones - I sorted this when I realized the proeprty had to be set to "everyone" in its "who can view" setting - maybe this will help others who find this post with a similar problem!
    Friday, October 23, 2009 3:36 PM
  • Hey - I know this is a very old thread .... but I am having the same issue !  Question is - How do you "Publish our list items"  as you mentioned above.

    Appreciate  your time

    Yu

    Thursday, May 1, 2014 4:16 PM