none
installation of package had non-zero exit status RRS feed

  • Question

  • Hello,

    I am experiencing an error when i try to install third party packages to Microsoft R Server.

    Maybe it comes from a Space-character in the R-Server installation path. See the message from the attached log "'E:\R' is not recognized as an internal or external command".

    I installed the Microsoft R Server 9.1.0 with the following command:

    Param (
        $InstallPath = 'E:\R Server',
        $InstallMediaPath = 'E:\Installs'
    )
    
    Set-Location "$InstallMediaPath\en_microsoft_r_server_910_for_windows_x64_10324119\MRS91Windows\"
    
    RServerSetup.exe /install /offline /installdir=$InstallPath /mediadir=$InstallMediaPath /models

    The log of the package installation is: 

    R version 3.3.3 (2017-03-06) -- "Another Canoe"
    Copyright (C) 2017 The R Foundation for Statistical Computing
    Platform: x86_64-w64-mingw32/x64 (64-bit)
    
    R is free software and comes with ABSOLUTELY NO WARRANTY.
    You are welcome to redistribute it under certain conditions.
    Type 'license()' or 'licence()' for distribution details.
    
      Natural language support but running in an English locale
    
    R is a collaborative project with many contributors.
    Type 'contributors()' for more information and
    'citation()' on how to cite R or R packages in publications.
    
    Type 'demo()' for some demos, 'help()' for on-line help, or
    'help.start()' for an HTML browser interface to help.
    Type 'q()' to quit R.
    
    Microsoft R Open 3.3.3
    The enhanced R distribution from Microsoft
    Microsoft packages Copyright (C) 2017 Microsoft
    
    Loading Microsoft R Server packages, version 9.1.0.
    Type 'readme()' for release notes, privacy() for privacy policy, or
    'RevoLicense()' for licensing information.
    
    Using the Intel MKL for parallel mathematical computing(using 1 cores).
    Default CRAN mirror snapshot taken on 2017-03-15.
    See: https://mran.microsoft.com/.
    
    > utils:::menuInstallLocal()
    'E:\R' is not recognized as an internal or external command,
    operable program or batch file.
    Warning messages:
    1: running command '"E:/R Server/R_SERVER/bin/x64/R" CMD INSTALL -l "E:\R Server\R_SERVER\library" "E:/Installs/AAJC_1.8.tar.gz"' had status 1 
    2: In install.packages(files[tarballs], .libPaths()[1L], repos = NULL,  :
      installation of package ‘E:/Installs/AAJC_1.8.tar.gz’ had non-zero exit status
    > 

    Best Regards,

    Steffen

    Tuesday, October 10, 2017 7:35 AM

All replies

  • It works, if R-Server is installed to a path without spaces.

    Param (
        $InstallPath = 'E:\R_Server',
        $InstallMediaPath = 'E:\Installs'
    )
    
    Set-Location "$InstallMediaPath\en_microsoft_r_server_910_for_windows_x64_10324119\MRS91Windows\"
    
    ./RServerSetup.exe /install /offline /installdir=$InstallPath /mediadir=$InstallMediaPath /models
    

    it's 2017!

    Thanks,

    Steffen

    Tuesday, October 10, 2017 9:08 AM
  • Hi Steffen,

    I think that you need to enable long filename support on your Windows installation. I suspect it is disabled.

    Please check this writeup for steps on how to enable long filenames on your installation. This needs to be enabled BEFORE you create the install directory with spaces.

    http://beta.itprotoday.com/windows-10/enable-long-file-name-support-windows-10?utm_test=redirect&utm_referrer=https%3A%2F%2Fwww.bing.com%2F

    Stephen Weller

    Tuesday, October 17, 2017 5:10 PM
  • Hi Steven,

    thanks for that, but according to https://msdn.microsoft.com/en-us/library/windows/desktop/aa365247(v=vs.85).aspx#maxpath this is a Windows 10 feature. I haven't found something similar for Windows Server 2012. And if i have to reinstall the R Server it would be easier to install it to a path without spaces. But maybe it works to rename a copy to the old path to use long file name support.

    I will test that with a Windows 7 system in a few days.

    Thanks

    Steffen Kampmann

    Thursday, October 19, 2017 4:55 PM