none
install of update rollup 10 for Exchange 2007 fails RRS feed

  • Question

  • I have problems installing RU10 for one of our Exchange 2007 server (HubTransport role) I have installed the same package on all our servers and its only failing on this specific server.

    A. Things that I have done:

    1. re-download the package
    2. empty the <systemdrive>/Windows/Temp folder
    3. found an article below about similar issue when Windows Management Framework 3.0 is installed. But I have viewed the Installed updates but KB2506146 and KB2506143 are not installed.
    http://blogs.technet.com/b/exchange/archive/2012/12/14/windows-management-framework-3-0-on-exchange-2007-and-exchange-2010.aspx
    4. Related to #3, I tried running a powershell line below to ensure I dont missed the KB's were not in the list but its not giving me result and generates an error instead . Running the same command remotely on another server provides the result/list though.
    Get-HotFix -ComputerName "<server name>"
    5. I tried installing via cmd line and initiate the /lxv switch to get a detailed logging and I get the errors below (let me know if someone wants to read the whole log file :)

    DEBUG: Error 2826:  Control BottomLine on dialog FatalError extends beyond the boundaries of the dialog to the right by 5 pixels
    The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2826. The arguments are: FatalError, BottomLine, to the right
    Action ended 06:03:53: FatalError. Return value 2.
    Action ended 06:03:53: INSTALL. Return value 3.
    MSI (c) (88:78) [06:03:53:943]: Destroying RemoteAPI object.

    B. What I have noticed:

    1. Event log shows Event ID 1024
    Product: Microsoft Exchange Server - Update 'Update Rollup 10 for Exchange Server 2007 Service Pack 3 (KB2788321) 8.3.298.3' could not be installed. Error code 1603. Windows Installer can create logs to help troubleshoot issues with installing software packages. Use the following link for instructions on turning on logging support: http://go.microsoft.com/fwlink/?LinkId=23127

    2. when I run EMS (Exchange Management Shell) an error is displayed immediately:

    There were errors in loading the format data file:
    Microsoft.Exchange.Management.PowerShell.Admin, , c:\Program Files\Microsoft\Exc
    hange Server\bin\Exchange.format.ps1xml : File skipped because of the following
    validation exception: AuthorizationManager check failed..

    WriteErrorStream      : True


    PoSH newbie, BaSH Oldie

    Monday, August 12, 2013 3:21 AM

Answers