locked
Error code 0x800700B7 with System Restore and Backup problems RRS feed

  • Question

  • My OS is Vista Ultimate. 2GB RAM. 13GB free space on C Drive. I am unable to use System Restore or Backup and Restore center. When I try to create a Restore Point (or do a backup) error message comes up 'Could not create the scheduled task for the following reason: Cannot create a file when that file already exists. (0x800700B7).' I think (not sure) that these problems came after I was infected with win32:Vitro virus. (No longer any infections showing). I think that my registry may be corrupt or files deleted. Can anyone help please?
    Wednesday, April 8, 2009 10:40 AM

Answers

  • Hi,

     

    Thank you for your post.

     

    Based on my research, I would like to suggest the following:

     

    Note: Please perform a complete system backup first. If any unexpected issue occurs, we can quickly restore the system to the current status.

     

    1.     Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.

     

    If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.

     

    2.     In the navigation pane, locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache

     

    3.     Right click on this key and select "Export" and save the key to a Flash Drive or other removable storage device.

     

    4.     Remove the key “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows

     

    5.     Please reboot the computer and check if the issue reoccurs. If it works, please also reconfigure the Scheduled Task for System restore in Task Scheduler.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Friday, April 10, 2009 8:32 AM
    Moderator

All replies

  • Hi,

     

    Thank you for your post.

     

    Based on my research, I would like to suggest the following:

     

    Note: Please perform a complete system backup first. If any unexpected issue occurs, we can quickly restore the system to the current status.

     

    1.     Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.

     

    If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.

     

    2.     In the navigation pane, locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache

     

    3.     Right click on this key and select "Export" and save the key to a Flash Drive or other removable storage device.

     

    4.     Remove the key “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows

     

    5.     Please reboot the computer and check if the issue reoccurs. If it works, please also reconfigure the Scheduled Task for System restore in Task Scheduler.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Friday, April 10, 2009 8:32 AM
    Moderator
  • I'm having the same problem described above.  I tried what you suggested and it didn't work.  Any other suggestions??

    Thanks!
    Thursday, July 2, 2009 3:59 AM
  • I tried everything, but nothing worked. In the end I paid a small sum [$34.95] to get Microsoft  (Omnitech Support/Microsoft Fix It) to fix it. It took nearly all day, but problems were fixed eventually. Waste of time doing Anti virus scans etc in my case.
    Thursday, July 2, 2009 3:50 PM
  • By any Chance do you remember the fix? Sure would be helpful to many people and I know I would Thanks-You.
    Friday, July 17, 2009 3:12 PM
  • Could you please share with us what they did to fix it? I'm willing to do whatever it takes to fix this except pay Microsoft $40.00.
    Wednesday, December 9, 2009 2:22 AM
  • I am surprised to find a MSFT suggesting this fix. :(

    If you folllow this guide you will effectively kill the task scheduler database in the registry and throw it completely out of sync. You will have to re-create all the systems' out of the box tasks if you remove this key. Backing up the key is useless because you will be unable to re-merge the key again even if you disable Task Scheduler.

    Remove the SystemRestore key not the Windows key. Also remove the ID class identified by the SystemRestore\SR value ID. It is located in Taskcache as the classID.

    Do this and System Restrore will re-create the task.

    • Proposed as answer by Peter Holdridge Wednesday, December 8, 2010 7:54 PM
    Wednesday, December 8, 2010 7:50 PM
  • I know this is an old thread, but in case someone on the internet comes looking for a solution to this issue here's what worked for me:

     

    I simply deleted the following file:  %windir%\system32\tasks\microsoft\windows\SystemRestore\SR

    I was then able to create a restore point without any problem.

    • Proposed as answer by Aaron Salvo Saturday, April 2, 2011 4:59 AM
    Saturday, April 2, 2011 4:58 AM
  • Thanks for the post. I've got the added problem that I cant even boot. I did the regedit above but dont have a 'schedule' section as per the path.... i can't get in to find the file you suggested, but thank you for taking the time to post it. Ill continue on my quest.... Strange that all this happened after I updated Samsung Kies for my Galaxy S and then upgraded its firmware...

    Friday, April 22, 2011 10:23 AM
  • tankyou, mr. Salvo, you suggestion, fix my problem, but no after i findout, how to used, for any other people whit the same problem do this: click star, go to computer, open c:, look for windows,system32,task,microsoft,windows,systemrestore and delete SR, you problem it fix.

    work for me and i'm sure, it will work for you. Sorry for my english, you friend jose.

    Tuesday, June 21, 2011 11:51 PM
  • I know this is an old thread, but in case someone on the internet comes looking for a solution to this issue here's what worked for me:

     

    I simply deleted the following file:  %windir%\system32\tasks\microsoft\windows\SystemRestore\SR

    I was then able to create a restore point without any problem.

    I Was having this error in Server 2012 R1 but found this Dir did not exist.. although i did find a file called Backup listed in the Dir %windir%\System32\tasks\microsoft\windows\

    I renamed this file and hit finish again on the WB wizard and Tada! all ok now..

    Hopefully this helps someone, i joined just to post this answer.

    Tuesday, March 11, 2014 11:46 PM
  • Outstanding post -- this worked for me on a Windows 7 install that wouldn't start. Had to get to startup repair and then command prompt to delete the SR file (actually, I just renamed it).

    Sunday, March 15, 2015 6:06 PM
  • Thank u so much... That really worked 
    Wednesday, September 16, 2015 4:51 AM
  • I know this is an old thread, but in case someone on the internet comes looking for a solution to this issue here's what worked for me:

     

    I simply deleted the following file:  %windir%\system32\tasks\microsoft\windows\SystemRestore\SR

    I was then able to create a restore point without any problem.

    Thanks Aaron - did a lot of research to fix the problem. Your solution worked magic on my seven year old Win 7 Ultimate 64 bit laptop. None of the usual fixes worked. It seems the old System Restore point wreaks havoc with saving restore points and, ultimately causing the BSOD. 
    Monday, October 5, 2015 5:59 AM