Hyper-V migration of Windows XP to Windows Vista; vmstorfl.sys error message RRS feed

  • Question

  • Hi everybody,

    I am running a Windows 2012 Core server as host OS with Microsoft Hyper-V on an Intel Xeon server.

    Because of a legacy application, I am running an old Windows XP machine, with all service packs and hotfixes installed.  Also Hyper-V integration services are running. Everything is running smoothly. Since Windows XP is not supported anymore, I want to upgrade this Windows XP machine to Vista. For that, I do have a DVD with Vista Business and SP1, including a .valid license. Unfortunately I cannot install this legacy application on Windows Vista for some reason, but that's not the case.

    After starting the upgrade van Windows Vista, the machine is really really slow. But that's okay, in the meantime I can grab a coffee (or two). The problems arise when the upgrade is completed. After the final reboot, an error message appears after the Windows Vista logo (translated poorly from Dutch to English):

    Cannot launch Windows This is probably caused by a recent change of hard- or software. <bla bla>.

    File: vmstorfl.sys
    Status: 0xc0000098
    Information: Cannot load Windows because a required file is missing or damaged.

    Using the Windows Vista DVD (ISO image) I was able to launch a command prompt to see what's wrong. The file, vmstorfl.sys, is in place, so that's not the issue. A chkdsk /f doesn't solve the issue.

    Luckily I have some snapshots of this Windows XP machine so I was able to revert back. However, after following the same procedure again, the same error comes back.

    What I've tried so far:

    • Removal of installation of integration services on the Windows XP machine before upgrade to Vista
    • Removal of all unncessary applications on the Windows XP machine
    • Booting from the Windows Vista ISO to try the system repair option

    But still.. Bad luck. I cannot get this issue fixed. Also on the Internet I haven't found hardly any information about vmstorfl.sys or any other information from this error message.

    Does anyone of you have a suggestion?


    Tuesday, May 16, 2017 1:30 PM