locked
Right Click Manage stops working. RRS feed

  • General discussion

  • I have seen this all over the web and encountered it on several machines. When you first install Windows 7 you can Right Click on the Computer Icon and click Manage. This normally brings up the Computer Management Console. Ater a while this same action starts to give you a File Association error. I have developed a quick work around that should work for most people. The problem is CompMgmtLauncher.exe stops working and loses its association with the Computer Management Console.


    Replace C:\Windows with your %SystemRoot% if you need to.

    Create a Batch File under C:\Windows\System32\   called CompMgmtLauncher.bat
    Edit CompMgmtLauncher.bat and put in these two lines

    Start C:\Windows\System32\compmgmt.msc
    Exit

    Save batch file and exit

    Type Regedit and do a search for CompMgmtLauncher.exe

    Mine was located here.

    [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command]

    Under this key you will find a line that ends in CompMgmtLauncher.exe

    Change the exe to bat and Manage should now work.

    I know it is not the best fix in the world but it gets your right-click manage back up and running fast.

    Monday, August 24, 2009 5:37 PM

All replies

  • Thanks for the tip cdsmith7789!  This has been driving me nuts!  Windows 7 has a few bugs, but hopefully they'll get them patched before too many folks notice!  :)
    Friday, September 4, 2009 1:21 AM
  • Thanks so much. This was driving me insane as well. Has anyone figured out the real reason this happens yet?
    Friday, November 6, 2009 4:57 PM
  • Thanks so much. This was driving me insane as well. Has anyone figured out the real reason this happens yet?

    If nothing happens when you right-click Computer and then click Manage, most probably you've installed an application that included a faulty context menu handler. Read this conversation: http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/f616b934-1248-49e9-b024-820231a7d78d

    On the other hand, if you are getting an error message when you click Manage, copy and paste the text here so that we can take a look and develop a fix that is appropiate for your case.
    Microsoft MVP Windows Desktop Experience
    Saturday, November 7, 2009 1:04 AM
    Answerer
  • Thanks Daliel Martin

    In the Command below

    [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command]

    Put: "%SystemRoot%\system32\mmc.exe" "%SystemRoot%\system32\compmgmt.msc" /s

    Computer Management Console will work fine.
    Saturday, November 14, 2009 4:50 PM
  • Thanks Daliel Martin

    In the Command below

    [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command]

    Put: "%SystemRoot%\system32\mmc.exe" "%SystemRoot%\system32\compmgmt.msc" /s

    Computer Management Console will work fine.

    I prefer to disable the bad context menu handler instead of implementing that workaround. A bad shell extension would likely cause other similar problems to the user interface.
    Microsoft MVP Windows Desktop Experience
    Sunday, November 15, 2009 4:28 PM
    Answerer
  • The flaw was not for bad shell extension, I think it was for malfunctioning of "CompMgmtLauncher.exe".

    Saturday, December 5, 2009 3:24 PM
  • I had the same issue as everyone here, ended up finding out that I installed an old version of a piece of software, that was not Windows 7 certified and it removed the jump list functionality as well as the right click on computer and manage.

    As soon as I removed it, all of the aforementioned items began working again with no issue.

    I would cycle back through each application that is installed and make sure it's the latest supported version as to avoid weird issues like this.

    Good luck and thanks for posting in general, it really helped jog my memory and troubleshoot this issue.
    Sunday, December 6, 2009 3:23 AM
  • I also had the same problem. I tried replacing the blocked CompMgmtLauncher.exe with a known working CompMgmtLauncher.exe file from another win 7 x64 system, and still nothing would happen.

    I discovered that a third party shell extension was causing the problem. In fact, I have installed  a security product "a-squared Anti-Malware 4.5" (http://www.emsisoft.com/en/software/antimalware/ ), on the computer with malfunctioning right-click context  menu, that would not execute CompMgmtLauncher.exe, and hence would not start CompMgmt.msc.

    I solved the issue by removing the a-squared context menu option, as follows:

    Open a-squared Anti-Malware, click Configuration , and uncheck Activate Explorer integration. The trade-off of this option is that you won't be able to scan individual files/folders from the context menu (if you really do need that functionality, it's easy to recheck the box and re-activate explorer integration).

    Now, I can right click my computer and "manage" works like a charm.

    Tuesday, December 22, 2009 7:39 PM
  • I know this is probably redundant... try right clicking on the start jewel, go to Properties, then for the Start Menu click on Customize, then make sure that Enable context menus and dragging and dropping is checked. Fixed it for me.
    Tuesday, December 22, 2009 11:21 PM
  • I also had the same problem. I tried replacing the blocked CompMgmtLauncher.exe with a known working CompMgmtLauncher.exe file from another win 7 x64 system, and still nothing would happen.

    I discovered that a third party shell extension was causing the problem. In fact, I have installed  a security product "a-squared Anti-Malware 4.5" (http://www.emsisoft.com/en/software/antimalware/ ), on the computer with malfunctioning right-click context  menu, that would not execute CompMgmtLauncher.exe, and hence would not start CompMgmt.msc.

    I solved the issue by removing the a-squared context menu option, as follows:

    Open a-squared Anti-Malware, click Configuration , and uncheck Activate Explorer integration. The trade-off of this option is that you won't be able to scan individual files/folders from the context menu (if you really do need that functionality, it's easy to recheck the box and re-activate explorer integration).

    Now, I can right click my computer and "manage" works like a charm.


    This was exactly my problem.. I just did a2 extebtion deactivatre and boom it works all fine thanks!!!!!!!!!!!!!!
    check the problem on emsi wesite forum too
    http://support.emsisoft.com/topic/1147-a-squared-free-explorer-integration-stops-accessing-windows-manage-right-click-on-this-computer/

    Friday, January 22, 2010 1:14 AM
  • I also have this problem.  The other thread did not help, unfortunately.  The reg entry is identical to what is already there, and the only non MS shell extentions I can find using that program are from Alcohol, McAfee and nVidia.  Disabling them all did not help.

    Tried to go through Control Panel - Administrative Tools only to get an error about unable to find missing shortcuts.  Then enabled Admin Tools in the Start menu, only to find the folder is empty!  I can run it from System32\compmgmt.msc or SysWOW64\compmgmt.msc, but not from Compmgmtlauncher.exe.
    Wednesday, February 3, 2010 4:53 AM
  • For the sake of clarity, remove all quotes (").
    %SystemRoot%\system32\mmc.exe %SystemRoot%\system32\compmgmt.msc /s
    Friday, April 2, 2010 5:34 AM
  • In the Command below

    [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command]

    Put: "%SystemRoot%\system32\mmc.exe" "%SystemRoot%\system32\compmgmt.msc" /s

    Computer Management Console will work fine.

    Thanks—that worked for me too.

     

    It didn't work the first time I tried it, because I'd included the quotation marks. When I retried without them, it worked. That's funny, because you can use quotes on paths in command lines, right? Anyway, just thought I'd mention that.

     

    Sunday, June 27, 2010 12:46 AM
  • This problem is not only caused by a faulty context menu handler.  I used ShellExView to check every non-MS context menu handler I had an uninstalled every single application that had installed a non-MS context menu handler and I still had this problem. 

    I don't know what was causing it in my case, but it was not a bad context menu handler (unless it's a bad MS context menu handler).  Not UAC either as I have that turned off.

    Thursday, July 1, 2010 10:15 PM
  • I'm also having this issue on Server 2008 R2, and it's not limited to context menu handling. If you just try to run CompMgmtLauncher.exe, it will not launch. I have other systems that are configured identically where it will run.
    Wednesday, July 7, 2010 7:17 PM
  • For the sake of clarity, remove all quotes (").
    %SystemRoot%\system32\mmc.exe %SystemRoot%\system32\compmgmt.msc /s
    This one works perfect, thanks
    Saturday, July 10, 2010 10:08 AM
  • This solution is inelegant as every time you click Manage in the Computer context menu a black window opens up, runs the batch file, and closes before the Computer Management window opens up. Can you come up with a better solution?
    Friday, July 23, 2010 8:20 PM
  • The correct solution was given by Daniel Martin here http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/f616b934-1248-49e9-b024-820231a7d78d All you have to do is uninstall a-squared and all will be well.
    Friday, July 23, 2010 8:59 PM
  • groucho43, I tried that & it did not work as it was not a 3rd party shell extension that was causing the issue for me. 

    I don't know what did cause it, but I did not have a-squared installed in the first place & uninstalling all other extensions had no effect.  Ultimately, I had to reinstall Windows anyway & after reinstalling everything I had installed previously, the problem has not reoccurred.  So I still have no idea what caused it in the first place.

    Sunday, July 25, 2010 11:46 PM
  • Thank you very much - this worked for me, too.
    handlin
    Wednesday, August 4, 2010 8:39 PM
  • %SystemRoot%\system32\mmc.exe %SystemRoot%\system32\compmgmt.msc /s

     

    Yep this worked for me too.

     

    A Very BIG Thank you to all that helped on this one.

     

     

    Monday, January 10, 2011 7:30 PM
  • I have seen this all over the web and encountered it on several machines. When you first install Windows 7 you can Right Click on the Computer Icon and click Manage. This normally brings up the Computer Management Console. Ater a while this same action starts to give you a File Association error. I have developed a quick work around that should work for most people. The problem is CompMgmtLauncher.exe stops working and loses its association with the Computer Management Console.


    Replace C:\Windows with your %SystemRoot% if you need to.

    Create a Batch File under C:\Windows\System32\   called CompMgmtLauncher.bat
    Edit CompMgmtLauncher.bat and put in these two lines

    Start C:\Windows\System32\compmgmt.msc
    Exit

    Save batch file and exit

    Type Regedit and do a search for CompMgmtLauncher.exe

    Mine was located here.

    [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command]

    Under this key you will find a line that ends in CompMgmtLauncher.exe

    Change the exe to bat and Manage should now work.

    I know it is not the best fix in the world but it gets your right-click manage back up and running fast.

    I did it rather like this:

    Explorer.exe "%SystemRoot%\system32\compmgmt.msc"

    and the window of the console starts without showing the black window.

    Monday, March 28, 2011 7:20 AM
  • yes, yesterday there was problem with MS Office 2007 : config.msi, when i fixed it microsoftfixit50154.msi, it got fixed, the i restarted and when i was installing office 2007 in half time power went off, so again when i started to fix this issue nothing worked, believe me i tried everything to get the office installed, so lastly i have to format the system and install windows 7 again, and today i am facing this problem of Right click
    Thursday, June 30, 2011 9:31 AM
  • Thank you, thank you, thank you cdsmith7789!! Worked perfectly :D
    Monday, October 3, 2011 8:09 PM
  • I know it's an old thread, but I figured I'll let you guys know that the easiest way to fix it IS replacing CompMgmtLauncher.exe with the known good file  Just make sure the version is the same (you can even find it on the net if you're not afraid to use something foreign). You will need to take ownership of the faulty file first (properties>security>advanced>owner>edit choose administrator), after that you can cut out this file from there and put it somewhere else for now, keep it for a while "just in case".

    ... then put the good CompMgmtLauncher.exe in the system32 location...

    I just did it and it works right away...

    Sunday, October 23, 2011 2:17 PM
  • Well here's something interesting I thought I would share.

    As I said above, I fixed that problem by replacing the file with a new one , by the way... here's a link to the one that worked~~~~~~> http://down.dllfiledump.com/English_6.1_32_/Windows/System32/CompMgmtLauncher.exe

    So I Have replaced it and everything worked fine right?... but here's a thing, I've had some major system updating to do. Flashed bios, new chipset drivers, GPU drivers, etc... and as I was doing it, after a restart, I was using the right click manage option, to check event viewer, every time. And it worked perfectly, but now, I just noticed, it stopped working again!!!

    I think it was after I run windows update. It had to replace that file.

    And here is one more thing... The size of the faulting file is 142KB. The one that you are downloading and which works is 144KB. And after I have fixed it, and it was working, suddenly the new file become 2KB lighter and stopped working again...

    WTF?

     

    I hope it helps someone.

     

    Tuesday, October 25, 2011 6:47 AM
  • On the other hand, if you are getting an error message when you click Manage, copy and paste the text here so that we can take a look and develop a fix that is appropiate for your case.


    • Edited by def333 Wednesday, December 21, 2011 9:46 PM
    Wednesday, December 21, 2011 9:42 PM
  • On the other hand, if you are getting an error message when you click Manage, copy and paste the text here so that we can take a look and develop a fix that is appropiate for your case.



    Timounter64.dll is part of Acronis True Image software. Try reinstalling this application.

    Microsoft MVP Windows Expert Consumer | http://blogs.msmvps.com/dmartin/ | http://www.wintecnico.com

    Thursday, December 22, 2011 3:19 PM
    Answerer
  • thanks for the tip!

    that worked

     

    • Edited by def333 Thursday, December 29, 2011 3:30 AM
    Thursday, December 29, 2011 3:27 AM
  • Awesome,

    worked for me.  Thanks

    Friday, July 6, 2012 7:46 PM
  • I too had the same problem and none of the causes described here were responsible but the .bat solution did provide what seems to be a slightly more efficient method for accessing mmc.exe than the original CompMngrLauncher.exe did.

    However, I did discover what had happened in my case and was able to fix it. And the cause, and solution, of the problem came as some surprise to me.

    Some tweaking software packages offer a way to remove the rather cheap looking shortcut arrows that appear on shortcuts created on the desktop by deleting two registry keys in 'HKEY_CLASSES_ROOT.

    The deleted entries are: 'HKEY_CLASSES_ROOT\lnkfile\IsShortcut' which is supposed to remove the again cheap looking 'Shortcut To' that appears in new shortcuts and 'HKEY_CLASSES_ROOT\piffile\IsShortcut' which removes the little arrow that appears on new shortcuts.

    I found that by restoring the 'lnkfile' entry, the problem was solved.

    Open 'Regedit.exe' and navigate to 'HKEY_CLASSES_ROOT\lnkfile'. There should be four entries under that key and one of them should be labelled 'IsShortcut'.

    If 'IsShortcut' is not there then right-click in the right-hand pane and select 'New => String Value' then type "IsShortcut" (without the quotes) and enter.

    And that's it. Go to the 'View' menu in 'Regedit', select 'Refresh' and then 'Right-Click => Manage' should work fine. It did for me and I was gobsmacked.

    This problem doesn't occur on XP so I suspect that this is a case of the left hand not knowing what the right hand is doing in relation to the Windows 7 programming team. Which is kinda normal of course.

    I hope that this is of some assistance to others out there who are having similar problems.

    Thursday, October 11, 2012 9:35 AM
  • its work fine!  but i omitted /s
    Friday, December 21, 2012 8:14 AM
  • it's work fine with me ..... thx ;)

    Tuesday, December 25, 2012 8:56 AM
  • For People still having the Problem.

    Sry, 4 bad english guys.

    I found out after ages why all the tipps dont work for me :)

    Navigating to the Registry Key and Change to all the provided ones here or in other Forums DID NOT work for me.

    Right click + manage all the time bring up a error message window. Explorer cant acces File, Path blabla bla. Maybe rights bla bla bla.

    Click START and typing in compmgmt.msc directly brings up the Manage msc.

    in a CMD echo %systemroot% gave me C:\windows. CD %systemroot% Change me to c:\windows. CD System32 + compmgmt.msc let the Windows Pop up.

    Now my solution : Change the %systemroot% part in the registry :)

    c:\windows\system32\mmc.exe compmgmt.msc

    and everything is be fine by now. ( for me )

    Look like that there is something missing elsewhere. I did not figured out yet.


    • Edited by udo.s Sunday, February 3, 2013 9:22 PM
    Sunday, February 3, 2013 9:22 PM
  • hey thanks man this did work with my system 
    cheeeeers :)

    Tuesday, October 1, 2013 2:24 PM
  • esta opción es mas practica y limpia ... muchas gracias
    Sunday, February 2, 2014 7:42 PM
  • Great it is worked for me... this is a fast and best way ...THANKS

    Friday, February 14, 2014 6:00 PM
  • Thanks, [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command]

    In (Default)

    Put: "%SystemRoot%\system32\mmc.exe" "%SystemRoot%\system32\compmgmt.msc" /s

    Worked for me

    Sunday, July 13, 2014 6:39 PM
  • Thank you so much!
    Monday, February 23, 2015 2:00 PM
  • What does the /s switch do on compmgmt.msc?
    Sunday, July 17, 2016 7:55 PM
  • Thank you. This worked for me.
    Friday, January 20, 2017 2:29 AM
  • Thanks for the information, it worked fine for my Windows 10 Enterprise (64bit) as well !
    Sunday, October 1, 2017 3:29 AM
  • This also worked fine for my Windows 10 Enterprise (64bit) as well, that was had the same issue!
    Sunday, October 1, 2017 3:34 AM
  • Thanks Daliel Martin

    In the Command below

    [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command]

    Put: "%SystemRoot%\system32\mmc.exe" "%SystemRoot%\system32\compmgmt.msc" /s

    Computer Management Console will work fine.

    Used this along with an authored MMC console I saved to a new location. Now the "Manage" link opens my customized MMC console. Thanks for the assist.


    Can't post hyperlinks, but heres the author MMC link...

    docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc749526%28v%3dws.10%29

    Wednesday, March 14, 2018 12:33 PM