none
The server goes slow because of the use of cpu 100%

    Question

  • Hi, about 2 months ago, we bought a server HP Proliant ML30 with 16gb Ram and 2 hp's hard disks and Windows Server 2016 Essentials.

    I'm not able to find the problem, but it goes very slow. I've seen:
    - it has problem with Windows Update. Since april the update's goes ok less kb4093120 (1,2gb). Always fails. Yesterday I downloaded it and try to install, manually, and also fails. At the moment, I've  stopped Windows Update.

    - when I look at the Adminstratator Task, very often I see 100% of the used of cpu. At the top there are always theses process:
       - WMI Provider Host (WMIprvSE.exe)
       - smbsvcs (host process for Windows Services)
       - system
       -
    Also, I stopped the Panda's antivirus services, but the problem persists.

    I can format again the Server, but I'm not sure to solve the problem. Can anybody help me? Does anybody know what happens with kb4093120? How can install it? 

    Thanks very much


    mblascog

    Saturday, May 26, 2018 5:17 PM

Answers

  • Hi,

    First, I would recommend you to check/update hardware drivers, including firmware, BIOS and etc. make sure that appropriate driver version which is applied to Windows Server 2016 Essentials has been installed.

    Besides, if possible, please try to re-start system in Clean Boot, with all 3rd arty process disable and do not manually start them. Then, wait for a period of time and check the resource(CPU) usage. If problem does not happens again, you can try to narrow down the problem during 3rd party process.

    Perform a clean startup to determine whether background programs are interfering with your game or program:
    https://support.microsoft.com/en-ca/help/331796/perform-a-clean-startup-to-determine-whether-background-programs-are-i

    for Windows Update problem, KB4093120 has been replaced by KB4103720, please try to manually install KB4103720 and check the result:
    1. Download KB4103720 from below link:
    https://www.catalog.update.microsoft.com/Search.aspx?q=KB4103720

    2. Double click to install it.

    If it failed, please provide me the detail error message. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 28, 2018 6:08 AM
    Moderator

All replies

  • Hi,

    First, I would recommend you to check/update hardware drivers, including firmware, BIOS and etc. make sure that appropriate driver version which is applied to Windows Server 2016 Essentials has been installed.

    Besides, if possible, please try to re-start system in Clean Boot, with all 3rd arty process disable and do not manually start them. Then, wait for a period of time and check the resource(CPU) usage. If problem does not happens again, you can try to narrow down the problem during 3rd party process.

    Perform a clean startup to determine whether background programs are interfering with your game or program:
    https://support.microsoft.com/en-ca/help/331796/perform-a-clean-startup-to-determine-whether-background-programs-are-i

    for Windows Update problem, KB4093120 has been replaced by KB4103720, please try to manually install KB4103720 and check the result:
    1. Download KB4103720 from below link:
    https://www.catalog.update.microsoft.com/Search.aspx?q=KB4103720

    2. Double click to install it.

    If it failed, please provide me the detail error message. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 28, 2018 6:08 AM
    Moderator
  • Eve,

    I've installed KB4103720 without problems. Just finished now after 5 hours.
    I restart again Windows Update services and it seems the problem has solved. CPU is working normal, the server is working fast.

    I'm going to pay attention few days and inform you.

    Thanks

     

    Monday, May 28, 2018 4:07 PM
  • Hi,

    Thank you for taking the time to share the result.

    Please remember to click “Mark as answer” if any of above reply is helpful. It would make this reply to the top and easier to be found for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 29, 2018 7:10 AM
    Moderator
  • Hi Eve,

    Tonight I've connected to the server, and again 100% of the cpu used. I've had problems with Iperius software (to make backups), I stopped it, restart, and again the server and the use of cpu was ok

    But I've taken a look to Events Viewer, all seems ok unless Security. There are a lot of Auditory Errors, event 4625, about 10 per minute. Is this a problem? may I solve it? how?

    Thanks very much


    mblascog

    Tuesday, May 29, 2018 9:49 PM
  • Hi,

    Event ID 4625 generates if an account logon attempt failed when the account was already locked out. It also generates for a logon attempt after which the account was locked out.

    If this event logged regularly, please check detail information on the event and confirm if it provide information about logon attempt, such as account, source address. 

    4625(F): An account failed to log on:
    https://docs.microsoft.com/en-us/windows/security/threat-protection/auditing/event-4625

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, June 1, 2018 6:30 AM
    Moderator
  • Hi, I can't believe I'm the only person in the world whose Server 2016 Essentials is going slowly. There is no way to know what happens. I wanted to believe the problem was with Windows Update, but I was wrong. If I take a look to Task Administrator when there is nobody working, the usage of cpu is between 10 and 30%. I think it's not normal.

    I restarted the server last weekend. Till wednesday more or less it was ok, the usage of cpu sometimes was 100% but quickly slow. This morning was fix, 100% and we had to restart the server. Now is going well again, but till when?

    Please till now I've worked with Server 2012 and all was fine. My first experience with Server 2016 and I've got a big headache.

    Is there anyway to know the detail of the use of cpu during last week, last month. Please any idea?

    Thanks


    mblascog

    Friday, June 8, 2018 6:29 PM
  • Do you see the CPU spike with Windows Server Essentials Storage Service running?

    Is the smbsvcs process taking the CPU?

    You can try re-configuring SMB Configuration on 2016 Server as per below article

    https://docs.microsoft.com/en-us/windows-server/administration/performance-tuning/role/file-server/smb-file-server


    Tuesday, June 26, 2018 11:03 PM
  • I too am having this same problem with high cpu usage on the Windows Essentials 2016 Dashboard.  If it is left open, even with no activity, it will eventually hog everything and bring any other server processes to their knees (like client or server backups).

    All updates are current as of 10/12/2018 as well as all drivers.

    Ideas????

    Thanks,

    P3QS008

    Friday, October 12, 2018 1:49 PM
  • My Windows Server 2012r2 Essentials has been running at 100% CPU for several days now.  It seems able to manage incoming requests.  Virtually all of the CPU is in the Dashboard, which is all I use.  No added software, just Essential shared folders and client backup.

    One clue:  maybe a week ago I deleted a lot of large files, about 4 TB in total from shared folders.  All the data is on a RAID5 4TBx4 array.  The first time I built the array it took maybe two days to build but when I had to clean reinstall WS2012r2 it took maybe 4 days to re-connect to the RAID array.



    Eric Robert Lewis, Ph.D.

    Monday, December 17, 2018 11:28 PM