locked
Cant sign in to Microsoft Account RRS feed

  • Question

  • I have recently installed Windows 10 onto my PC. I can't log into my account, every time I select "Log In" the prompt closes and nothing happens. I can type the password correctly and incorrectly and an "incorrect password" prompt doesn't even show up. just straight up closes. I doubt it has to do with my account. can log in elsewhere, just not into windows 10.

    Edit: Even when I try to create a new account, halfway through typing in new information, the prompt closes again. really frustrating. Any Ideas? :(

    Thursday, July 30, 2015 2:06 AM

Answers

  • SOLVED!!!

    I had to do nearly everything in this post:

    social.technet.microsoft.com/Forums/en-US/694058fe-0351-4414-b3cc-27703d1da8db/cant-add-my-microsoft-acct-to-my-domain-acct-on-windows-10-build-10162?forum=WinPreview2014Setup

    1.) Delete any fragments of Microsoft account sign-ins. (start, settings, accounts, "other accounts you use")

    2.) Next, delete any local accounts that are specific to Microsoft accounts.  (start, user accounts, manage user accounts, delete the Microsoft account if applicable).  Make sure you add a LOCAL admin or domain admin account so you can still login)

    3.) Change your group policy GPO.  Start, edit group policy,

    Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies/Security Options/Other/Accounts: Block Microsoft Accounts

    Try blocking that from applying to the computer and instead applying a GPO with that setting set to "This policy is disabled."

    4.) Edit your registry

    HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\StoredIdentities

    Here, you will see the account that is giving you trouble.  Delete (Right click the email address and click delete).

    5.) Settings, Accounts, add your Microsoft account back in. 

    6.) Fixed.

    • Marked as answer by Karen Hu Sunday, August 2, 2015 8:20 AM
    Friday, July 31, 2015 3:10 PM

All replies

  • I can't log in at all in any of the native Windows 10 apps. I can log in via the web browser, but if I go to the store, xbox, onenote apps, etc it doesn't even let me type in my credentials to sign in.
    Thursday, July 30, 2015 2:14 AM
  • Having the same issue, logins to Cortana failed, every time I click search it says "Let's pick up where you left off" and then prompts me to login.  I also tried adding the account in user account controls and it has the same behavior. It acts like the validation happened, but nothing changes and the Microsoft account is not added in. 

    I'm running a Dell Latitude E7450 upgraded from 8.1 Pro.  I am logged into a work domain.  I am able to login to Microsoft properties without issue from web browsers and other devices.  

    Potentially related:  If I login to my Microsoft Account, (account.microsoft.com) it does not show my devices (Xbox, Surface, Laptops) under the main devices section.  However, my surface and pc that is having this account issue is listed under "Apps & Games Devices"

    Other notes:

    An old tech article (for preview build) recommended sfc /scannow as admin from Command Prompt.  That did nothing.

    It also suggested running this in powershell:
    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    This also did nothing, except the next time I tried to login to Cortana it asked me if it can use my location.

    Edit:

    If I login to any other Microsoft apps (store, weather, etc) I am also presented the option to login to my Microsoft account.  It will accept the login, and ask if I want to make it my default account system wide, if I say yes, I get "We're sorry, but we weren't able to make this Microsoft account your default account for Windows.  Don't worry, we will sign you into this app.  If you want to use this account to sign in to Windows, you can set that up in the Accounts section of Settings."

    Thursday, July 30, 2015 1:18 PM
  • SOLVED!!!

    I had to do nearly everything in this post:

    social.technet.microsoft.com/Forums/en-US/694058fe-0351-4414-b3cc-27703d1da8db/cant-add-my-microsoft-acct-to-my-domain-acct-on-windows-10-build-10162?forum=WinPreview2014Setup

    1.) Delete any fragments of Microsoft account sign-ins. (start, settings, accounts, "other accounts you use")

    2.) Next, delete any local accounts that are specific to Microsoft accounts.  (start, user accounts, manage user accounts, delete the Microsoft account if applicable).  Make sure you add a LOCAL admin or domain admin account so you can still login)

    3.) Change your group policy GPO.  Start, edit group policy,

    Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies/Security Options/Other/Accounts: Block Microsoft Accounts

    Try blocking that from applying to the computer and instead applying a GPO with that setting set to "This policy is disabled."

    4.) Edit your registry

    HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\StoredIdentities

    Here, you will see the account that is giving you trouble.  Delete (Right click the email address and click delete).

    5.) Settings, Accounts, add your Microsoft account back in. 

    6.) Fixed.

    • Marked as answer by Karen Hu Sunday, August 2, 2015 8:20 AM
    Friday, July 31, 2015 3:10 PM
  • Hi Jesse,

    Have you tried the methods that StrategicSourceror provided?

    If no, please have a try.

    If yes, please tell us your current situation in order to know if you need further help.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Sunday, August 2, 2015 8:22 AM
  • Solved in a much easier way...

    I went into settings, accounts, family and other users, add someone else to this PC.  Used the email address that's linked to the Microsoft account you want to use.  Sign out of local account and log in to Microsoft account.

    Note:  Before you delete the old local account, copy files from the old account to the new one.


    • Edited by HtcofOttawa Monday, August 3, 2015 9:35 PM
    • Proposed as answer by HtcofOttawa Monday, August 3, 2015 9:35 PM
    Monday, August 3, 2015 9:31 PM
  • I have followed the 4th step

    4.) Edit your registry

    HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\StoredIdentities

    Here, you will see the account that is giving you trouble.  Delete (Right click the email address and click delete).

    but I couldn't find my email address there, I can see only "(Default) with type REG_SZ and data (value not set)"

    it would be great if you help me out in this

    thanks in advance :)

    Friday, August 7, 2015 5:14 PM
  • I have followed the 4th step

    4.) Edit your registry

    HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\StoredIdentities

    Here, you will see the account that is giving you trouble.  Delete (Right click the email address and click delete).

    but I couldn't find my email address there, I can see only "(Default) with type REG_SZ and data (value not set)"

    it would be great if you help me out in this

    thanks in advance :)

    I have the exact same problem...
    • Proposed as answer by jwitalka Saturday, September 5, 2015 3:40 PM
    Tuesday, August 11, 2015 2:49 PM
  • I have followed the 4th step

    4.) Edit your registry

    HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\StoredIdentities

    Here, you will see the account that is giving you trouble.  Delete (Right click the email address and click delete).

    but I couldn't find my email address there, I can see only "(Default) with type REG_SZ and data (value not set)"

    it would be great if you help me out in this

    thanks in advance :)

    I also have the same issue

    Tuesday, August 11, 2015 4:12 PM
  • Went strait to step 4, and it worked. it worked.  Whoo hoo!  Thank you for this post.
    • Proposed as answer by Lynnard1 Thursday, August 13, 2015 12:29 AM
    Thursday, August 13, 2015 12:28 AM
  • I have the same problem.  There is no email address or account listed in the Registry.

    To review, I have an individual computer not tied into any group and I am the only user.

    What is frustrating is that the system worked just fine for a few days after installing Windows 10 last week. 

    Now Cortana keeps telling me I must sign in with a Microsoft Account.  I have one! I actually COULD do this.  I click on the sign-in and get a gray blank screen that quickly disappears.  

    Every possible sign-in area either results in nothing or in the quickly disappearing gray blank screen.

    There are no fragments of Microsoft accounts in my system.

    I have looked at all possible solutions on the internet. I have seen others with my problems but have found no solutions.

    UPDATE 1:25 AM 8/17/2015:  
    I had tried the solution listed on 

    https://www.techmesto.com/fix-start-menu-broken-windows-10-technical-preview/

    last week to no avail.  

    After posting here, I thought I would try repeating the steps there because there had been another Windows 10 update since I last tried it.  

    No change. Cortana just kept producing the gray blank screen again.  

    However, an hour later, without my doing anything else, Cortana "spoke up" and asked me to sign in.  I clicked on the "sign in" and lo and behold, it worked. 

    I have no idea if Cortana's reappearance and my ability to sign in to my Microsoft account were due to running the PowerShell as directed on that page, but someone might find it to be helpful.

    The steps listed there (after doing some back-up) are to...

    1. Open Windows PowerShell as Administrator
      1. Right click Start button
      2. Choose Command prompt (Admin)
      3. Key in Powershell in the black window and hit Enter
    2. Paste the following command in the Administrator: Windows PowerShell window and press Enter key:
      Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    3. Wait for PowerShell to execute and complete the command. Ignore the few errors (in red color) that may pop up.
    4. When it finishes, try hitting Start.



    • Edited by AndreaZoe Monday, August 17, 2015 5:36 AM
    • Proposed as answer by SirobTO Saturday, August 22, 2015 12:18 AM
    Sunday, August 16, 2015 2:50 PM
  • Didnt work :(

    Tuesday, August 18, 2015 10:14 AM
  • Works for me! Thank you.
    Saturday, August 22, 2015 12:18 AM
  • Holy fuck Thank you Soo Much this worked . FUCK I LOVE YOU 
    Wednesday, September 2, 2015 2:00 PM
  • awesome..thank you so much...

    Thursday, September 3, 2015 2:50 PM
  • None of the above worked for me.
    • Proposed as answer by Smart phone 7 Monday, April 8, 2019 1:59 PM
    Saturday, September 5, 2015 7:03 AM
  • I have done every step listed in the solution at the beginning of this thread but Cortana wizard won't proceed past the password phase. I enter my local Windows password and the log in prompt goes away and... nothing else happens.
    Sunday, September 27, 2015 10:38 AM
  • what is registry,how to access it.


    Monday, February 8, 2016 7:52 AM
  • Thank you this works!!!
    Sunday, April 3, 2016 8:46 PM
  • Thank you so much man, it worked !
    Friday, July 22, 2016 3:02 PM
  • Look in family and other people section and see if MS account you trying to switch to listed there. If it is probably says can't sign in. Click on it and change to allow.

    That's all I had to do to fix it!

    Saturday, August 6, 2016 4:50 AM
  • The new update (anniversary update) caused my account to not work when signing in. It would sign in with temporary account and say couldn't sign in, if you sign back out it should fix it or something like that but when I did it did not. I rebooted and everything and still the same. Tried local account and still same.


    My Solution:

     Go to C:\Windows\System32\Sysprep\sysprep.exe and run it. Reboot and when it asks if this is you say no. When all done you can sign in as normal.


    I'm not completely certain for why this works but it is by far the easiest solution.


    Michael J. Hall

    Friday, August 12, 2016 6:20 PM