none
LocalGPO on Win8/Server 2012 RRS feed

  • Question

  • Yes I realize that Win8/Server 2012 have not RTM'd yet, but the localGPO tool refuses to add the MSS settings to my Server 2012 RC instance. How soon can we expect an update to SCM to support Win8/Server 2012, even sans the security baselines?
    Sunday, July 8, 2012 2:50 AM

Answers

All replies

  • Derek;

    We're working on it, we hope to have final releases of the Windows 8 and Windows Server 2012 baselines and tools ready for the launch in October but things are tight and we may be a bit late. You should consider joining our project on Connect so that you can get access to prerelease versions when they become available: https://connect.microsoft.com/site715/InvitationUse.aspx?ProgramID=2682&InvitationID=SCM2-HKHB-4DXM.

    Regards,

    Kurt


    Kurt Dillard http://www.kurtdillard.com

    Friday, August 10, 2012 7:20 PM
    Moderator
  • OK, so SCM 3.0 was released, with support for Windows 8 and Windows Server 2012... however the LocalGPO tool provided with SCM 3.0 does not recognize nor support Windows 8.1 and Windows Server 2012 R2.  If you try to run the LocalGPO.wst script, it presents an error.

    I'm willing to bet that the new Windows 8 & Windows Server 2012 SCE modification support added with SCM 3.0 is also fully compatible with Windows 8.1 and Windows Server 2012 R2, so all it would take is a simple update of the LocalGPO.wsf file to include detection for the newer OSes (version 6.3 detection to add to the existing version 6.2 detection), and point the script to the same installation steps as Windows 8 and Windows Server 2012.

    Thoughts?

    (Hint: I've already modified my copy of LocalGPO.wsf myself to do exactly this, and it works great - but it would be nice to have it done by Microsoft, officially!)

    Thursday, April 3, 2014 8:49 PM
  • I'm not sure if they've released a modified copy yet, but I had to do the same thing EdgeDC did.  I modified my copy of LocalGPO.wsf and inserted a line for OpVer 6.3 and pointed it to "WS12" as the line below it does for OpVer 6.2.  It worked fine and let me import my settings that I created in Server 2012 R1.

    Tuesday, April 15, 2014 7:05 PM
  • Update on this old one... Microsoft is finally addressing this issue and has created the ADMX template MSS-legacy.admx/.adml in their latest SCM release... so we won't have to mess with the LocalGPO.wsf script & SCE settings any more.

    The new ADMX template adds a new GPME section:

    Computer Configuration / Policies / Administrative Templates / MSS (Legacy)

    ...and all of those old settings we came to know and love/hate are there. :)

    Friday, October 16, 2015 10:20 PM