locked
Win 8 DirectAccess - Where's the "Use Local Name Resolution" option in NCA? RRS feed

  • Question

  • We're using Server 2012 + Win 8 DirectAccess.  Using Win7's DA Connectivity Assistant, there was a "Use Local DNS" option, which effectively disables DirectAccess.

    In Server 2012's DA wizard, we've enabled the "Allow DA clients to use local name resolution" option.  Yet after subsequently applying this GPO and rebooting, we still don't see any such option in Win8's Network Connectivity Assistant.  How do I enable local name resolution (bypass the NRPT) in Win8?  Am I missing something?





    • Edited by Calliper Sunday, January 19, 2014 7:13 PM
    Wednesday, March 20, 2013 3:39 PM

Answers

  • I've found it.  There's a Connect\Disconnect button in the Networks list next to the DirectAccess network.  When pressing the Connect button, it connects instantly, so is clearly just re-enabling the NRPT rather than re-establishing the DA tunnels.



    • Marked as answer by Calliper Wednesday, March 20, 2013 7:07 PM
    • Edited by Calliper Sunday, January 19, 2014 7:13 PM
    Wednesday, March 20, 2013 7:07 PM

All replies

  • I've found it.  There's a Connect\Disconnect button in the Networks list next to the DirectAccess network.  When pressing the Connect button, it connects instantly, so is clearly just re-enabling the NRPT rather than re-establishing the DA tunnels.



    • Marked as answer by Calliper Wednesday, March 20, 2013 7:07 PM
    • Edited by Calliper Sunday, January 19, 2014 7:13 PM
    Wednesday, March 20, 2013 7:07 PM
  • Correct. And just further information for anyone else reading this post. Using either the "Disconnect" or "Use Local DNS" options don't actually disable DirectAccess, they simply disable name resolution from happening over the DirectAccess tunnels temporarily. The tunnels remain established in the background, so management functions and IT's ability to maintain these machines remains intact even if the user chooses to disable name resolution.
    Wednesday, March 20, 2013 8:47 PM