locked
Extend the size attach file by default 18MB - EXChange 2016 RRS feed

  • Question

  • Dear everyone !
    I was setup exchange 2016, i was config Maximum receive/send message with 25MB.

    I was get-TransportConfig for "MaxDumpsterSizePerDatabase" is 25MB ( this is just support for exchange 2010, not exchange 2016)

    So, Can you help me config exchange, users can attach file when use webmail owa are 25MB ( file attach ) ?

    I was follow this link : https://support.microsoft.com/en-in/kb/2957856 ( not do )

    https://technet.microsoft.com/en-us/library/hh529949(v=exchg.150).aspx (not do )

    https://technet.microsoft.com/en-us/library/bb124151(v=exchg.160).aspx

    Thanks .



    Tuesday, October 11, 2016 7:46 AM

Answers

  • Hi,

    Have you followed above link to edit the Web.config file on a Client Access server to enable large messages to be sent by using Outlook Web App?

    Also run the command below to check the settings:

    get-mailbox user |ft Name, Maxsendsize, maxreceivesize

    Get-SendConnector | ft name, MaxMessageSize

    In addition, for message size limits on owa, The value are approximately 33% larger than the actual usable maximum message size because of the overhead that's associated with Base64 encoding.  For example, if you specify a maximum message size value of 64 MB, you can expect a realistic maximum message size value of approximately 48 MB.

    Regards,


    David Wang
    TechNet Community Support


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 12, 2016 7:39 AM
  • Thank for all support !

    I was using EXchange Management Shell set size value 

    • Set-TransportConfig -MaxReceiveSize 35MB -MaxSendSize 35MB

    Use can attach file with value is 26MB ( 74% ) value so i was set for SendSize.

    Don't need edit file web.config. Just need are set value in EX MNG Shell.

    Thanks. 

    Wednesday, October 12, 2016 8:28 AM

All replies

  • Apart from changing the Transport limits, you need to adjust the client-side limits as detailed in the second article. For Outlook, you need to play with the registry settings:http://www.slipstick.com/outlook/email/outlook-2010s-default-attachment-size/
    Tuesday, October 11, 2016 8:27 AM
  • Dear @Vasil L. Michev !

    This isn't case for outlook client, it is webmail /OWA with EXChange server 2016

    Thanks !



    Tuesday, October 11, 2016 8:36 AM
  • Please follow instructions in this article Error when adding large attachment in Outlook on the Web

    There is a default 10 mb limit for OWA and you can change it by editing OWA Web.config file.
    Tuesday, October 11, 2016 8:42 AM
  • Dear BearEater !

    I was try to follow this link https://support.microsoft.com/en-in/kb/2957856  and link https://technet.microsoft.com/en-us/library/hh529949but default 10bm limit, then exchange 2016 default is 18MB, why is this ?

     <readerQuotas maxStringContentLength="102400" />

    Thanks


    Tuesday, October 11, 2016 9:35 AM
  • Dear  Hồng Chương,

    There is a mailtip on your screenshot.
    Following is true for Exchange 2013, but I believe same is true for 2016 also:

    The MailTip is displayed if the message size violates one of the following size restrictions:
    Maximum send size setting on the sender's mailbox
    Maximum receive size setting on the recipient's mailbox
    Maximum message size restriction for the organization

    You should check restrictions on sender's and recipient's mailboxes and message size restriction for the organization (message size limits on the connectors aren't taken into account by mailtips):
    Get-Mailbox <MailboxIdentity> | ft Name, Maxsendsize, maxreceivesize
    get-transportconfig | ft maxsendsize, maxreceivesize 

    Thanks


    Tuesday, October 11, 2016 10:18 AM
  • Dear BearEater !

    This my screenshot after I  "get-transportconfig | ft maxsendsize, maxreceivesize "

    Tuesday, October 11, 2016 10:51 AM
  • Hi,

    Have you followed above link to edit the Web.config file on a Client Access server to enable large messages to be sent by using Outlook Web App?

    Also run the command below to check the settings:

    get-mailbox user |ft Name, Maxsendsize, maxreceivesize

    Get-SendConnector | ft name, MaxMessageSize

    In addition, for message size limits on owa, The value are approximately 33% larger than the actual usable maximum message size because of the overhead that's associated with Base64 encoding.  For example, if you specify a maximum message size value of 64 MB, you can expect a realistic maximum message size value of approximately 48 MB.

    Regards,


    David Wang
    TechNet Community Support


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 12, 2016 7:39 AM
  • Thank for all support !

    I was using EXchange Management Shell set size value 

    • Set-TransportConfig -MaxReceiveSize 35MB -MaxSendSize 35MB

    Use can attach file with value is 26MB ( 74% ) value so i was set for SendSize.

    Don't need edit file web.config. Just need are set value in EX MNG Shell.

    Thanks. 

    Wednesday, October 12, 2016 8:28 AM