none
DPM 2012 R2 Not Using Expired Tapes RRS feed

  • Question

  • We've installed a fresh copy of DPM 2012 R2 on a Windows 2012 R2 server with two HP LTO5 stand-alone tape drives attached.

    We've got one set of optimized PG's being backed up long term to one of these drives and one set to the other drive(short term goes to disk).

    All of the retention parameters match for all of these PGs in the optimized sets.

    The Tape co-location parameters are:

       Write period: 7 days

       Expiry Tolerance: 7 days

    We've got two sets of daily backup tapes and the retention range for the backups is 7 days.

    We have been running this configuration successfully for about 6 months on this version and on DPM 2010 for longer that that.

    Recently - we've been receiving the following error on one of the drives, but not the other(backups on the other drive re-use expired tape and run to completion - no issues):

    The back up to tape job failed for the following reason: (ID: 3311) Failed to perform the operation since the tape free tape is not available in Stand Alone Drive Tape Library Hewlett Packard LTO Ultrium-5 drive-2 (ID: 24050)

    The tape inventory of the tape before it's use shows the tape as expired, but each member of the job sits for an hour throws this error and fails

    We'll cancel the rest of the pending jobs after several fails and there's always .13MB on the expired tape just used.

    if we force free the tape and re-queue the member backups it runs to completion without any issues.

    There's no physical errors shown on the tape drive or any of the tapes and searching the logs doesn't show any 8007045D errors at all.

    Any Help as to the cause of this would be most appreciated!

    Any suggestions we might try?



    • Edited by stangr Tuesday, November 3, 2015 3:27 PM
    Thursday, October 29, 2015 7:47 PM

All replies

  • I have a similar thing happening as follows:

    • there are three tapes in the library with status "Tape available" and blank "Offsite Ready"
    • by invoking "View Tape Contents" I can see that the "expires on" date of all items on each tape are 2015-12-27 or earlier
    • there are no 0x8007045D errors in the logs
    • Each backup job scheduled for 2016-01-05 failed with error 3311 "Failed to perform the operation since the tape free tape is not available in Tape Library IBM TotalStorage 3563 Tape Library (ID 24050)".  These failures occurred approximately one hour apart.
    • invoking "Mark Tape as Free" on a tape containing only items with "expires on" dates that have passed results in error 31116 "The selected tapes cannot be marked as free because they belong to protection groups."
    • Calling Remove-RecoveryPoint for all the recovery points on a tape causes "Offsite Ready" for that tape to become "Expired"
    • Remove-RecoveryPoint reported several messages similar to "Datasource 'master' on computer SCCM01: Saturday, November 14, 2015 8:06:10 PM The operation will remove the following recovery point(s) because they have dependencies on each other: Datasource 'ReportServer$SCCM01' on computer SCCM01: Saturday, November 14, 2015 8:03:20 PM"
    • Once the tape is marked as "Expired" invoking "Resume Tape Backups" for each of the protection groups seems to cause the backups to occur as expected.

    I am running 4.2.1373.0 which is DPM 2012 R2 UR8.

    Why aren't the tapes containing only items with "expires on" dates in the past being marked as "Expired"?

    Stangr, did you make any progress with this error?

    Tuesday, January 5, 2016 9:20 PM
  • Hello, alx9r! Please show us a screenshot of recovery points located at one of these tapes.

    https://exchange12rocks.org/ | http://about.me/exchange12rocks

    Thursday, January 7, 2016 6:16 AM
  • Hi Kirill,

    Here is the screenshot of the "View Tape Contents" dialog box for one of the affected tapes:

    and here is the same tape in the "Libraries" view:

    Thursday, January 7, 2016 9:39 PM