none
FIM 2010 R2 SP1 Quickstart tool authentication error - please help!?? RRS feed

  • Question

  • Hello fellow FIMsters,

    Anybody run into the issue of running the quickstart tool to provision the password registration / reset portals and have the script fail with the following output?:

    "failed to connect to the specified database or forefront identity management service"

    Event ID 3:

    Log Name:      Forefront Identity Manager Management Agent
    Source:        ForefrontIdentityManager.ManagementAgent
    Date:          4/16/2013 2:36:48 PM
    Event ID:      3
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      <computer fqdn>
    Description:
    mmsmafim: MIIS.ManagementAgent.ManagedMACredentialFailureException: The credentials provided for accessing Forefront Identity Manager are invalid
       at MIIS.ManagementAgent.Context.WindowsIdentityImpersonationFactory..ctor(String user, String password, String domain)
       at MIIS.ManagementAgent.RavenMA.InitializeConnection(XmlNode connectionInformationNode, XmlNode encryptedAttributeNode, Boolean runInitialization)
       at MIIS.ManagementAgent.RavenMA.UIInitialize(String pszInitString, Int32& pfValid, String& ppszResult)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="ForefrontIdentityManager.ManagementAgent" />
        <EventID Qualifiers="0">3</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-04-16T18:36:48.000000000Z" />
        <EventRecordID>68</EventRecordID>
        <Channel>Forefront Identity Manager Management Agent</Channel>
        <Computer><computer fqdn></Computer>
        <Security />
      </System>
      <EventData>
        <Data>mmsmafim: MIIS.ManagementAgent.ManagedMACredentialFailureException: The credentials provided for accessing Forefront Identity Manager are invalid
       at MIIS.ManagementAgent.Context.WindowsIdentityImpersonationFactory..ctor(String user, String password, String domain)
       at MIIS.ManagementAgent.RavenMA.InitializeConnection(XmlNode connectionInformationNode, XmlNode encryptedAttributeNode, Boolean runInitialization)
       at MIIS.ManagementAgent.RavenMA.UIInitialize(String pszInitString, Int32&amp; pfValid, String&amp; ppszResult)</Data>
      </EventData>
    </Event>

    I have just about tried everything to get past this issue - I would be much appreciative if somebody who has run into this issue can help me out - thank you

    Tuesday, April 16, 2013 7:52 PM

All replies

  • If anyone has been successful running the quickstart tool can you please share your experience? Specifically as it relates to provisioning AD user objects to be used for both the -ActiveDirectoryManagementAgentCredential and the -ForefrontIdentityManagerManagementAgentCredential parameters in the "invoke-quickstart" command? Are there special rights either of these AD user objects need and how could I further troubleshoot the error I posted above that states that "the credentials provided for accessing Forefront Identity Manager are invalid"???

    Thank you for your help

    Wednesday, April 17, 2013 1:25 AM