locked
Adding .net framework 3.5 after deployment RRS feed

  • Question

  • Hi,

    Is it possible to enable the optional .net framework 3.5 feature to an existing Windows 10 environment?

    I have tried to add this by using a startup PowerShell script by Group Policy with the following command:

    Enable-WindowsOptionalFeature –Online –FeatureName NetFx3 –All

    It works when I type it manually on each machine, but doesn't seem to do anything as a startup script.  Can the system user enable optional features at startup? Am I missing any required settings or permissions?

    How do I go about troubleshooting a startup script?  In rsop.msc it lists the script as being successful!

    Thanks,

    Paul

    Thursday, September 8, 2016 9:38 AM

Answers

  • I eventually got this working by using dism in powershell instead.

    This was the command I used:

    dism /online /Enable-Feature /FeatureName:NetFx3 /Source:\\servername\Win10SxS /LimitAccess

    Thanks anyway,

    Paul

    Monday, September 12, 2016 9:27 AM

All replies

  • Hi Paul,

    According to your description, there is no doubt that your PowerShell script is correct, what we need to do is make it work.

    I suspect that permission issue leads to your script doesn’t work, it may not be executed as administrator. We can try use Computer Start Script use to see if let script work normally, refer to this link below for more information.

    Assign Computer Startup Scripts

    https://technet.microsoft.com/en-us/library/cc770556(v=ws.11).aspx

    Besides, there is a documentation introduces how to Deploy the .NET Framework by Using Active Directory, please have a look.

    https://msdn.microsoft.com/en-us/library/kz6tzdt1(v=vs.90).aspx

    Sincere regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 9, 2016 1:10 AM
  • I eventually got this working by using dism in powershell instead.

    This was the command I used:

    dism /online /Enable-Feature /FeatureName:NetFx3 /Source:\\servername\Win10SxS /LimitAccess

    Thanks anyway,

    Paul

    Monday, September 12, 2016 9:27 AM
  • Hi Paul,

    Glad to hear this issue has been solved by yourself. Thanks for sharing, hope your experience will help other community members facing similar problems.

    Kindly mark your reply to close this case


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 22, 2016 9:49 AM