none
Default RCDC xml files RRS feed

  • Question

  • I'm looking for a way to reset some RCDC settings back to defaults.  Specifically the "view set"and "edit set" RCDC have been broken.  Anyone have a pointer where I can download the default RCDC xml files for FIM2010?

    I know that I can download the default edit mode templates but they contain minimal formatting to get it working and I would prefer to restore to the original XML from Microsoft.

    Wednesday, August 15, 2012 4:42 PM

Answers

All replies

  • OK - let me see if I can ask this a different way. :D

    Could someone, who has not edited these RCDC files, send me a copy of their 'Set' files?

    1. Administration | Resource Control Display Configuration
    2. Open the RCDC 'Configuration for Set Creation'
    3. Click 'Export configuration'
    4. Save the xml file
    5. Repeat steps 2-4 for 'Configuration for Set Viewing' and 'Configuration for Set Editing'

    You can email them to protoluke [at] gmail.com

    Friday, August 17, 2012 5:06 PM
  • https://skydrive.live.com/#cid=A78AC98D2861ED9A&id=A78AC98D2861ED9A%21119

    I've uploaded them there. Hopefully, you can access them. They are for R2, but might work. My copy of 2010 is past the eval period.

    Thanks,

    Sami


    • Edited by SamiVV Friday, August 17, 2012 8:52 PM
    • Marked as answer by Pr0t0luke Monday, August 20, 2012 11:59 AM
    Friday, August 17, 2012 7:49 PM
  • SamiVV!

    Looks like this is getting me back to where I need to be.  Thank you!

    Monday, August 20, 2012 11:59 AM
  • Glad to help. :)
    Monday, August 20, 2012 12:02 PM
  • SamiVV,

    Not to hijack the post too much... but

    After importing the xml's you attached the option 'enable criteria-based membership in current set' is greyed out.  I am running FIM2010R2, so the xml files you posted were for the correct version.  I checked the MPR for Sets and everything looks good (Administration: Administrators control set resources).  Though I've looked at them way too many times.

    The checkbox is available when creating a group.  I must be missing some MPR somewhere.
    • Edited by Pr0t0luke Monday, August 20, 2012 1:49 PM Addition
    Monday, August 20, 2012 1:45 PM
  • Hi Pr0t0luke,

    Sorry for the delayed reply--I'm on the road and without lab access right now. In your "Administration: Administrators control set resources" MPR, is the membershipLocked attribute in the allowed attributes? (I think that's what it's called--that's it in the groups.)

    When I can get to a lab environment, I can check for you.

    Thanks,

    Sami


    Edit: also check the attributes in the "Advanced" view, "Extended Attribtues" of the set.
    • Edited by SamiVV Wednesday, August 22, 2012 1:44 AM
    Tuesday, August 21, 2012 7:49 PM
  • The "Administration: Administrators control set resources" MRP did _not_ contain the membershipLocked attribute, adding it did not resolve the issue.  I also checked the Advanced views and they looked correct (ie the new attribute was added and settings were similar).  For additional testing I temporarily changed the MPR to use 'All attributes'.  This did not resolve the issue either.

    Based on these result I thought that maybe there is different MPR we need to consider.  I reviewed at all the old requests when I changed anything about a set and the only MPR I saw that was used was this "Administration: Administrators control set resources"

    Wednesday, August 22, 2012 11:40 AM
  • Hi,

    Not sure this helps, but I was able to recreate this... If I created a set as Manual membership then removed the members, the checkbox to enable criteria based membership always stays greyed out.

    Perhaps you could use PowerShell to change the Set Type?

    Thanks,

    Sami

    Thursday, August 23, 2012 4:21 PM
  • Interesting thought - though this does happen with all of the sets.  I'll check the set types shortly.
    Thursday, August 23, 2012 4:42 PM
  • you have to go to avanced view and manualy edit the filter with a criteria based xpath that works....hit submit and it will change it.  Then you can go back into the set, view criteria based and make the correct change there.
    • Proposed as answer by gdtilghman Thursday, August 23, 2012 4:53 PM
    • Unproposed as answer by Pr0t0luke Thursday, August 23, 2012 5:22 PM
    Thursday, August 23, 2012 4:53 PM
  • I would have to do this on every single set?  That just doesn't seem right.

    Thursday, August 23, 2012 5:23 PM
  • seeming right or not....it is the way it is.  I've only had this happen a few times to me.  I didn't blank out manually managed membership on all my sets....just a few.

    In your case, the reloading of the XML's has apparently caused you some frustration and I'd be happy to know if you could manage this globally once.

    Thursday, August 23, 2012 5:37 PM
  • A bit late on this reply, but PowerShell might help you here. You could try something like this script: http://social.technet.microsoft.com/Forums/en-US/ilm2/thread/63dcd915-c92d-4fa2-8183-45e2db601693
    Wednesday, August 29, 2012 2:38 PM