none
How to Install Windows 7 on EFI system using GPT disk using MDT 2010 Update 1

    Question

  • I'm trying to apply the first image from MDT 2010 Update 1 to a HP Elite 8200 SFF workstation. This workstation will become my reference machine, on which I will try to generate my reference image.

    When booting from the WinPe iso generated from my MDT workbench I get the following error:

    "Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed to GPT disks."

    I started looking into this issue, as EFI/GPT etc is new to me.

    -In the bios there is no option to choose between EFI or BIOS boot.

    -From the Boot Order option I can enable/disable the EFI sources and/or the Legacy devices.

    -The system disk is listed as legacy device.

    -Disabling the EFI sources doesn't change the behaviour.

    After reading the web I found, on technet, the article called: Create UEFI-based Hard-Disk Partitioned by Using Windows SIM.

    I edited the unattend.xml for the used image from the MDT Workbench. So after the the Format and Partition step from the task sequence (creating 2 MBR partitions) the disk is wiped and 3 partitions GPT based are generated (I verified (DISKPART) that this happens in the end).

    Now, however, the process of applying the image to my reference machine (using the updated WinPe iso from MDT Workbench) stops with the error (to my frustration/surprise):

    "Windows cannot be installed to this disk. The selected disk is of the GPT partition style"

    So, what next??

    I also found the entry on this forum called: "How-To install 2008 R2 on UEFI systems using GPT disk using MDT 2010 with Update 1". I'm not sure how/whether this is applicable to Windows 7 too. I seem to have no problem to create the 3 partitions from the unattend.xml. Just removing the "Format and Partition Disk" step doesn't sound sufficient.

    Any clues on how to persuade MDT to install the image to the GPT disk?

    The entry, on 2008 R2 in this forum, also mentions to boot your UEFI system using "Legacy Mode" when using MBR based (system)disk. Should this option be there, on all UEFI based systems? I've not found anything in the BIOS, where should I look for?? 

    Andy



    • Edited by Andy Komen Monday, November 07, 2011 8:45 AM
    Monday, November 07, 2011 8:43 AM

All replies

  • Andy,

    Take a look at this blog for some background information.

    http://blogs.technet.com/b/mniehaus/archive/2011/06/11/mdt-2012-beta-1-uefi-support.aspx


    Dave Guenthner [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights. http://blogs.technet.com/b/davguents_blog
    Monday, November 07, 2011 2:58 PM
  • Thanks Dave, for the pointer.

    I've red the article. I've a feeling I'm somewhere in between.

    MDT 2012 will 'support' EFI better. With the mentioned article from this Forum on getting things to work with 2008 R2 I was able to continue my stuggle. I followed all instructions (apart from the 2008 R2 hotfixes ;-)). Pointed to the correct partition at the unattend (which is 3 (used WillShowUI=true for this)).

    So in the end the whole procedure worked, and the image was applied to my EFI/GPT partitioned harddisk.

    However, it will not boot. I can see that somehow a device called "Windows Boot Manager" is now part of the EFI Boot Sources. Booting ends with a blinking icon at he upper left corner.

     

    I've the feeling the the EFI 'bios' of this device is causing the problem. It doesn't look like the UEFI interface I've seen on the HP 8530P laptop, which might be similar to the HP 8440p mentioned in the MDT 2012 article. It's rather similar to the BIOS from the HP 8000 serie, apart from the EFI Boot Sources part.

     

     

    I've been able to partition my Legacy Boot Hard Disk as an EFI device. Could that be the/a problem?

    So the question is:

    - should I be able to boot this workstation te behave as (Legacy) BIOS, and format the disk accordingly with MBR?

    - if it is an EFI device, how can I get Windows booting from the Legacy harddisk using MDT?

    - or will MDT 2012 Beta answer all my questions by supporting this (hybrid) HP 8200 PC out-of-the-beta-box?

    - or.... should I stay away from EFI PC's for the next 1 to 2 years (when using MDT)

     

    Andy

    Tuesday, November 08, 2011 2:07 PM
  • Andy,

    Take a look at this link as I think it helps address some of your concerns as well.

    http://blogs.technet.com/b/askcore/archive/2011/03/25/deployment-options-for-uefi-based-computers.aspx


    Dave Guenthner [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights. http://blogs.technet.com/b/davguents_blog
    Tuesday, November 08, 2011 3:22 PM
  • Thanks again Dave, my knowledge of EFI/GPT is increasing.

    However, as this isn't helping me directly with our problem, I contacted HP on this.

    Also, as they (HP) advertise (found a 6 page brochure on the web) to use MDT with their workstations and laptops. They mention 4 types in this brochure, including the one (HP 8200 sff) we try to deploy using MDT.

    Their initial suggestions to 'solve' the issue have not been helpfull yet, but I wait for the miracle. To me it looks like this box remains an EFI based machine for MDT, and it expects an "EFI Source" boot device. The harddisk in this system remains a "Legacy device", although I was able to correctly partition it to GPT.

    Within the bios there is a list with the Boot order. This list contains two groups of device, EFI Sources and Legacy Sources. You can change the boot order within the groups, and you can disable a group. The suggestion of HP to disable the EFI Sources group does not solve the issue, MDT still sees the box as an EFI computer.

    I tried this on another, bare metal HP 8200, machine following the (HP) instructions in their brochure. This does the default Partition and Format (MBR).

     

    Andy


    • Edited by Andy Komen Friday, November 11, 2011 7:23 AM
    Friday, November 11, 2011 7:23 AM
  • The product team has released the beta 2 version of MDT 2012. Perhaps it would be worth your time to spin up a quick VM etc to run the beta code and see if "just works" with machine. There is a link below to the connect site from where you can download code. There is also a link to provide feedback etc. If you go this route, please post whether deployment worked or not.

    http://blogs.technet.com/b/deploymentguys/archive/2011/06/01/released-mdt-2012-beta-1.aspx


    Dave Guenthner [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights. http://blogs.technet.com/b/davguents_blog
    Friday, November 11, 2011 11:22 AM
  • Hello Dave,

    I'm working on setting up a setup with MDT 2012 Beta 2.

    So I'll report back.

    First issue encountered, will not load the OS from the DVD, so now I will research the Beta forum.

     

    Andy

    Monday, November 14, 2011 1:20 PM
  • I have the same problems with my HP 8200 SFF so please tell me when you have solved the problem...

    The funny thing is that sometimes its works setting up the machine with MDT and most of the time not...

     

    Andi

    Monday, November 14, 2011 2:56 PM
  • Hello,

    I am currently working on getting it done via MDT 2012 Beta 2.

    I'v downloaded it today. I solved the 'issue' of not being able to import the OS. It just required a reboot after installation of WAIK and MDT 2012.

    And at the moment it is generating the ISO's, so tomorrow morning I will give it a try.

    With MDT 2010 Update 1 I've not been able get it to work with the HP 8200 SFF yet.

     

    Andy

     

    Monday, November 14, 2011 3:24 PM
  • OK, it works from MDT 2012 Beta 2

    It looks like it partitions the disk as GPT (3 partitions).

    As I had the disk (controller) selected as IDE (because HP asked me to do this), I'm doing a second test.

    Now it is  AHCI, and to be sure, I removed the partitons from the disk too.

    I had one problem, I created a Recovery Disk from this system, to be sure to have it supporting EFI/GPT,

    however I'm not able to boot from it. Whether I select the DVD player as EFI source or Legacy source.

    The MBR based recovery CD won't work either (this version of System Recovery Options is not compatible...).

    But that's not an MDT issue.

     

    Andy


    OK, finished the second test, indeed when selecting AHCI it will end up with the AHCI driver as can be seen from the Device Manager.

    Also this time it created a GPT based disk with 3 partitions.

    It only was not able to add the workstation to  our domain automatically, that must be a user error.

    Still wondering what MDT version HP used when they prepared their brochure ( http://h20195.www2.hp.com/v2/GetPDF.aspx/c03078429.pdf )

    This leaves me (us) to decide on whether to use the Beta in our production environment, wait for HP, or??? 

     

     


    • Edited by Andy Komen Tuesday, November 15, 2011 3:13 PM
    Tuesday, November 15, 2011 9:48 AM
  • Hi Andy,

    What did you decide to go with in the end?  We are in the same position, using the same 8200 Elite SFF.  We think it may be an issue with the BIOS Firmware but it seems unlikely that HP will rectify this before we would require it.  We don't really want to run with a Beta version of MDT but I can't see any definitive answer as to when the full version of 2012 MDT may come out.

     

    Regards,

    Doug

    Tuesday, January 17, 2012 12:41 PM
  • Hi Doug,

    right now i m using the MDT 2012 Beta. With this version its working without problems.

    I didnt find any solution with the old version.

     

    Andy

    Tuesday, January 17, 2012 12:44 PM
  • OK, thanks for that.  I just downloaded the beat now so will install on one of our servers. 

    Do you know if it is possible to create a linked deployment share between MDT 2010 and 2012?

    Also, I was planning on uninstalling MDT 2010 on one of my servers and simply installing 2012 in it's place.  Do you know if it is possible to then point the newly installed 2012 to the old deployment share created under 2010?  It would be a serious pain in the ass if I had to manually add the 170 software apps and countless drivers associated with our build currently on the 2010 deployment share...

     

    Thanks for your thoughts on this and for your speed in responding.

     

    Doug

    Tuesday, January 17, 2012 1:27 PM
  • i m sorry Doug, but i dont know that.. maybe another one can help you.

     

    I installed MDT completly new so this worked fine..

    Tuesday, January 17, 2012 1:35 PM
  • That's OK, I just tried it and it worked a charm.

     

    For anyone looking at doing the same...

    Took under a minute to uninstall 2010 and install 2012.  Open Deployment workbench, click on deployment share and from the right hand pane select upgrade deployment share.  Seems like MS are on the ball, shame the same can't be said for those working at HP...

    Tuesday, January 17, 2012 1:39 PM
  • Hi Doug,

    good to hear it works for you too.

    We recently, waited for some time for a (better) answer from HP, decided to go with the Beta. Assuming, hoping, that it would be possible to import the deployment share from the Beta into the final, like the Beta supports the import from 2010 etc.

    However, we changed priorities, I first will work on deploying Office 2010 on our XP base, and soon after, when there is time for it, restart with Windows 7 deployment on the Beta.

    Last week I got a request to describe all the steps I did on MDT 2010 which lead to the error etc, from HP. Which I did before already. So I just replied to them, for a test I followed their exact steps (described in the PDF mentioned in one of my earlier replies), what I did. I've no idea what they will come back with.

     

    Andy

    Wednesday, January 18, 2012 12:48 PM
  • Not sure ifthis will be of any help but we ran into a similar problem trying to install a Win7 64bit image onto these 8200 SFF PC's.  Specifically, we are installing form a DVD so after trawling the web I found this useful article: http://support.microsoft.com/kb/2481490

    What we did to get it working was the following:

    Boot into Bios, navigate to the boot options and then disable all UEFI boot options so you are only left with the legacy boot options.  Reboot the machine with the image DVD inserted and hey presto, the installation starts without problems.  Once loaded you can re-enable the UEFI boot options if needed.

    Thought I'd add my 2 cents worth ;)

    Friday, January 27, 2012 4:55 AM
  • Yeah, we tried that to no avail.  The problem occurs after the WinPE has established a connection to the MDT server, and the Task Sequence launches the Win 7 Installer, having successfully loaded the NIC driver...

    As Andy mentions earlier in the thread, a simple migration to MDT 2012 Beta 2 seems to have resolved the issue.

    Friday, January 27, 2012 11:11 AM
  • OK, HP is still with us to help us. They made 2 suggestions which seem to make sense. Although I thought I did similar things, like Don mentions 2 replies earlier.

    1. MDT 2010 + task sequence with MBR partitions + hit F9 to legacy boot to optical drive (or disable UEFI boot on a target system)

    2. MDT 2010 + task sequence with GPT partitions + UEFI boot on a target system


    I tried the first one yesterday, by hitting F9 I selected the optical drive as Legacy device. (although I'm sure I did disable the UEFI devices, like Don did, in the past). This time everything went OK, and Windows 7 was installed.

    Initially I had a problem with the WinPe boot CD, everytime I got an error when it tried to start from it. I checked my bios settings and noticed I had it on AHCI (disk, which wasn't a problem with the MDT 2012 beta boot CD). After I switched it back to IDE it worked.

     

    I will continue to test the second scenario, I already had the task sequence ready for this, as mentioned in an earlier entry, and will make sure to select the UEFI optical drive.

    I will also retry the AHCI part, as I do want it to work with it when applying the image. I don't want to do it manually afterwards. And, again, it does work with Beta 2012.

     

    to be continued...

     

    Andy

    Thursday, February 09, 2012 8:38 AM
  • That's interesting, as I too am sure that we tried the first to no avail.  No matter now, as you say, MDT 2012 seems to be working fine for our needs.  Do let us know if you get the second option working if for nothing other than curiosity sake.

    Doug

    Thursday, February 09, 2012 9:08 AM
  • I've been battling MDT 2010 on this issue as well. MDT 2012 Release Candidate 1 has been posted. I'm going to install it today and see if it works with my HP Elite 8200 workstations.

    Craig

    Thursday, March 01, 2012 5:14 PM
  • We have tested MDT210 with a 9300 touchsmart (that has uefi) and i had no issues at all - i didnt even think about it, just plugged in the demo unit hit f12 and imaged the machine....  I will have to look at it to see whats different...

    Thursday, March 01, 2012 11:16 PM
  • Most UEFI+MDT problems actually come forward when you're trying to do PXE boot and try to install Windows that way. If you're using some form of media to boot from into the MDT environment (2010 as well as 2012), it should work w/o much issues when you're trying to configure it to install on a GPT disk.

    Server 8 will offer better uefi pxe boot support then the current pxe provider with 2008/(R2). 


    If one of these posts answered your question or issue, please click on "Mark as answer".

    My Blog | Twitter: @Schwarz_Stephan | MCTS, MCITP, MCC.
    How to configure Windows RE/OEM Recovery Partition with MDT

    Friday, March 02, 2012 11:17 AM
  • Andy,

    Seems that i have found an answer for the issue and that too with MDT 2010 Update 1. Please follow the following steps. It did wonder for me

    1. Within the MDT task sequence, you must disable the step “Format and Partition Disk” under Preinstall>New Computer Only container.
    1. Within the MDT task sequence, you must configure the operating system to install to DISK 0 PARTITION 2 under the “Install Operating System” step which is located under the Install container.
    1. Within the UNATTEND.xml file, you must remove the “InstallTo” object completely. This is located under the 1 windowsPE>Microsoft-Windows-Setup_neutral>ImageInstall>OSImage container.
    1. Within the UNATTEND.xml file, you must configure the “InstallToAvailableParition” property to “TRUE”. This setting is located in the 1 windowsPE>Microsoft-Windows-Setup_neutral>ImageInstall>OSImage container.
    2. Next we need to create a text file which will store the parameters required for DISKPART to create our partition structure on DISK 0 for us, you can use the below as a sample to create a single full logical C:\ drive.

     

    select disk 0

    clean

    convert gpt

    create partition efi size=200

    format quick fs=fat32 label="EFI"

    create partition msr size=128

    create partition primary

    format quick fs=ntfs label="SYSTEM"

    assign letter=C noerr

     

    1. Next we need to include this text file into your Windows PE image; you can use MDT to achieve this.
    1. Within the MDT task sequence, we need to add a “Run Command Line” step to your task and populate it with the following:

      Command Line:

    Diskpart /s <x:\filename.txt>

     

    Start in: 

    x:\Windows\System32

     

    To keep the same flow of deployment steps, you can place this task right above or below the “Format and Partition Disk” task that we disabled earlier.

     

    1. Once the above is completed, ensure to update the deployment share and use the newly modified WinPE image to boot up the UEFI enabled servers and then start your Task Sequence and everything should work correctly now.

    Original Link: http://social.technet.microsoft.com/Forums/en/mdt/thread/a6679550-a343-463c-9301-1bf9706ad9af 

    Thanks,

    Rakesh



    Rakesh Sahoo

    • Proposed as answer by Rakesh Sahoo Wednesday, July 18, 2012 7:22 PM
    Wednesday, July 18, 2012 7:20 PM
  • Similar to Don Schult, I solved the issue by changing the BIOS "Boot Options" setting, however I did not disable anything.  I merely changed the 1st boot device to be the DVD drive, from the internal HDD. Windows 7 install worked fine after that.
    Wednesday, October 17, 2012 7:44 PM

  • "Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed to GPT disks."


    I had the same issue while installing server 2008 r2 on a dell T110 server.....without deleting other partitions or loosing any data on other drivers you can solve this problem... Troubleshooting steps will be similar for all windows having this issue..  simply I followed these steps using gparted and solved my problem.. for anyone having the similar issue, all steps i have documented here..

    http://www.pcandtablet.com/windows-8-errors-and-crashes/846/windows-cannot-be-installed-to-this-disk-the-selected-disk-has-an-mbr-partition-tabl.html
    Saturday, May 11, 2013 3:06 AM