locked
restoring mailbox content in a storage group that contains a regular DB and a journal database RRS feed

  • Question

  • I am trying to recover deleted emails for a user whose mailbox resides in SG4\DB4.  also in SG4 resides a db called Journal_2 where we are journaling a few mailboxes.  I created a storage group RSG and a created a db called DB4.  When I try and create a RSG with ExTRA tool it automaically selects the Journal_2 db in SG4 along with DB4.  so I went along with it and created another DB and called it Journal_2 the same as the db in SG4.  When i go into Tivoli and try and restore DB4, Journal_2 database grows rather than DB4??? I am able to see the mailbox i need to restore in the list of mailboxes to copy or merge, but the merge fails.

    Any ideas on what I am doing wrong?
    Thursday, August 13, 2009 3:27 PM

Answers

  • Hi EwicHert,

    Remove all and Try this...

    Create SG...
    New-StorageGroup -name RSG -Server [servername] -Logfolderpath "Temp path for logs" -Systemfolderpath "temp path for sys files" -Recovery

    Logfolderpath and systemfolderpath can be same (but should be a designated drive e.g. r:\rsg\Log_data)

    Create DB...
    New-MailboxDatabase -name DB4 -Storagegroup "ServerName\RSG" -MailboxdatabasetoRestore "SourceFolder DB ID (in your case ServerName\SG4\DB4)" -Edbfilepath "temp path for database file which is going to be restored"

    Verify the the DB and SG created....
    Get-Storagegroup -Server Servername

    Note the RSG is created and Recovery is true

    Get-Mailboxdatabase -Storagegroup ServerName\RSG -status | fl name, storagegroup, recovery, mounted, Mailboxdatabasetoc*

    Note here the the DB is created in under RSG, recovery is true and Mailboxdatabasetorestore is pointed to source database.

    Try restoring it from Tivoli either by manully pointing the restore to RSG or by Selecting the option Redirect to RSG if any.

    Please let us know how does it go.

    Thanks.


    Vishal Ramnani | MCITP - Exchange 2007 | MCSE Messaging | MCTS - Win 2008 Config
    • Proposed as answer by V I S H A L Friday, August 14, 2009 1:43 PM
    • Marked as answer by Xiu Zhang Friday, August 21, 2009 8:16 AM
    Friday, August 14, 2009 1:43 PM

All replies

  • What is the error message you got?

    Also please check the below step by step in order to use RSG to recover mail box. make sure you have not forgotten any step.

    How to Recover an Exchange 2007 Mailbox

    http://technet.microsoft.com/en-us/library/bb795895.aspx

    Using Recovery Storage Group in Exchange 2007

    http://www.petri.co.il/using_rsg_in_exchange_2007.htm
    Vinod |CCNA|MCSE 2003 +Messaging|MCTS|ITIL V3|
    Friday, August 14, 2009 1:18 PM
  • Hi EwicHert,

    Remove all and Try this...

    Create SG...
    New-StorageGroup -name RSG -Server [servername] -Logfolderpath "Temp path for logs" -Systemfolderpath "temp path for sys files" -Recovery

    Logfolderpath and systemfolderpath can be same (but should be a designated drive e.g. r:\rsg\Log_data)

    Create DB...
    New-MailboxDatabase -name DB4 -Storagegroup "ServerName\RSG" -MailboxdatabasetoRestore "SourceFolder DB ID (in your case ServerName\SG4\DB4)" -Edbfilepath "temp path for database file which is going to be restored"

    Verify the the DB and SG created....
    Get-Storagegroup -Server Servername

    Note the RSG is created and Recovery is true

    Get-Mailboxdatabase -Storagegroup ServerName\RSG -status | fl name, storagegroup, recovery, mounted, Mailboxdatabasetoc*

    Note here the the DB is created in under RSG, recovery is true and Mailboxdatabasetorestore is pointed to source database.

    Try restoring it from Tivoli either by manully pointing the restore to RSG or by Selecting the option Redirect to RSG if any.

    Please let us know how does it go.

    Thanks.


    Vishal Ramnani | MCITP - Exchange 2007 | MCSE Messaging | MCTS - Win 2008 Config
    • Proposed as answer by V I S H A L Friday, August 14, 2009 1:43 PM
    • Marked as answer by Xiu Zhang Friday, August 21, 2009 8:16 AM
    Friday, August 14, 2009 1:43 PM