none
DPM Server Memory Utilization RRS feed

  • Question

  • Hi

    I have a 64-bit DPM 2007 server with 4GB RAM and has some 15 agents configured. Synchronization takes place every 4 hours and during that time, the memory utilization would reach 95%. I checked the process monitor and found that the process 'sqlservr.exe' takes the maximum memory. I just wanted to check if this is usual? Am I running under the MS recommendation for RAM? Will increasing the memory fix the issue?

    Thanks in advance

    Regards

    Pavit

    Thursday, August 23, 2012 1:35 PM

All replies

  • Hi 

    That's actually by design, you can stipulate a max memory amount for SQL otherwise it will utilise everything it can. It will release memory if other 
    processes require it.

    You can add more memory but if you don't throttle SQL it will use it.

    Kind Regards

    DareDevil57

    Thursday, August 23, 2012 4:09 PM
  • Hi DareDevil57

    Please let me know how can I throttle max amount for SQL? Will it affect server/DPM performance if I do so?

    Regards

    Pavit

    Tuesday, August 28, 2012 2:42 PM
  • 4GB are not very much for a DPM server...

    Just check if performance goes down.

    Open SQL Managemen, right click on the server and then under options you can adjust SQL memory setting


    My postings are provided "AS IS" with no warranties and confer no rights

    Thursday, August 30, 2012 1:46 PM
  • Hi Pavit

    You can use SQL Management Studio and change it there as follows below, it shouldnt affect the server but dont throttle it too badly:

    Ref: http://msdn.microsoft.com/en-us/library/ms178067.aspx

    Interesting read: http://support.microsoft.com/kb/319942/EN-US

    Use the two server memory options, min server memory and max server memory, to reconfigure the amount of memory (in megabytes) managed by the SQL Server Memory Manager for an instance of SQL Server. By default, SQL Server can change its memory requirements dynamically based on available system resources.

    Procedure for configuring a fixed amount of memory

    To set a fixed amount of memory

    1. In Object Explorer, right-click a server and select Properties.

    2. Click the Memory node.

    3. Under Server Memory Options, enter the amount that you want for Minimum server memory and Maximum server memory.

      Use the default settings to allow SQL Server to change its memory requirements dynamically based on available system resources. The default setting for min server memory is 0, and the default setting for max server memory is 2147483647 megabytes (MB). 

    Thursday, August 30, 2012 6:29 PM
  • Hi DareDevil57, bkpfast

    Thanks for your response.

    I am now able to set throttle for SQL server, but at peak backup times, SQLAGENT90.EXE takes 7-8MB, sqlbroser.exe*32 takes 500KB, sqlservr.exe takes 200MB and sqlwriter.exe takes 1MB. I'm afraid the rest of the memory is being used by LOCAL SERVICE, SYSTEM and NETWORK SERVICE and some user specific services. Although there is no performance issue seen but the memory utilization is 92%. I'm not sure if I should really be changing the throttle value since it is not consuming that much (or maybe there are some other sql related processes that I'm not aware of). Should I be upgrading server's RAM to deal with this? Thanks in advance!

    Regards

    Pavit


    Pavit Bhutani

    Tuesday, September 4, 2012 9:12 AM