none
Visio Web Access - XpathResult error

    Question

  • When using IE 11 to add a Visio Web Access Web Part that points to a .vsdx file in the Document Library the web part always returns 'XpathResult' is undefined. How can this error be resolved?

    Thanks,

    Wednesday, October 19, 2016 9:45 PM

Answers

  • Hi Lee,

    Thank you for the reply.

    I've done a little more investigating.  I have found that out SharePoint pages are set to display content in Edge compatibility:
        <meta http-equiv="X-UA-Compatible" content="IE=Edge" />

    When I open the Developer Tools in IE 11 and change the content mode for the page to 10 the Visio Web Access Web Part works as expected.

    Thanks,


    Thursday, October 20, 2016 2:28 PM

All replies

  • Hi,

    I tested in our online environment. It works fine.

    Could you create a simple file and try.

    If the issue still exist, could you provide your Visio software version.

    Best Regards,

    Lee


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, October 20, 2016 2:58 AM
  • Hi Lee,

    Thank you for the reply.

    I've done a little more investigating.  I have found that out SharePoint pages are set to display content in Edge compatibility:
        <meta http-equiv="X-UA-Compatible" content="IE=Edge" />

    When I open the Developer Tools in IE 11 and change the content mode for the page to 10 the Visio Web Access Web Part works as expected.

    Thanks,


    Thursday, October 20, 2016 2:28 PM
  • Hi,

    Thanks for sharing, you could MARK your findings as answer so it may help others who faced the same issue.

    Best Regards,

    Lee


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, October 21, 2016 1:18 AM
  • How can this be an acceptable answer.  Expecting users to use developer tools and set the compatibility is simply not workable.  Can someone please tell me what I need to do on the page to make the Visio Viewer work in IE11?
    Friday, July 21, 2017 1:44 AM
  • You could set "X-UA-Compatible" to 10 in your page header. But for me that is also not an "acceptableanswer".

    Emulating an old browser can NEVER be a good idea.

    Monday, August 27, 2018 7:29 AM