none
Troubles using Assignment Owner (MS Project 2010) RRS feed

  • Question

  • Hi,

    I am having troubles using the assignment owner field. For example:

    - I create a project with two tasks

    - First task (T1) is assigned to resource R1 but the default assignment owner for R1 is R2.

    - Second task (T2) is assigned to R2 (assignment owner is also R2)

    I save and publish the project and then:

    - R1 enters PWA and he is informed of one new task assigned to him. However, when clicking on the message no task is shown on the timesheet.

    - R2 enters PWA and finds one new task (T2) assigned to him --> This is OK

    T1 seems to be lost somewhere because it can't be seen from R1's nor R2's timesheet page. What could be wrong? R1 is Project Manager so it's not about permissions.

    Thank you very much in advance.

    Monday, May 27, 2013 5:44 PM

Answers

  • You referred to "R2's timesheet and tasks page."  Those are two different pages.  In Quick Launch, under "My Work," can R2 navigate to "Tasks"?  If so, and if you have generally standard configuration, then the "My Assignments" view should display both assignments for R2.

    Also be sure there is no filter applied to the My Assignments view.


    Reid McTaggart – DeltaBahn Vice President
    Blog | Twitter | LinkedIn Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can help other community members reading the thread.


    Thursday, May 30, 2013 2:02 PM

All replies

  • Hi E_FG

    Have you tried with recreating the timesheet period?? Please delete specific Timesheet reporting period and re-create it again...

    Also, check this task in calendar view.


    Regards, Pankaj Waghmare - MCTS | Consultant



    Tuesday, May 28, 2013 6:38 AM
  • Thanks for your reply Pankaj.

    I have deleted all timesheets and created the project again but still the assignment owner can't see the task.

    I have checked the task in calendar view to make sure the dates are correct and also change the resources set as assignment owners but it does not work properly...

    Is this supposed to work ok in SEM?

    Tuesday, May 28, 2013 8:16 AM
  • Assignment owners can update task status for other resources whose assignment they own, but will only see their own assignments in their timesheets.  This is by design, because a timesheet is supposed to be about a single person's time.

    If you are using Timesheets/SEM, you may wish to look into the Delegation feature instead of trying to use assignment owners. 


    Reid McTaggart – DeltaBahn Vice President
    Blog | Twitter | LinkedIn Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can help other community members reading the thread.

    Tuesday, May 28, 2013 3:34 PM
  • Thank you Reid.

    The thing is that the assignment owner receives the notification "You have 1 task assigned to you" but he can never update the status of the task because it is not shown in the tasks page or in the timesheet. Where is the assignment owner supposed to update the status of the task?

    Wednesday, May 29, 2013 7:58 AM
  • E_FG --

    Just to throw out another idea, you might try this:

    1. Open the project in question and apply the Task Usage view.
    2. To the right of the Task Name column, insert the Assignment Owner column.
    3. Confirm that R2 is set as the Assignment Owner for the resources assigned to both T1 and T2.  If not, set R2 as the Assignment Owner for the resources assigned to these two tasks.
    4. Save and publish your project again.

    Please let us know if this helps.


    Dale A. Howard [MVP]

    Thursday, May 30, 2013 10:09 AM
    Moderator
  • I followed the steps and the result is:

    • R1 enters PWA and receives no notification and has no task shown in his timesheet/tasks page.
    • R2 enters PWA and receives a notification: "You have 2 tasks assigned to you". I click on the message but I can only see T2 in R2's timesheet and tasks page. I changed the selected period but T1 is nowhere.


    Thursday, May 30, 2013 11:56 AM
  • You referred to "R2's timesheet and tasks page."  Those are two different pages.  In Quick Launch, under "My Work," can R2 navigate to "Tasks"?  If so, and if you have generally standard configuration, then the "My Assignments" view should display both assignments for R2.

    Also be sure there is no filter applied to the My Assignments view.


    Reid McTaggart – DeltaBahn Vice President
    Blog | Twitter | LinkedIn Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can help other community members reading the thread.


    Thursday, May 30, 2013 2:02 PM
  • Thank you Reid! Your answer was key to find the error.

    I discovered we had the My Assignments web-part in the tasks page so I could never see the assignment. I added the My tasks web part and now I can see both T1 and T2 assigned to R2 :)

    Friday, May 31, 2013 8:16 AM