Unable to open a ppsx file in slide show mode. RRS feed

  • Question

  • Hi , 

    I have a Powerpoint file which is saved as .ppsx. But it doesnot open as slide show when uploaded in the SharePoint Document Library. Instead it open the ppsx in the edit mode. 
    How can I open a ppsx file as a slide show?  Is there any workaround other than modifying the registry settings?

    Any help would be appreciated.


    Thursday, August 23, 2012 10:01 AM

All replies

  • Hi,

    Go to library settings-->advanced settings-->open your file in browser instead of client so choose open in browser.

    You can also try another way as mentioned in this link:


    Hope it could help

    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"

    Thursday, August 23, 2012 11:19 AM
  • Hi Agrawal, 

    Thanks for the reply, but the first option dint work for me. And I am looking for any other workaround other than making the changes in the windows registry settings.

    Friday, August 24, 2012 9:15 AM
  • I had same problem but think I have solved it.

    I went to the properties of a file saved as .ppsx which would open in power point in the edit mode instead of opening as a slide show.

    In the properties I went to Change how it opens then clicked on Power Point and clicked apply and OK. I saw that the icon had changed slightly and saw that the icons of all my .ppsx files had slightly changed and all the .ppsx files now open as a slide show and no longer in PP as an edit file.

    Don’t know what happened but think that when you work in Power Point and save the file as a.ppsx it really does not save it as a.ppsx but as a .pptx (as it says it must in the Options in the PP program!!) by changing how it opens afterwards it has magically adopted the.ppsx and changed all the files with that suffix to open as shows!  Think it bypasses the glitch in the actual programme where it states in Options – Save that it must save as a presentation with no alternative such as a show.

    In Power Point click on File then on Options then on Save  and then check how Power Point saves the work - it only saves it as a Presentation of one of 4 variations but no mention of Show so despite saving it as a .ppsx it subliminally really saves it as a.pptx.  The file has a.ppsx suffix but only adopts it when Power Point is reselected in the properties of the file. It then automatically did all similar files on my PC.

    Wednesday, September 20, 2017 7:58 AM
  • When you say that in properties you changed how it opens can you explain exactly where you went to to get these properties, I can't seem to find any such option.

    Thank you

    Thursday, October 12, 2017 10:07 PM
  • I'm having this issue, too. I've saved a .ppsx that is set to view only access on our SharePoint server. Using that link we can access the file as an anonymous user, but the file opens as though it's a .pptx -- in edit mode IN the browser, as though it's in PowerPoint Online (even though it's set to read-only access by the link). We had done this successfully in the past (not even needing to switch to the .ppsx format to get the file to load in slideshow mode), but it appears something has changed in the last year.

    The strange thing is that the FIRST time I create a new view-only link from a .ppsx, it does show with a black border fully surrounding the initial slide and the menu that lets you start the slideshow. But if I open it again on the same pc (even if I clear the browser cache and use incognito or private mode -- same browser or a different one) -- or if someone else in the office views it on their pc -- in incognito or private mode, they see it clearly in the slide browser/edit mode with no slick black background or easy link to start in slideshow mode.

    On a pc, it opens in slideshow mode when clicked (so it really is a ppsx and not a pptx). And this used to work online, using SharePoint and a PowerPoint file. We can't use the present online option (this needs to be viewable at any hour, self-run) and that isn't compatible with our account, either (because we have Office 365 and SharePoint -- not live.com or microsoft.com accounts).

    Thursday, December 14, 2017 8:48 PM