locked
unable to change permissions on item in another list using a site-level workflow RRS feed

  • Question

  • Hi all,

    I am able to create an OOTB workflow attached to a list, and use impersonation to change the list item's permissions with no issues.

    When I create a site-level workflow and attempt to do the same thing, I receive a "Failed to update permissions." error in the Workflow History.  I am able to change the list item's properties (e.g. update a field), but not the permissions using a site-level workflow without receiving that error. 

    No errors in ULS or anywhere else that I can see.  I am a site collection/farm administrator and published the workflow myself, so no permission issues should exist.

    Thanks for your help,

    Phil

    Tuesday, June 11, 2013 6:02 PM

Answers

  • Hi Phil,

    I create a simple site level workflow to replace the list item permission using SharePoint Farm Administrator, and it is working.

    Please create another new simple site workflow on another site to replace a specified list item permission (specify thel ist item ID number), test again.

    Thanks


    Daniel Yang
    TechNet Community Support

    Monday, June 17, 2013 10:48 AM

All replies

  • Hi Phil,

    I create a simple site level workflow to replace the list item permission using SharePoint Farm Administrator, and it is working.

    Please create another new simple site workflow on another site to replace a specified list item permission (specify thel ist item ID number), test again.

    Thanks


    Daniel Yang
    TechNet Community Support

    Monday, June 17, 2013 10:48 AM
  • Hi Phil,

    I create a simple site level workflow to replace the list item permission using SharePoint Farm Administrator, and it is working.

    Please create another new simple site workflow on another site to replace a specified list item permission (specify thel ist item ID number), test again.

    Thanks


    Daniel Yang
    TechNet Community Support

    I tried again and received the same error.  To clarify, I want the site-level workflow to execute against each item as it is created automatically.  The workflow should not be tied to a specific ID.

    Wednesday, July 17, 2013 2:44 PM