none
Could a recent update have made the F-keys inaccessible in a dosbox application?

    Question

  • I've been using an excellent free cad program called bCad for many years in a dosbox from a desktop mode in Win 8.1. The function keys were accessed in combination with the FN-key and I never had a problem until now. When I tried that recently, all I see is bar indicator icon? on the desktop showing 98 or 100. Any ideas to get my function keys back? 
    Wednesday, May 16, 2018 4:15 PM

All replies

  • Hi,

    Is there any change before this issue?

    Which function keys did you use?

    If yes, please revert back the changes to see the results.

    Please try to use On-Screen keyboard to see if it can work.

    And please check if the function key could work without this application running.

    Please try to use clean boot to boot PC into a clean environment to see it the issue still occur.

    Here is a link for your reference.

    How to perform a clean boot in Windows:

    https://support.microsoft.com/en-in/help/929135/how-to-perform-a-clean-boot-in-windows

    Please try to uninstall the recent update to see if it can work.

    If it can work, please try to reinstall the update to see if the issue still occur.

    If it still can’t work, please contact the application vendor.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, May 17, 2018 3:22 AM
  • Hi, 

    How’s everything going? Please feel free to give me any update.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, May 24, 2018 4:06 AM
  • Hi Vera, thanks for your responses. Sorry I
    didn't get back to you
    earlier, but I ran into a disaster here. I'd
    recently done a full backup
    (Macrium 7), after which I permanently
    deleted a 250GB ..\local\temp
    folder. And I thought that this might have
    given me the problem in
    question. So I tried to do a full restore
    from the back-up image. Big
    mistake!! I guess I forgot to verify the
    image, for it stopped soon with a
    large block writing error on my c-disk. Then
    I probably made it worse by
    trying it again through the option of
    drag-and-dropping the c-partition
    onto the now greyed-out c-disk space, as it
    soon quit writing again.
    Couldn't boot anymore of course and with a
    linux rescue disk discovered
    that most of my directories and files on the
    c-partition were no longer
    existing or inaccessible. I sent both drives
    to Ontrack for recovery and
    and can only hope for the best, as all my
    data is on it too. Haven't heard
    back from them yet...
    Thursday, May 24, 2018 6:25 PM