none
Error in invoking AttachProductionServer method of dpmserver object RRS feed

  • Question

  • Hi,

    I have been trying to attach the production server by making a call to 

    $Pwd = ConvertTo-SecureString -String $Password -AsPlainText -Force Add-PSSnapin -Name Microsoft.DataProtectionManager.Powershell $dpmServer = Connect-DPMServer $DPMServerName #Call Attach production server method on DPM server

    $dpmServer.AttachProductionServer($PSName, $UserName, $Pwd, $Domain)

    but it while invoking $dpmServer.AttachProductionServer($PSName, $UserName, $Pwd, $Domain) an error has raised which states

    A positional parameter cannot be found that accepts argument 'Exception calling "AttachProductionServer" with "4"
    argument(s): "Exception of type 'Microsoft.Internal.EnterpriseStorage.Dls.Utils.DlsException' was thrown."'.
        + CategoryInfo          : InvalidArgument: (:) [Write-Error], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,Microsoft.PowerShell.Commands.WriteErrorCommand
        + PSComputerName        : dpm-2012-01

    I can't figure it out why is it happening.

    Any help in getting through this will be highly appreciated.

    Thanks

    -Noor

    Friday, July 20, 2012 6:31 AM

All replies

  • Closing for housekeeping.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, September 3, 2013 9:19 PM
    Moderator