locked
PXE BOOT Option 67 boot file name RRS feed

  • Question

  • I need some help. Where can i find the name of my bootfile so i can configure Option 67 which request the bootfile-Name if someone could tell me where i can find this or how to find this that would be great thanks
    Thursday, January 7, 2016 3:16 PM

Answers

  • Hi,

    If you use bootfilename option 67 it should be set to smsboot\x86\wdsnbp.com as described here:

    http://blogs.technet.com/b/adnanezzi/archive/2009/06/22/configmgr-2007-osd-how-to-allow-dhcp-broadcasts-across-vlan-s.aspx

    I recommend however that you use IP helpers instead as hard coding option 67 will result in problem in the future when you upgrade to the latest version of Configuration Manager and then you perhaps want to pxe boot either UEFI or x64 machines and they using a static value for option 67 will not work.

    Regards,

    Jörgen


    -- My System Center blog ccmexec.com -- Twitter @ccmexec

    • Proposed as answer by DonPick Thursday, January 7, 2016 11:38 PM
    • Marked as answer by Garth JonesMVP Saturday, January 23, 2016 3:46 PM
    Thursday, January 7, 2016 8:21 PM
  • so does IP helpers have to be configured on my PXE server?????......... is the PXE Server also call my WDS is????? because right now my WDS and DHCP are separate

    IP helper is something you configure on the router interface/VLAN where your client machines who need to PXE-boot are.
    (the client machine issues a local broadcast to their subnet/VLAN, which needs to be forwarded via IP helper, onto the remote DHCP and PXE/WDS servers)

    WDSserver = PXEserver

    it's fine to have WDS on a different server than DHCP, but, IP helper has to forward the client requests to *BOTH* WDS & DHCP for PXE to succeed.


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Marked as answer by Garth JonesMVP Saturday, January 23, 2016 3:46 PM
    Monday, January 11, 2016 8:35 PM

All replies

  • Hi,

    If you use bootfilename option 67 it should be set to smsboot\x86\wdsnbp.com as described here:

    http://blogs.technet.com/b/adnanezzi/archive/2009/06/22/configmgr-2007-osd-how-to-allow-dhcp-broadcasts-across-vlan-s.aspx

    I recommend however that you use IP helpers instead as hard coding option 67 will result in problem in the future when you upgrade to the latest version of Configuration Manager and then you perhaps want to pxe boot either UEFI or x64 machines and they using a static value for option 67 will not work.

    Regards,

    Jörgen


    -- My System Center blog ccmexec.com -- Twitter @ccmexec

    • Proposed as answer by DonPick Thursday, January 7, 2016 11:38 PM
    • Marked as answer by Garth JonesMVP Saturday, January 23, 2016 3:46 PM
    Thursday, January 7, 2016 8:21 PM
  • I was just informed by my network admin that we already have IP helpers set up on the DHCP server and PXE Boot is still not working on a pc. I think it has something to do with Option 60 66 67 not configured what do you think????

    • Edited by Joej1980 Friday, January 8, 2016 7:33 PM
    Friday, January 8, 2016 7:31 PM
  • If IP Helpers are correctly configured (the ip helper address for *both* DHCP server *AND* PXE server, needs to be configured, in *ALL* router interfaces/VLANs), DHCP Options 66/67 are not needed at all.

    The client machine will issue a PXE request (broadcast), which is received by the router interface, and the router interface has IP Helper configured to "forward" this broadcast to *BOTH* DHCP-server *AND* PXE-server.
    The DHCP-server responds with an offer of an IP address, and, the PXE-server responds with an offer of a boot file.

    DHCP Option 60, is important if your DHCP-server & PXE-server are running on the same Windows-server. (because DHCP & WDS won't share nicely without Option60)


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Friday, January 8, 2016 9:50 PM
  • so does IP helpers have to be configured on my PXE server?????......... is the PXE Server also call my WDS is????? because right now my WDS and DHCP are separate
    Monday, January 11, 2016 4:19 PM
  • the error i am getting from PXE Boot is PXE-E53 "no boot filename recieved"

                                                                  PXE-M0F: Exiting Broadcom Pxe Rom

    Monday, January 11, 2016 4:27 PM
  • so does IP helpers have to be configured on my PXE server?????......... is the PXE Server also call my WDS is????? because right now my WDS and DHCP are separate

    IP helper is something you configure on the router interface/VLAN where your client machines who need to PXE-boot are.
    (the client machine issues a local broadcast to their subnet/VLAN, which needs to be forwarded via IP helper, onto the remote DHCP and PXE/WDS servers)

    WDSserver = PXEserver

    it's fine to have WDS on a different server than DHCP, but, IP helper has to forward the client requests to *BOTH* WDS & DHCP for PXE to succeed.


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Marked as answer by Garth JonesMVP Saturday, January 23, 2016 3:46 PM
    Monday, January 11, 2016 8:35 PM
  • the error i am getting from PXE Boot is PXE-E53 "no boot filename recieved"

                                                                  PXE-M0F: Exiting Broadcom Pxe Rom

    So this is simply saying "I did a broadcast asking for a bootfile but nobody ever responded with a bootfile name for me :("

    The PXE-ROM on the client doesn't know why no response came, only that it didn't get anything it could use.

    It sounds like your WDS/PXE is not getting the client-request so it's not responding to the client. *either ip helper isn't setup correctly or the WDS isn't receiving the packets or WDS isn't working correctly. check the WDS logs/smspxe log on the PXE Service Point (WDS)


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Monday, January 11, 2016 8:44 PM