locked
Skype for Business - Calls will ring you at work is blank RRS feed

  • Question

  • Hi, I'm trying to figure out what would cause this value to be blank? Typically this is populated with the user's phone number with something like +1 (123) 123-4567 X4567.

    Any thoughts on what would cause this to appear in this manner?

    

    Thanks,

    Matt

    Tuesday, April 5, 2016 3:55 PM

Answers

  • I found the issue. There's a bit more going on in our environment I didn't detail, specifically with synchronization of attributes.

    Basically, msRTCSIP-Line attribute value needs to have tel: in lower case. For some reason our sync was creating this in caps. This doesn't seem to impact anything else, but this Call Forwarding field does not like it.

    Also, modifying this line in AD reflects the changes almost immediately in the SfB client so this value is not pulled from the Address Book. 

    Thanks for everyone's input, appreciate it!

    Cheers,

    Matt


    • Edited by MattSlusar Friday, April 8, 2016 11:22 PM
    • Proposed as answer by Liinus Saturday, April 9, 2016 7:13 AM
    • Marked as answer by MattSlusar Monday, April 11, 2016 3:03 PM
    Friday, April 8, 2016 11:12 PM

All replies

  • Hi Matt,

    Do you have any delegates added or any phone number configured already?

    If don't have delegates, then it won't show up the options to forward to delegate.

    Also you can configure phones from Lync of SFB client.

    https://support.office.com/en-us/article/Set-Phones-options-and-numbers-cc0adaf8-26bf-4761-8b61-60094c13c971


    - Muralidharan. Please mark as answer/useful if my contribution helps you.

    Wednesday, April 6, 2016 2:07 PM
  • That would be your DID number , if you are enabled for enterprise voice. you can assign  that number through Lync control panel 


    Linus

    Wednesday, April 6, 2016 5:02 PM
  • The number is assigned, user is enabled for enterprise voice. EV Works fine. Shows up under configuration information lineuri in the format of +15551234567ext=4567 but for some reason it does not meet what this portion of the client is looking for. 

    There are no delegates configured. What I've typically experienced with this field is that if you do NOT have forwarding to anyone configured, which is the case in my example above, it shows your assigned number. Strangely in this environment it does not. Maybe it requires extension dialing rules to be present?

    Thanks for your help.

    Wednesday, April 6, 2016 6:09 PM
  • There was bug causing similar behaviour some time ago. You on the latest version?

    FYI - Workaround for the bug http://ucsorted.com/2014/12/09/number-missing-from-call-button-but-present-in-contact-card/


    Please remember, if you see a post that helped you please click Vote As Helpful; and if it answered your question, please click Mark As Answer

    UC Sorted


    Wednesday, April 6, 2016 6:28 PM
  • Sorry I should've mentioned, latest and greatest, Skype for Business 2016 client although the same was present via the Lync 2013 and older SfB clients too. 
    Wednesday, April 6, 2016 9:07 PM
  • Hi,

    It should show the work number.

    On SFB client--option--phones, work number, check if the number there without issue.

    If there is no work number there, on Skype for Business Server side, make sure there is the correct normalization rule for the address book.

    Best Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    Thursday, April 7, 2016 7:49 AM
  • Hi Eason,

    The number does appear there under Work Phone. That is what is puzzling me. Why does it appear there OK but missing from the Call Forwarding field? 

    Thanks,

    Matt

    Thursday, April 7, 2016 3:57 PM
  • Hi,

    Just to be clear, can you confirm that this is affecting all users in your environment? If you search for a user in the client, and look at their contact card, do you see their work number displayed correctly on it?

    Can you please also confirm that the telephone number is correctly formatted in the user active directory user object properties under the telephone field?

    Incidentally, does the feature still work regardless of the fact the number is not displayed correctly?

    Kind regards
    Ben


    Note: If you find a post informative, please mark it so using the arrow to the left. If it answers a question you've asked, please mark the thread as answered to aid others when they're looking for solutions to similar problems.

    Thursday, April 7, 2016 4:15 PM
  • I found the issue. There's a bit more going on in our environment I didn't detail, specifically with synchronization of attributes.

    Basically, msRTCSIP-Line attribute value needs to have tel: in lower case. For some reason our sync was creating this in caps. This doesn't seem to impact anything else, but this Call Forwarding field does not like it.

    Also, modifying this line in AD reflects the changes almost immediately in the SfB client so this value is not pulled from the Address Book. 

    Thanks for everyone's input, appreciate it!

    Cheers,

    Matt


    • Edited by MattSlusar Friday, April 8, 2016 11:22 PM
    • Proposed as answer by Liinus Saturday, April 9, 2016 7:13 AM
    • Marked as answer by MattSlusar Monday, April 11, 2016 3:03 PM
    Friday, April 8, 2016 11:12 PM
  • Thanks Matt for sharing the root cause, very interesting behavior and sure thing to note when Lync  dependency on MsRTCsip-Line Attribute is so much.


    Linus

    Saturday, April 9, 2016 7:13 AM