locked
Disable Discovery of certain Databases RRS feed

  • Question

  • Hi All,

    I am running into the following issue. I have imported the SQL 2012 management pack. Everything is working ass configured I only want to exclude some databases from the discovery.

    When I Select Discover SQL Server 2012 Database Engines (Windows Server) and do a override "For all objects off class: SQL Server installation Seed" 

    Check Exclude List and enter the Database (In this example) tempdb,master,model,msdb

    Everything got saved. I restarted the monitoring agent on the SQL server I monitor the Database are still getting discoverd.

    Also when I restared the server databases in the excluded list are getting discoverd.

    Hope you can help me solve this issue

    Thanks in advance


    Roel Knippen

    Wednesday, September 13, 2017 2:37 PM

Answers

  • Hi Sir,

    You may use another discovery rule "discover databases for a database engine" :


    After the override , you please run command "Remove-SCOMDisabledClassInstance" and refresh database in SCOM console .

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    • Edited by Elton_Ji Monday, September 18, 2017 6:04 AM
    • Marked as answer by Roel Knippen Monday, September 18, 2017 6:55 AM
    Monday, September 18, 2017 6:02 AM

All replies

  • Hi Roel,

    did you run also Remove-SCOMDisabledClassInstance after making the overrides?

    From this great article, explaining SCOM discoveries:

    How stuff is discovered by Operations Manager, and how you can remove it

    For items created by a discovery, you can just disable the discovery using the information provided in the previous section. You can then open up the Operations Manager PowerShell interface and run the command Remove-SCOMDisabledClassInstance. This will prompt you with a warning that this is a database-heavy operation (and it actually is, so take care). If you choose to continue, SCOM will effectively scrub all objects and relationships that have disabled discoveries.

    image

    P.S. You should also make sure that no other discoveries are trying to discover those particular DBs, as per:

    Undiscovering with Multiple Discoveries

    Please try it and post back. Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov


    Wednesday, September 13, 2017 3:31 PM
  • Hi Stoyan, 

    Did run the command Remove-SCOMDisabledClassInstance but the databases arrend undiscoverd. 

    I know there aren't multiple disvocerys runnin against te databases.

    Hope you have any more suggestions.

    Greetings

    Roel Knippen

    Thursday, September 14, 2017 7:44 AM
  • Hi Sir,

    You may use another discovery rule "discover databases for a database engine" :


    After the override , you please run command "Remove-SCOMDisabledClassInstance" and refresh database in SCOM console .

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    • Edited by Elton_Ji Monday, September 18, 2017 6:04 AM
    • Marked as answer by Roel Knippen Monday, September 18, 2017 6:55 AM
    Monday, September 18, 2017 6:02 AM
  • >>Everything got saved. I restarted the monitoring agent on the SQL server I monitor the Database are still getting discovered.
    Once the DB is being discovered, SCOM will not automatic delete the discovered entity. You need create an override to disable DB discovery and then run Remove-SCOMDisabledClassInstance to remove it.

    Roger

    Monday, September 18, 2017 6:54 AM
  • Hi Elton

    Thank's for the reply. This was the solution for my problem. 

    Greetings Roel Knippen

    Monday, September 18, 2017 6:55 AM