locked
Workflow Canceled Error in Sharepoint 2013 RRS feed

  • Question

  • A new SP 2013 installation, one server with SP, WF, etc and the other is simply SQL Server. Went through the installation steps for Workflow including the powershell bits. In designer, I am able to create a simple workflow and select 2013 as the type.  When the workflow is run, is shows internal status is canceled and has the following error text below. Note that I am running the workflow as a basic user, not as a system account.

    RequestorId: 55c6990b-c4a6-352c-4a5b-449fc1aecac4. Details: System.ApplicationException: HTTP 401 {"x-ms-diagnostics":["3001000;reason=\"There has been an error authenticating the request.\";category=\"invalid_client\""],"SPRequestGuid":["55c6990b-c4a6-352c-4a5b-449fc1aecac4"],"request-id":["55c6990b-c4a6-352c-4a5b-449fc1aecac4"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"SPRequestDuration":["61"],"SPIisLatency":["1"],"Server":["Microsoft-IIS\/8.0"],"WWW-Authenticate":["Bearer realm=\"61e7a76b-024e-40d5-9185-2887a044d7cc\",client_id=\"00000003-0000-0ff1-ce00-000000000000\",trusted_issuers=\"00000005-0000-0000-c000-000000000000@*,00000003-0000-0ff1-ce00-000000000000@61e7a76b-024e-40d5-9185-2887a044d7cc\"","Negotiate","NTLM"],"X-Powered-By":["ASP.NET"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Date":["Tue, 05 Feb 2013 19:17:31 GMT"]} {"error_description":"The server was unable to process the request due to an

    I've found few instances of this via various searches, most discuss not running the workflow as a system account, which is not the case here. The other mentions User Profile Service. I have no desire to have My Sites setup and whenever I start looking at initiation User Profile Service it begins by creating a MySite web app and site collection to associate the UPS to. Is this all required to get Workflow going?

    Thanks for any ideas/advice. I'm considering SP 2010 instead but would prefer to get 2013 working properly.

    Tuesday, February 5, 2013 9:37 PM

Answers

All replies

  • I am getting the same issue, you found any solution?

    Anuja - Sharepoint Consultant

    Tuesday, February 12, 2013 6:45 AM
  • I found the soution

    please see it in my blog:

    http://anujabhojani.blogspot.in/2013/02/sharepoint-2013-workflow-gets-canceled.html

    Hope it hepls,


    Anuja - Sharepoint Consultant

    Tuesday, February 12, 2013 8:05 AM
  • I had a similar error and was able to resolve it by following these instructions: http://msdn.microsoft.com/en-us/library/jj822159.aspx

    Friday, February 15, 2013 9:01 PM
  • Manually creating the my profile in User Profile Service (still awaiting Replicate Directory Changes on customer's domain:) fixed this issue for me - thx!

    Wednesday, February 20, 2013 1:12 PM
  • Hi, for the record, I found another case where this error happens: if the workflow initiator does not have write access to the hidden Workflow History List, the same error happens. To solve the issue, simply open the hidden list permission (through SharePoint Designer>All Files>Lists, for example) and make sure to have your potential initiators contribute rights. The list defaultly inherits the site's permissions.
    Thursday, August 1, 2013 2:26 PM
  • The links below show how to fix the problem. The issue comes from the fact that Workflow Manager (WM) authenticates with SharePoint over OAuth (specifically using S2S). The only identity information passed in an OAuth token with SharePoint is the ID. SharePoint collects the rest of the information from the UPA that has a cache of all users. If you haven't run a UP Sync to populate the UPA, you get this error.

    This is also why WM is only available with SharePoint Server 2013... not SharePoint Foundation 2013 (UPA is only in SPS2013, not SPF2013).


    -AC [MVP SharePoint Server] http://www.andrewconnell.com

    Wednesday, August 28, 2013 1:55 PM
  • We are getting same error with LDAP form based authentication and kicking off sharepoint 2013 workflow.

    Details: System.ApplicationException: HTTP 401 {"x-ms-diagnostics":["3001000;reason=\"There has been an error authenticating the request.\";category=\"invalid_client\""],

    We are not able to submit the workflow in sharepoint code using form based authentication.

    Does this mean form based authentication is not supported to kick off sharepoint 2013 workflow?


    MCTS Sharepoint 2010, MCAD dotnet, MCPDEA, SharePoint Lead

    Thursday, September 19, 2013 11:43 AM
  • hi,

    I am getting below error message...
    RequestorId: e948b96b-77ab-d56e-e414-512061490b18. Details: System.ArgumentException: ContentTypeId at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

    The WF is designed in SPD2013 and it has below steps..
    1. Send email to sharepoint group member.
    2. Start WF task with same group.
    3. Add item to another list based on WF Outcome variable value.
    4. End WF.

    I have single server stand alone setup, everything on one server. Setting done for SMTP server on Central Admin out going mail and I am receiving the mail.

    User ID used to to login to server is a member of Farm admin and also has Site Collection Admin rights. The WorkFlow service is running using different service account.

    Any direction to get the exact error would be great help! Many thanks in advance.

    Regards,
    Kapildev

    Tuesday, February 17, 2015 5:57 AM
  • This is the real solution of the issue, please review:
    https://support.microsoft.com/en-us/kb/2839070
    Bye.
    Thursday, October 8, 2015 1:06 AM
  • Hi Amit,

    <g class="gr_ gr_13 gr-alert gr_spell gr_run_anim ContextualSpelling" data-gr-id="13" id="13">Its</g> been some time by now, but were you able to solve your issue? We are also using LDAP and running <g class="gr_ gr_137 gr-alert gr_gramm gr_run_anim Grammar only-ins doubleReplace replaceWithoutSep" data-gr-id="137" id="137">workflow</g> with those users throw this error. 

    If you have any solution, to get rid of this issue, please do share.

    Thanks


    IN
    Thanks, Kashif

    Wednesday, November 2, 2016 4:21 PM
  • Thanks Anuja. Configuring and Starting the User Profile Synchronization service did the trick. I do not know what is the dependency of the workflow on User Profile Sync Service but my workflow is executing.
    Monday, April 24, 2017 10:57 AM