locked
Remote WMI Access denied Error - 0x80070005 RRS feed

  • Question

  • Hi,

    I am facing an WMI issue in a Windows 7 machine when i try a WMI connection to the machine remotely thorough wbemtest

    Error: "Remote WMI Access denied Error - 0x80070005"

    However the test is successful when it is executed locally in the Windows 7 machine. 

    The account i had used for testing the WMI connection is part of the local administrators group and firewall is disabled in the client machine


    Please help me to understand where the issue is.

    Thanks in Advance

    Sathish

    Wednesday, November 22, 2017 10:05 AM

All replies

  • 

    Hi,

    Based on my research and test, I would suggest you check the DCOM permission firstly.

    Detailed steps as below:

    1. Run Dcomcnfg command.
    2. Expand Component Service – Computers – My computer.
    3. Open the properties of My Computer and select “COM Security” tab.
    4. Under COM Security, click "Edit Limits" for both sections. Give the user you want remote access, remote launch, and remote activation.
    5. Then go to DCOM Config, find "Windows Management Instrumentation", and give the user you want Remote Launch and Remote Activation.

    For more information about troubleshoot WMI connections, you may refer to the following article:

    WMI Troubleshooting

    https://msdn.microsoft.com/en-us/library/aa394603(v=vs.85).aspx


    If there is anything else we can do for you, please feel free to let us know.

    Best Regards,

    William



    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 23, 2017 2:44 AM
  • Hi,

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,
    William

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 24, 2017 8:54 AM
  • Hi,

    Was your issue resolved? 

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,
    William

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 28, 2017 1:27 AM
  • Hi William,

    Thanks for the assistance with this issue. The issue was with the local security policy setting where the user groups was not given any permission in "Access this computer from the network". 

    Once the permission was provided, remote WMI started working

    1.       Click Start and type gpedit.msc in the start search box and press Enter.
    2.       Navigate to the following location
    Computer Configuration/ Windows Settings/ Security Settings/ Local Policies
    3.       Under this click on User Rights Assignment.
    4.       Double click Access this computer from the network and check that EVERYONE is added to the list.
    5.       If not add it by clicking Add User or group and then type EVERYONE, click OK and then Apply and OK.

    Thanks

    Sathish


    Monday, December 4, 2017 5:04 PM
  • Hi,

    Good to hear that you have solved this issue by yourself. In addition, thanks for sharing your solution in the forum as it would be helpful to anyone who encounters similar issues.
    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    William


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 5, 2017 1:42 AM
  • Hi William,

    I'm getting the same error when using a non-administrator account to connect remotely with WBEMtest.

    I have changed security settings in:
    - DCOM settings (has suggested);
    - WMI control: Root\CIMV2

    But i'm able to query with WMIC.

    I'm with this issue since i'm unable to get SSMS to work properly with non-admin account: https://blog.sqlauthority.com/2016/10/19/sql-server-management-studio-seeing-white-icon-instead-green-red/

    Please help me to understand where the issue is.

    Thanks in Advance,
    João


    Thursday, September 6, 2018 3:21 PM