none
ping no se reconoce como comando interno o externo

    Question

  • Buenas tardes, tengo el problema de que no puedo hacer uso del ping desde cmd. Al escribirlo me dice que no se reconoce como comando. Ya estuve revisando y en internet sugieren que revise las variables de entorno en propiedades de <Mi Pc> y todo esta correcto (%systemroot%\system32), si en cmd escribo <c:\windows\system32\ping.exe servidor> el comando funciona correctamente.

    Estoy utilizando WinXp Pro, tengo problemas de impresion en red (solo desde algunos programas) al mandar a imprimir se tarda mucho el trabajo en cola de impresion y el svchost consume mucha memoria (por lo cual el equipo se vuelve lento). Si imprimo desde office el equipo funciona muy bien, no es lento e imprime rapido. Tambien accesar a otro equipo en la lan o navegar por internet funciona sin problemas.

    No se si tenga algun problema de configuracion en la red que me este afectando la velocidad y rendimiento al imprimir desde esos programas en especifico.

    Gracias.

    Thursday, February 08, 2007 7:40 PM

Answers

  • Hola, Mario, entiendo que tienes problemas para ejecutar la herramienta Ping.exe desde la línea de comandos. Si escribes C:\WINDOWS\system32\ping.exe la herramienta se ejecuta adecuadamente.

    Como ya te han comentado, todo apunta a que la variable de entorno Path de tu sistema está incorrectamente definida. Además de las sugerencias que te han dejado los compañeros, debes asegurarte de que el valor de Registro que contiene esa variable de entorno sea de tipo cadena expandible (REG_EXPAND). Echa un vistazo al método 2 de este artículo mío (no hagas caso del título):

    http://www.fermu.com/content/view/384/2/lang,es/

    Saturday, February 10, 2007 4:26 PM

All replies

  • Buenasss...

    Pues tu problema son las variables de entorno

    Seguro que en la variable de sistema path tienes esto?

    C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;

    Si en una ventana de ms-dos escribes path, qué te sale?

    1Saludo

    Thursday, February 08, 2007 8:10 PM
  • Si la ruta del Path está bien puedes probar lo siguiente:

    Puede que esté dañado  el fichero ping.exe prueba a copiarlo de otro equipo y pegarlo en el directorio c:\Windows\System32




    Un saludo y Suerte .
    Thursday, February 08, 2007 9:56 PM
  • Gracias

    Me aparece PATH = C:\IDSE\bin; %Systemroot%\system32; %systemroot%; y otros mas de otros programas. El IDSE y compac si los utilizo.

    Ya tambien probe sobreescribiendo el archivo ping.exe pero sigue igual.

    Saludos

    Thursday, February 08, 2007 10:01 PM
  • Fíjate en estas variables y díme lo que contienen:

    Variable path: Como mínimo te tiene que aparecer esto

    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;

    Variable PATHEXT: Como mínimo te tiene que aparecer esto

    .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH

    Variable ComSpec: Te tiene que aparecer

    %SystemRoot%\system32\cmd.exe

     

     

    Friday, February 09, 2007 2:58 PM
  • Hola, Mario, entiendo que tienes problemas para ejecutar la herramienta Ping.exe desde la línea de comandos. Si escribes C:\WINDOWS\system32\ping.exe la herramienta se ejecuta adecuadamente.

    Como ya te han comentado, todo apunta a que la variable de entorno Path de tu sistema está incorrectamente definida. Además de las sugerencias que te han dejado los compañeros, debes asegurarte de que el valor de Registro que contiene esa variable de entorno sea de tipo cadena expandible (REG_EXPAND). Echa un vistazo al método 2 de este artículo mío (no hagas caso del título):

    http://www.fermu.com/content/view/384/2/lang,es/

    Saturday, February 10, 2007 4:26 PM
  • Hace unos días me pasó lo mismo que a ti. Sucedió que manipulé las variables de entorno por la instalación de un programa y no me di cuenta de que había dejado espacios en blanco entre las rutas.
    De casualidad se me ocurrió eliminar aquellos espacios en blanco, por ejemplo 'c:\windows; c:\windows\system32;' dejando juntos los caracteres ; y c:
    Espero se haya entendido la idea. Ya que al hacer esto se solucionó mi problema y al ejecutar 'ping' desde CMD este funcionó correctamente.
    Thursday, August 28, 2008 2:58 AM
  • SOLUCION!!!! A QUE NO RECONOCE COMANDO EXTERNO O INTERNO:
    MIRA ME PASABA LO MISMO Y HICE ESTO:
    FUI A MI PC LE DI CLICK DERECHO,ENTRE A PROPIEDADES,OPCIONES AVANZADAS,VARIABLES DE ENTORNO Y DONDE DICE VARIABLES DE
    SISTEMA ENTRE EN DONDE DICE PATH Y PUSE AL PRINCIPIO %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;
    OJO HAY QUE PONERLO Y SI ESTA REVISEN SI ESTA BIEN ESCRITO, OK LUEGO DE AHI INTENTE Y NO RESULTO.
    LUEGO CHEQUEO LA VARIABLE PATHEXT, Y REVISO SI TIENE ESTAS EXTENSIONES .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.4mm;.RB;.RBW;
    LAS CUALES SON LAS EXTENSIONES QUE EL SISTEMA PUEDE EJECUTAR, OK LUEGO INTENTO Y NO FUNCIONO , PERO LUEGO ME DOY
    CUENTA QUE ESTAS MISMAS EXTENSIONES SE TENIAN QUE AGREGAR EN PATHEXT PERO EN LAS VARIABLES DE USUARIO EN LAS CUALES ESTAN
    LOCALIZADAS MAS ARRIBA EN LA MISMA VENTANA.
    SOLUCIONADO EL PROBLEMA!!!
    ATT:ENMANUEL MARTINEZ GONZALEZ(REP DOM)
    • Proposed as answer by Bebeneitor Thursday, March 13, 2014 4:08 PM
    Sunday, March 21, 2010 12:26 AM
  • Compadre, solucionaste el problema. Te has ganado mi respeto!!  :D

     

    Podrias compartir como lo descubristeis.

     

    Un Abrazo!!

     

     

    saludos!!

    Friday, April 22, 2011 8:17 AM
  • Gracias brother :D tu respuesta soluciono mi problema , salu2!
    Saturday, February 18, 2012 3:16 AM
  • Gracias..

    De super lujo la ayuda..

    Thursday, March 13, 2014 4:08 PM
  • Gracias compañero era unicamente copiar lo que publicastes para el path darle aceptar y listo. Gracias muy agradecido, que lindo este mundo de la Informatica es super amplio
    Saturday, May 31, 2014 3:28 PM
  • Gracias, problema solucionado. Interesante solución aportada, saludos !
    Tuesday, June 24, 2014 7:19 PM
  • Gracias Man, excelente aportación solucionaste mi problema
    Wednesday, July 09, 2014 12:09 AM
  • Yo tengo el mismo problema y ninguna de sus soluciones me funciono... 

    Wednesday, March 23, 2016 3:27 PM
  • eres un amor de persona gracias!!! :')

    Tuesday, August 09, 2016 12:24 AM
  • Esta es la forma correcta de solucionar el problema, es reparar la variable del entorno.

    Desde la ventana de cmd  colocar :

    path C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;

    
    Monday, October 03, 2016 2:53 PM
  • De lujo amigo!! 

    Se solucionó

    Thursday, February 08, 2018 8:00 PM
  • EXCELENTE!! GRACIAS AMIGO
    Wednesday, May 09, 2018 5:36 PM