locked
standalone mode Without Streaming: UNinstallation of application Removes all other App-V shortcuts RRS feed

  • Question

  • Hi All,

    My environment is Stand-Alone Client Without Streaming

    I am Sequencing the applications for our test environment. I deployed the App-V 4.6 SP1 client using this command Stand-Alone Client Without Streaming

    Setup.exe /s /v"/qn SWICACHESIZE=\"12144\" SWISKIPDATASETTINGS=\"false\" SWIGLOBALDATA=\"C:\AppVirt\Global\" SWIUSERDATA=\"^%APPDATA^%\" SWIFSDRIVE=\"Q:\" REQUIREAUTHORIZATIONIFCACHED=\"0\" ALLOWINDEPENDENTSTREAMING=\"1\" AUTOLOADONLAUNCH=\"0\" AUTOLOADONLOGIN=\"0\" "

    It went pretty well, Now

    I am Generating the msi while sequencing and copying the msi & sft into local machine, installing the msi in quiet mode ( Stand-Alone Client Without Streaming), For that I am using this script 

     @echo off

    if not exist %SystemDrive%\install\Logs\ md %SystemDrive%\install\Logs\
    if not exist %SystemDrive%\install\AppV\ md %SystemDrive%\install\AppV\
    if not exist %SystemDrive%\install\AppV\MozillaFirefox_13_0_1\ md %SystemDrive%\install\AppV\MozillaFirefox_13_0_1\

    xcopy /y /e /q "%~dp0MozillaFirefox_13_0_1.msi" "C:\Install\AppV\MozillaFirefox_13_0_1\" >NUL 2>&1

    xcopy /y /e /q "%~dp0MozillaFirefox_13_0_1.sft" "C:\Install\AppV\MozillaFirefox_13_0_1\" >NUL 2>&1

    "%SystemDrive%\install\AppV\MozillaFirefox_13_0_1\MozillaFirefox_13_0_1.msi" /qb!

    Everything is going well, the application Installed Pretty well and runing

    But the problem is when I am tryng to uninstall this application using this command 

    MsiExec.exe /X {D58E10CD-3AF8-433C-8F36-8E3DA63963A7} /qb!

    Its is uninstalling but, it is also removing the other advertised shortcuts of my App-V applications from the machine and client. When I open the App-V client and selected Applications section all other virtual applications are gone. They are not uninstalled (I checked the Registry Keys) but no shortcuts 

    I opened the Globel cache and checked there, the OSD files of other Virtual Applications are there but no shortcuts 

    Any suggessions?

    Am I installing the applications in stand alone mode correctly?? by copying them to locally?? Any Improvements?? 

    Am I uninstalling the apps correctly by msiexec /x command??

    What I can do better to remove the App-V application with out effecting other virtual applications ??

    How much Cache space do I need to give while Deploying the client forstand alone mode Without Streaming (I gave 12144 MB), because I need to copy all applications locally right??


    Thursday, August 23, 2012 12:09 AM

Answers

  • Hey Aaron, thanks for the suggestion, created a log for uninstillation,  It is not uninstalling other apps but the reason why other apps did not launch was error "Unable to initialize package information (0x00000000)" because in the softgrid client UserInterphase registry path was set up to C:\Windows\system32\CCM\VappLauncher.exe and I changed that to C:\Program Files\Microsoft Application Virtualization Client\sftdde.exe it resolved my issue. 

    Thanks

    Friday, August 24, 2012 3:45 PM

All replies

    • Why aren't you copying the entire MozillaFirefox_13_0_1 folder locally before installing?
    • If you uninstall the package via MSIEXEC and write a log file, does that log file give any indication as to what is being removed?
    • Do your App-V packages happen to have the same GUID?
    • What happens if you use SFTMIME to add and remove packages instead? How to Add a Package by Using the Command Line

    The size of the App-V cache is not related to the delivery method of your packages - size the cache based on the total size of the packages that you'll be delivering to a client.



    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Thursday, August 23, 2012 6:54 AM
    Moderator
  • Hey Aaron, thanks for the suggestion, created a log for uninstillation,  It is not uninstalling other apps but the reason why other apps did not launch was error "Unable to initialize package information (0x00000000)" because in the softgrid client UserInterphase registry path was set up to C:\Windows\system32\CCM\VappLauncher.exe and I changed that to C:\Program Files\Microsoft Application Virtualization Client\sftdde.exe it resolved my issue. 

    Thanks

    Friday, August 24, 2012 3:45 PM