none
"Send As" / "Send on Behalf" not working with Exchange 2013 RRS feed

  • Question

  • I am not able to send an email as a public folder entity even though I have “Send Ad” and “Send on Behalf” permissions.  I am user ‘ntsa’.  Here are screenshots of the public folder config:

    In outlook, when I try to send as the email address of the public folder, I get:

    Any ideas?  I'm pulling my hair out trying to figure this out.


    ~David

    Wednesday, April 17, 2013 12:42 PM

Answers

  • Hello - Thanks for the responses.  We had rebooted the server several times and support@domain.com is not a group, just an alias for a public folder.

    The solution ended up that the public folders and shared mailboxes must be marked to 'show in directory' in order for the send-as to work.  Very weird and uncool but at least it works.


    ~David

    • Marked as answer by David V_ Wednesday, July 10, 2013 7:00 PM
    Wednesday, July 10, 2013 7:00 PM

All replies

  • Hi David,

    How long have you waited? There's normally a 2 hour cache cycle for permissions. You can speed this up two ways,

    1. Is to restart the store in question

    2. You can lower default 2 hour window.

    Oliver


    Oliver Moazzezi | Exchange MVP, MCSA:M, MCITP:Exchange 2010, BA (Hons) Anim | http://www.exchange2010.com | http://www.cobweb.com | http://twitter.com/OliverMoazzezi

    Thursday, April 18, 2013 1:07 PM
  • Several days...

    ~David

    Thursday, April 18, 2013 1:39 PM
  • Restart the Exchange store Service or do a full server restart instead ;)

    Thursday, May 23, 2013 2:48 PM
  • Is support@domain.com is group? Have you tried with the ntsa user?

    Thursday, June 27, 2013 6:14 AM
  • Hello - Thanks for the responses.  We had rebooted the server several times and support@domain.com is not a group, just an alias for a public folder.

    The solution ended up that the public folders and shared mailboxes must be marked to 'show in directory' in order for the send-as to work.  Very weird and uncool but at least it works.


    ~David

    • Marked as answer by David V_ Wednesday, July 10, 2013 7:00 PM
    Wednesday, July 10, 2013 7:00 PM