none
Secondary DPM 2010 Server not showing any protected server RRS feed

  • Question

  • We have a working DPM 2010 machine(dpm01) protecting several servers like sql, exchange and file servers.

    Now we installed a second dpm server(dpm02) to protect the datasources from the first dpm server. From dpm02 we installed the agent to dpm01 without any problems now when we create a new PG on dpm02 and look at the available datasources we have no protected servers listed we get no error mesages.

    I have looked through the forums but could not find a solution for what we are experiencing does anyone have a idea/solution?


    Regards, Alfred
    Tuesday, January 4, 2011 9:45 AM

Answers

  • can you try accessing  \\<primaryDPMName>\mtatempstore$\PSInfo from secondary DPM?

    if this fails then that means you have some problem in DPM folders in primary DPM. you can try to recreate MTAtempStore share on primary DPM by looking @ secondary DPM share. (see run -> compmgmt.msc ->system tools -> shared folders)

    after fixing this share on primary, try secondary protection it will succeed.


    Thanks, NikhilKumar.R [MSFT] - This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, February 10, 2011 3:42 PM

All replies

  • Hi

    The workloads that the primary DPM server is protecting is located under the Primary DPM server / Protected Servers when you create a new protection group.

    If the problem still persists, on the secondary DPM server refresh the agent for the primary DPM server and try again.

     

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Tuesday, January 4, 2011 11:00 AM
    Moderator
  • Hello,

    Thanks for your reply. I refreshed like you suggested but it made no difference. The options i can protect are only All Shares, All SQL Servers, All Volumes and System Protection.


    Regards, Alfred
    Tuesday, January 4, 2011 11:28 AM
  • Hi

    Ok, strange. Anything usefull in the logs? Have you tried to reboot the secondary DPM server and try again? If that doesn't work, try reboot both DPM servers with the Primary DPM server first.



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Tuesday, January 4, 2011 11:59 AM
    Moderator
  • Rebooting did not work i noticed 1 strange event on the primary server when i look on the secundary server what i can protect.

    I cannot explain the message "The network name cannot be found." the servers are on the same subnet a no firewalls are active.

    ----------------------------------- event -------------------------------

    The description for Event ID 997 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    A non-fatal failure instance has been detected for process 'msdpm'. This will be reported to Microsoft.

    Problem Details:

    <FatalServiceError><__System><ID>19</ID><Seq>17882</Seq><TimeCreated>4-1-2011 13:56:51</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>IOException</ExceptionType><ExceptionMessage>The network name cannot be found.

    </ExceptionMessage><ExceptionDetails>System.IO.IOException: The network name cannot be found.

    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

    at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, DirectorySecurity dirSecurity)

    at System.IO.Directory.CreateDirectory(String path, DirectorySecurity directorySecurity)

    at Microsoft.Internal.EnterpriseStorage.Dls.AgentManager.DB.ProtectedPSs.GeneratePSInfoXml(Object obj)</ExceptionDetails></FatalServiceError>

     

    the message resource is present but the message is not found in the string/message table


    Regards, Alfred
    Tuesday, January 4, 2011 2:36 PM
  • can you try accessing  \\<primaryDPMName>\mtatempstore$\PSInfo from secondary DPM?

    if this fails then that means you have some problem in DPM folders in primary DPM. you can try to recreate MTAtempStore share on primary DPM by looking @ secondary DPM share. (see run -> compmgmt.msc ->system tools -> shared folders)

    after fixing this share on primary, try secondary protection it will succeed.


    Thanks, NikhilKumar.R [MSFT] - This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, February 10, 2011 3:42 PM