none
msexchangerepl.exe consume 100% cpu every morning RRS feed

  • Question

  • Hi guys,

    as mentioned in title,every morning about 10AM this process (msexchangerepl.exe) is using 100% cpu and causes all mail functions in the company to stuck.

    I tried many things that people have said online (mostly exchange 2010 users):

    *Disabled AV and all other 3rd party apps

    *Updated the Win server  and Exchange to latest build (CU12)

    Im working on two exchange servers (Active/passive),and only the active one gets high cpu

    i tried to make the passive one active and then he gets the high cpu.

    Im using Win server 2016,with 32 gb of ram and 4 cpu's.

    do you guys have any suggestions about the next step?

    Tuesday, June 4, 2019 11:51 AM

All replies

  • Hi Nisimm,

     

    1.Does this phenomenon just happen on 10 am?

    2.What's the meaning that "Im working on two exchange servers (Active/passive)", DAG?

     

    You could try the following troubleshooting steps:

     

    1.If you have a File-Level Antivirus software installed, make sure that you have the Exchange folders excluded from scanning.

     

    Running Windows antivirus software on Exchange servers

    http://technet.microsoft.com/en-us/library/bb332342.aspx

     

    2.Reboot the Servers.

     

    3.Temporarily Remove database copies on the servers, then restart ms Exchange replication service. If the issue disappears afterward, add the database copies one at a time and see if the issue occurs again.

     

    It's also suggested tha tlooking into the Event Viewer to verify whether there are some related errors or warnings included.

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, June 5, 2019 4:32 AM
  • 1. as mentioned i excluded files as microsoft suggest and it didnt work so i disabled it totally.

    2.i rebooted the server few times since it happend

    3.I should defentily try this.

    Wednesday, June 5, 2019 7:44 AM
  • Hi ,

     

    I am writing here to confirm with you how the thing going now?

     

    If the above suggestion helps, please be free to mark it as an answer for helping more people.

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, June 11, 2019 2:50 AM