none
Perpetual replica is inconsistent issue (DPM 2012 SP1) RRS feed

  • Question

  • We're testing DPM 2012 SP1 with full Server 2012 installs and Windows 8 clients.  However, the problem I'm having now is trying to backup a 2012 server.  I'm using disk storage for the backup.  The disk I'm using is 500GB with 400GB used.  So the disk has another 100GB of space left and all protection groups are set to auto expand.

    One of my protection groups always shows replica is inconsistent.  Here's the protection group:

    Here's the errors:

    Here's my disk:

    (only allowed 2 images) - My disk shows Total Capacity 500GB, Used Space 400.38GB, Unallocated Space 99.61GB

    So if it's out of room I don't understand why it's not expanding (or is that just a general error?).  I've deleted the protection group and reset it up a couple times with no change.  I've also changed the disk allocation manually with no change in the replica error.  I should also note that this DPM 2012 install is an exact mirror to my DPM 2010 setup in production and it has no problem backing up these volumes (same exact data) on an identical 500GB disk.  All my other "server" protection groups work fine.

    I would greatly appreciate any help on this issue!

    Justin

    Wednesday, January 2, 2013 7:57 PM

Answers

  • Instead of trying to increase the space manually...I blew out the PG, set it up again only this time I put in a ridiculous amount from the beginning.  I made it 800GB.  Let it go over night and came in this morning and it's fine.  I went back in and shrunk the volume, did a CC and created an RP and it created it just fine.

    I'm at a loss as well.  But that round about way of creating it seems to have forced it to work.

    • Marked as answer by JEmlay Tuesday, January 8, 2013 1:22 AM
    Friday, January 4, 2013 5:29 PM

All replies

  • Hi,

    DPM will not auto-grow more than once in a 15 minute timeframe. If another alert of the same type for the same datasource was raised and resolved within 15 minutes of the current alert, then auto-grow will fail.

    Manually grow the replica then run a CC.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, January 2, 2013 9:05 PM
    Moderator
  • Thanks for your response!

    This has been going on for over a week.  It's the only alert and, "I've also changed the disk allocation manually with no change in the replica error."  As well as performing a CC (I failed to mention that part).  The error remains.

    Wednesday, January 2, 2013 10:23 PM
  • Can you run this DPM power shell script, and post the output for that particular G:\ data source.

    $DPMservername=&"hostname"
    "Selected DPM server = $DPMservername"
    $PG=get-protectiongroup $DPMServerName
    foreach ($member in $PG)
    {
    $ds=get-datasource $member
    $alloc=Get-DatasourceDiskAllocation $ds
    $alloc|format-list
    }


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, January 2, 2013 10:34 PM
    Moderator
  • Computer                 : STORE1
    Name                     : G:\
    LogicalPath              : G:\
    ObjectType               : Volume
    LatestRecoveryPointLabel : -
    OldestRecoveryPointLabel : -
    TotalRecoveryPointsLabel : 0
    DiskAllocation           : Replica volume: 200.00 GB allocated, 157.83 GB used
                               | Recovery point volume: 6.24 GB allocated, 68.89
                               MB used
    Thursday, January 3, 2013 2:33 AM
  • Hi,

    OK - nothing seeming out oh whack here, we have about 42gb free on the replica, so unless we're trying to bring over a very large file that exceeds that, we should be able to get the replica created.  Do you know then exact size of the protected data source (sum of g:\docs and g:data) that we're trying to bring over ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, January 3, 2013 3:25 AM
    Moderator
  • I calculate 155GB so I'm assuming the above 157.83GB is spot on.
    Thursday, January 3, 2013 6:27 PM
  • Hi,

    Ok - to be honest, I'm at a loss.  Would need to look at DPM logs to figure out why it believes it's out of space on the replica when it appears there is pleanty available.  Try adding the additional 99GB to the replica and see if that at at least works.  Once you determine how much space is required, you can delete it from protection and reprotect it using the required replica size to start. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, January 3, 2013 8:22 PM
    Moderator
  • Instead of trying to increase the space manually...I blew out the PG, set it up again only this time I put in a ridiculous amount from the beginning.  I made it 800GB.  Let it go over night and came in this morning and it's fine.  I went back in and shrunk the volume, did a CC and created an RP and it created it just fine.

    I'm at a loss as well.  But that round about way of creating it seems to have forced it to work.

    • Marked as answer by JEmlay Tuesday, January 8, 2013 1:22 AM
    Friday, January 4, 2013 5:29 PM
  • OK, So when all said and done, what is the used space on the replica now ?  Is it more than the 200GB originally allocated before you started over ?

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, January 4, 2013 9:47 PM
    Moderator
  • 157.91 GB used
    Monday, January 7, 2013 4:56 PM
  • Ok, Thanks - big mystery that will never be solved.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, January 7, 2013 6:29 PM
    Moderator
  • Went back in today and blew it out again then set it up again as per it's normal recommendation (Replica volume: 200.00 GB allocated) and had the same problem.  It remained inconsistent.

    Blew it out yet again, did the ridiculous 800GB.......works fine.

    Tuesday, January 8, 2013 12:31 AM
  • In my Environment I found that enabling the Windows Backup Feature on the Windows 2012 "Clients" made the consistency Problems disappear.

    Tuesday, January 29, 2013 10:34 AM
  • I have the exact same behavior as Justin above and I know the space I need for the replica is below what I'm setting but I also discovered the auto-grow feature to not be working properly.

    Is enabling the Windows Backup feature really a solid fix?  I don't have much to lose to try that I suppose.


    Dave Durand


    Thursday, May 2, 2013 7:48 PM
  • Hi!

    I was the same issue with my DPM 2012 SP1 and Exchange 2013 CU1.

    I've found resultions on this page http://www.compit.se/?p=370

    <QUOTE>

    Install Visual C++ Redistributable for Visual Studio 2012 Update 1 on your DPM 2012 SP1 server. http://www.microsoft.com/en-us/download/details.aspx?id=30679

    Inactivate the alerts and Perform consistency check on the databas.

    </QUOTE>


    Wojciech Sciesinski

    • Proposed as answer by it-praktyk Wednesday, June 5, 2013 6:17 AM
    Wednesday, June 5, 2013 6:09 AM
  • Hi WojciechS

    For exchange 2013 protection and running eseutil.exe for verification, then the above Visual Studio 2012 Update 1 is indeed required, however the error for not having that will not be due to lack of disk space.  So that is not a valid solution for the scenario described above.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, June 5, 2013 2:33 PM
    Moderator
  • Hi!

    Yes, I know that eseutil.exe and ese.dll from Exchange 2013 must be copied to DPM Server for verification.

    I've copied it previously but verification was first time successfully after Visual C++ Redistributable for Visual Studio 2012 Update installation.

    I don't know/understand why but in case case this work! Not a first time with Microsoft products ;-)

    Regards


    Wojciech Sciesinski

    Wednesday, June 5, 2013 3:06 PM
  • I had exact situation. Lot of space, ese, eseutil all there. No backup copy created from Exch 2013 srv, always inconsistency error. Applying Visual C++ Redistributable for Visual Studio 2012 Update - (there is Update Nr 3 available since 25/6/2103) solved the problem. So I vote for Wojciech.

    greg

    Friday, July 12, 2013 11:58 AM
  • Import-Module ServerManager

    If Server 2012 Type “add-windowsfeature windows-server-backup”
    If Server 2008 R2 Type “add-windowsfeature backup”
    Right click on the member in the DPM console and click “Perform consistency check”

    I hope it will work. Best of luck..........Palash

    Tuesday, September 30, 2014 4:55 AM
  • I had the problem of DPM 2016 showing 'Replica inconsistent' on a Windows Server client machine. This problem disappeared after I installed 'Windows Server Backup' feature on the Windows Server client machine (the one that is protected) and ran consistency check again.

    If this is a requirement, why is it not mentioned in the documentation?

    Sunday, August 13, 2017 11:51 AM
  • Hi,

    Only systemstate/BMR protection requires the Windows Server Backup feature to be installed on the protected server.   See https://docs.microsoft.com/en-us/system-center/dpm/back-up-system-state-and-bare-metal#prerequisites-and-limitations


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, August 21, 2017 4:56 PM
    Moderator