locked
WMIC - remote installation RRS feed

  • Question

  • Hi all,
    I’m trying to remotely install MSI program through WMIC but I’m having some difficulties.
    This is what I’m running:
    "wmic:root\cli>/node:192.168.1.10  /user:domainname\username product call install true,"" , "c:\themsi.msi"
    its working fine on my computer but I get this error while running it on a remote one:
    192.168.1.10 - Invalid node (discarded)"

    then it asks for my password and then show this error:

    "ERROR:
    Code = 0x800706ba
    Description = The RPC server is unavailable.
    Facility = Win32"

    And that’s it.
    Can anyone please help me? Is it my firewall?
    Sunday, November 29, 2009 1:18 PM

Answers

  • This problem occurs when the client computer that is running Windows XP releases the remote COM+ object. Approximately 20 seconds to 30 seconds after the client computer releases the remote COM+ object, the RPC ports that were used by DCOM on the server are closed. If the network is disconnected immediately after the client computer releases the remote COM+ object, the RPC ports that were used by DCOM on the server remain open for several hours. This can lead to port exhaustion. Future requests from the client computer to the remote COM+ object fail.

    This is corrected with a hotfix from microsoft...see below and let me know if this works.

    http://support.microsoft.com/default.aspx/kb/935677
    BrianM - MCSE,MCSA,MCTS,A+,NET+,SEC+ Toronto, On.
    • Marked as answer by Kevin Remde Monday, December 14, 2009 1:03 PM
    Saturday, December 12, 2009 3:31 AM