locked
Can not initiate Public Folder Migration from Ex10 to Ex13 RRS feed

  • Question

  • Hey,

    I followed official migration documentation and pre-created .csv file and Public Folder mailboxes on Ex13 side. After I initiate New-PublicFolderMigrationRecuest (command line also form documentation) I received following error:

    Couldn't connect to the target mailbox.
        + CategoryInfo          : NotSpecified: (:) [New-PublicFolderMigrationRequest], RemoteTransientException
        + FullyQualifiedErrorId : [Server=SERVER,RequestId=2cb57218-5814-40ec-b25f-4cc1dbe3662d,TimeStamp=8/25/2013 4:06:
       55 PM] AC30D5DA,Microsoft.Exchange.Management.RecipientTasks.NewPublicFolderMigrationRequest
        + PSComputerName        : SERVER.domain

    Any ideas for to fix it?


    Regards, Mindaugas Laucius

    Sunday, August 25, 2013 4:12 PM

All replies

  • Many blogs out there have examples of "Mailbox1", 'Mailbox2" as a target Public Folder mailbox names on Ex13.

    Perhaps this is some sort of default name and migrations only possible into MailboxX? Should not be the case, but just a thought. What do you think?


    Regards, Mindaugas Laucius

    Wednesday, August 28, 2013 1:04 AM
  • Mindaugas,

    There are some ways that you can get more detailed information that would help troubleshooting the issue:

    1. Use the -Verbose switch when you create the request so that we know at which step of the process we are when the cmdlet fails

    2. Look at the $error variable. Supposing that the migration cmdlet is the last one you ran, $error[0] will contain the full exception stack. It's going to be either under $error[0].Exception or $error[0].SerializedRemoteException. Invoking a .ToString() in either one of these should provide the full call stack.

    Some extra verifications that you can do:

    * Make sure you didn't have any public folder mailboxes when you created the first public folder mailbox with -HoldForMigration switch.

    * Make sure you allow time for the newly created mailboxes have their corresponding Active Directory entries replicated throughout all the Domain Controllers. Specifying a DC in the command line won't help here because the migration cmdlet creates a task that Migration Service will process later. While you can force a DC for the cmdlet to run against, there is no guarantee that Migration will use the same DC when it processes your request.

    * Finally, double check that your source server is accessible from the destination server.

    Please let us know if it works nor not.

    Tuesday, September 10, 2013 6:38 PM
  • Hey All,

    Has a solution been found for this?  I have the same issue.  I've deleted and recreated the 2013 PF mailboxes multiple times, cleared all migration holds, and searched high and low for answers.  When I run with -verbose it seems to search for all mailboxes, then goes to "Processing object". 

    "The call to <server.com> timed out.  Error Details:: The operation did not complete within the allotted timeout of 50 seconds".

    I'm running from the 2013 server, so it is very odd to me that it would not be able to see itself.

    Please help if possible.

    • Edited by ChiTy Monday, September 30, 2013 9:55 PM
    Monday, September 30, 2013 9:54 PM
  • we are having the same problem. Microsoft???? 
    Friday, October 25, 2013 6:44 PM
  • I had a case open with Microsoft support. They admitted it is a bug. It will be fixed in CU3. No interim update is available...

    Regards, Mindaugas Laucius

    Sunday, October 27, 2013 3:06 AM
  • OK, after weeks of waiting we've installed CU3 hoping that it will resolve the issue. but nothing has changed. Any more advise from Microsoft? Anyone?
    Thursday, November 28, 2013 6:39 PM
  • I quite sure, that Mindaugus followed exactly the same guide, like all others, since this is the only official guide for this process.

    And i'm sure noone want to pay 3rd party just for that Microsoft didn't tested their products and processes good enought.

    We have now a case with Microsoft open as well. I will post you on our findings.

    Friday, November 29, 2013 1:16 PM
  • Hello Vladimir,

    I must correct myself a little bit. The issue I explained in this topic was solved by cleaning up source public folders (on Exchange 2010). I had public folders with "\" in the name, some other special characters, etc.

    The issue I had after clean up was related to the permissions. By migration job successfully transferred ~70gb of data into target public folder mailboxes and was looping with following error:

    9/4/2013 5:16:58 PM [server] Connected to source mailbox '', database 'PD01',
    Mailbox server ‘server.hosting.local' Version 14.3 (Build 158.0).
    9/4/2013 5:17:00 PM [server] Request processing continued, stage LoadingMessages.
    9/4/2013 5:17:15 PM [server] Copying messages is finished. Copying rules and
    security descriptors.
    9/4/2013 6:02:52 PM [dc1-em1] Transient error CommunicationErrorTransientException
    has occurred. The system will retry (1/60). ---
    9/5/2013 12:35:51 AM [server] Copying messages is finished. Copying rules and
    security descriptors.
    9/5/2013 1:20:16 AM [server] Transient error CommunicationErrorTransientException
    has occurred. The system will retry (11/60).

    This was identified as a bug and I was promised by Microsoft that it will be fixed in CU3.

    I applied the CU3 in my environment and initiated Public folder migration job moments ago. It should be running for few days. I'll post the results here.

    I would recommend cleaning up the existing public folders and please make sure your .csv files are correct, small typo might result in error I initially mention in this topic.

    Sorry for confusion..


    Regards, Mindaugas Laucius

    Friday, November 29, 2013 6:50 PM
  • Thank you a lot for bringing more light to the topic, since i see there are more people suffering from similar troubles, but in all cases i found no specific description or resolution described.

    I has checked from the beggining that \ is not present in any of the names, as it is stated in migration guide, but what other special characters were causing the problem on your experience?

    And just to clarify details more preciselly, so, unless you replaced those characters, the migration process woudn't start AT ALL, with the initially posted error, is this correct? 

    Friday, November 29, 2013 7:33 PM
  • Hey,

    I have for example "`" character in the name of Public folder. Other than this make sure that all the target Public Folder mailboxes exists. double check migration .csv. This helped me to pass that initial issue..


    Regards, Mindaugas Laucius

    • Proposed as answer by Vladimir Usov Friday, January 10, 2014 8:24 PM
    • Unproposed as answer by Vladimir Usov Friday, January 10, 2014 8:24 PM
    Sunday, December 1, 2013 2:16 PM
  • For those who it might help.

    Our issue was that the migration CSV cannot contains more then 64 mailboxes. 

    As soon as you have Mailbox65, the migration process will simply not start at all, I has specifically tested this when we finally identified the reason.

    Weird that even Microsoft support didn't awaire/noticed about this problem.


    Friday, January 10, 2014 8:26 PM